Autor Thema: [ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)  (Gelesen 12542 mal)

Offline JoWiemann

  • Tester
  • Hero Member
  • ****
  • Beiträge: 3199
Antw:Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #15 am: 08 Oktober 2019, 22:43:44 »
Hilft Dir jetzt nicht weiter, aber vor Änderungen der Berechtigungen: Einstellungen speichern.

Grüße Jörg
Jörg Wiemann

Slave: RPi B+ mit 512 MB, COC (868 MHz), CUL V3 (433.92MHz SlowRF); FHEMduino, Aktuelles FHEM

Master: CubieTruck; Debian; Aktuelles FHEM

Offline D3ltorohd

  • Full Member
  • ***
  • Beiträge: 487
Antw:Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #16 am: 09 Oktober 2019, 07:51:20 »
Ich weiß, hätte ich machen sollen. Weiß auch gar nicht warum ich von der Box kein Backup habe. Sonst von allem.

Aber dennoch etwas schwach von AVM finde ich. Da hätten Sicherheitsmechanismen greifen müssen um sowas zu verhindern. Keine Push Benachrichtigung eingerichtet, erst einrichten. Oder kein Benutzer für Einstellungen berechtigt, min. Bei einem Benutzer setzten. Irgendwie sowas.

Kann ich denn irgendwie noch das phonebook inkl das interne für gesperrte Anrufer exportieren oder speichern. Im call Monitor Modul gibt es doch was mit phonebook.
Base : Intel NUC Debian 9, FHEM aktuell || Zigbee (Coordinator FW Z-Stack 1.2 default Koenkk) || MaxCUL (culfw V 1.67 nanoCUL868) || SIGNALduino 433MHz (V 3.3.2.1-rc8 ) || Shelly s1

Offline frank

  • Hero Member
  • *****
  • Beiträge: 10557
Antw:Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #17 am: 09 Oktober 2019, 08:36:52 »
vielleicht kannst du dich nach reboot wieder anmelden.
FHEM: 6.0(SVN) => Pi3(buster)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [HMdeviceTools.js (hm.js)]: https://forum.fhem.de/index.php/topic,106959.0.html

Offline D3ltorohd

  • Full Member
  • ***
  • Beiträge: 487
Antw:Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #18 am: 11 Oktober 2019, 17:54:24 »
Sooooo, alles wieder iO, Box läuft, eingerichtet und auch das Modul scheint jetzt zu laufen...

Hier noch mal danke an alle die mitgeholfen haben !!
Base : Intel NUC Debian 9, FHEM aktuell || Zigbee (Coordinator FW Z-Stack 1.2 default Koenkk) || MaxCUL (culfw V 1.67 nanoCUL868) || SIGNALduino 433MHz (V 3.3.2.1-rc8 ) || Shelly s1

Offline TRallala

  • Jr. Member
  • **
  • Beiträge: 52
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #19 am: 30 Oktober 2019, 10:05:32 »
Stand bis eben vor demselben Problem "Didn't get a Session ID" und wollte nur kurz irgendwo dokumentieren was bei mir half:

Ausgangslage:
- FritzBox 7590  FW v.7.01
- Login NUR per Passwort
- Definition laut wiki  "define FritzBox FRITZBOX"
- telnet (überflüssigerweise) installiert
- Fritzbox  per ping über fritz.box   erreichbar
- passwort gesetzt
- attr allowTR064Command=1 gesetzt

Trotzdem keine Daten und im Log:

FRITZBOX FritzBox: Web_OpenCon.4529 Web connection could not be established. Please check your credentials (password, user).
FRITZBOX FritzBox: Readout_Run_Web.1376 Error: Didn't get a session ID


Dannach alles mögliche versucht: Fhem Update/Neustart, Device gelöscht und neu angelegt. PW geändert, Fritzbox neu gestartet...usw.


Am Ende brachte ein

Zitat
defmod FritzBox FRITZBOX 192.168.x.x

die Lösung. Obwohl DNS funkionierte.

Das nur für alle die über diesem Fred stolpern.

Gruß
Markus

Offline D3ltorohd

  • Full Member
  • ***
  • Beiträge: 487
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #20 am: 30 Oktober 2019, 14:10:04 »
Brauchst du nicht auch einen User dafür, der die benötigte Berechtigung in der Box hat ? Hast du das ganz ohne User hinbekommen ?
Base : Intel NUC Debian 9, FHEM aktuell || Zigbee (Coordinator FW Z-Stack 1.2 default Koenkk) || MaxCUL (culfw V 1.67 nanoCUL868) || SIGNALduino 433MHz (V 3.3.2.1-rc8 ) || Shelly s1

Offline TRallala

  • Jr. Member
  • **
  • Beiträge: 52
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #21 am: 30 Oktober 2019, 14:16:56 »
korrekt. ohne User.
Momentan verarbeite ich aber auch erstmal nur die Readings.
Keine Ahnung ob die Box auch Befehle annimmt. 

Gibts da was, was ich "einfach" mal testen kann?

Offline Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19696
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #22 am: 30 Oktober 2019, 16:17:35 »
eventuell nimmt das Modul per default den ftpuser
Versuch doch mal Fb Neustart :)
https://forum.fhem.de/index.php/topic,70064.msg920069.html#msg920069
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline ch.eick

  • Hero Member
  • *****
  • Beiträge: 2006
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #23 am: 24 Mai 2021, 18:49:57 »
Hallo zusammen,
dies ist zwar ein alter Thread, jedoch passt der Inhalt sehr gut hier zu.

Nach dem aktuellen Fritzbox update auf 7.27 meiner 7490 funktionierte die Anmeldung nicht mehr.
2021.05.24 16:32:59.648 4: FRITZBOX ZentrumRouter: Readout_Start.718 Fork process FRITZBOX_Readout_Run_Web
2021.05.24 16:32:59.810 4: FRITZBOX ZentrumRouter: Readout_Run_Web.1302 Prepare query string for luaQuery.
2021.05.24 16:32:59.814 5: FRITZBOX ZentrumRouter: readPassword.4737 Read FritzBox password from file
2021.05.24 16:32:59.826 4: FRITZBOX ZentrumRouter: Web_OpenCon.4521 Open Web connection to 192.168.178.1
2021.05.24 16:33:00.647 2: FRITZBOX ZentrumRouter: Web_OpenCon.4529 Web connection could not be established. Please check your credentials (password, user).
2021.05.24 16:33:00.648 2: FRITZBOX ZentrumRouter: Readout_Run_Web.1376 Error: Didn't get a session ID
2021.05.24 16:33:00.687 4: FRITZBOX ZentrumRouter: Readout_Done.1770 Back at main process
2021.05.24 16:33:00.689 4: FRITZBOX ZentrumRouter: Readout_Process.1792 Processing 2 readouts.
2021.05.24 16:33:00.691 4: FRITZBOX ZentrumRouter: Readout_Process.1801 Reset SID

Es scheint nun obligatorisch zu sein, dass man einen Benutzernamen angeben muss.
Mein Login über das Web Interface ist weiterhin nur mit Passwort, jedoch musste ich im FRITZBOX Modul nun erstmalig das entsprechende Attribut setzen.
attr <Fritzbox> boxUser <Username>
Der Username kann über die Web Oberfläche abgefragt werden
System | Fritz!Box Benutzer | Benutzer
==> fritz[nnnn]   , das ist der automatisch angelegte Benuter.

Getestet habe ich auf zwei 7490 und bei beiden klappt es wieder.
AVM hat die Version 7.27 auch für weitere Fritzboxen angekündigt, jedoch steht das Update wohl noch nicht bereit.

VG
   Christian
RPI4; Docker; CUNX; Eltako FSB61NP; 230V zentral verschaltet; SamsungTV H-Serie; DLNARenderer; TV.pl;  Sonos; Vallox; Luxtronik; 2x FB7490; Stromzähler mit DvLIR; wunderground; clever-tanken; Plenticore 10 mit BYD; EM410; SMAEM; Modbus TCP
Gefällt mir Gefällt mir x 6 Liste anzeigen

Offline is2late

  • Full Member
  • ***
  • Beiträge: 422
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #24 am: 27 Mai 2021, 16:44:57 »
Vielen Dank, Christian!

Ich wusste gar nicht, dass ich ein Problem hatte, bis ich deinen Beitrag las  ;)
Lösung passt prima.


LG Ingo
« Letzte Änderung: 27 Mai 2021, 16:58:12 von is2late »
Pi4, Tahoma Jalousien, Hue, Echo, Sonos, Lupusec XT3, FritzBox
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline ch.eick

  • Hero Member
  • *****
  • Beiträge: 2006
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #25 am: 27 Mai 2021, 17:07:10 »
Ich wusste gar nicht, dass ich ein Problem hatte, bis ich deinen Beitrag las  ;)
Lösung passt prima.
Hallo Ingo :-) :-)
Das sind doch die schönsten Probleme ;-)

Gruß
    Christian
RPI4; Docker; CUNX; Eltako FSB61NP; 230V zentral verschaltet; SamsungTV H-Serie; DLNARenderer; TV.pl;  Sonos; Vallox; Luxtronik; 2x FB7490; Stromzähler mit DvLIR; wunderground; clever-tanken; Plenticore 10 mit BYD; EM410; SMAEM; Modbus TCP
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline mkraus81

  • Jr. Member
  • **
  • Beiträge: 93
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #26 am: 09 Juni 2021, 17:47:26 »
ooh gut das es hier stand... gerade neue Handy eingerichtet und das PRESENCE-Device angepasst... und dann hä... warum geht das nicht
dann sehe ich die "Session Id Meldung"... auf die Idee mit dem Benutzer währe ich vermutlich erst gekommen, wenn ich alles neu eingerichtet hätte...
DANKE
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline ch.eick

  • Hero Member
  • *****
  • Beiträge: 2006
Antw:[ERLEDIGT] Didn't get a Session ID Meldung (FRITZBOX Modul)
« Antwort #27 am: 09 Juni 2021, 18:30:23 »
ooh gut das es hier stand... gerade neue Handy eingerichtet und das PRESENCE-Device angepasst... und dann hä... warum geht das nicht
dann sehe ich die "Session Id Meldung"... auf die Idee mit dem Benutzer währe ich vermutlich erst gekommen, wenn ich alles neu eingerichtet hätte...
DANKE
gerne :-)
RPI4; Docker; CUNX; Eltako FSB61NP; 230V zentral verschaltet; SamsungTV H-Serie; DLNARenderer; TV.pl;  Sonos; Vallox; Luxtronik; 2x FB7490; Stromzähler mit DvLIR; wunderground; clever-tanken; Plenticore 10 mit BYD; EM410; SMAEM; Modbus TCP
Gefällt mir Gefällt mir x 1 Liste anzeigen