Autor Thema: Neues Modul: Signalbot (Integration für den Signal Messenger) via signal-cli  (Gelesen 38428 mal)

Offline enno

  • Sr. Member
  • ****
  • Beiträge: 763
Moin Jörg,

ich habe eine VM mit FHEM gestartet. Dann meine Festnetznummer (habe ich im Log gelöscht) registriert. Ich habe aber keinen Anruf bekommen, der mir die SMS vorliest. Hier mal das Log:
root@Test:~# sh signal.sh
This script will help you to install signal-cli as system dbus service
and prepare the use of the FHEM Signalbot module

Please verify that these settigns are correct:
Signal-cli User:              fhem
Signal-cli Install directory: /opt/fhem
Signal config storage:        /var/lib/fhem
Signal version:               0.7.4
System library path:          /usr/lib
Phone number to be used:      +49yyyyyy
Your configuration
Linux Test 5.4.78-2-pve #1 SMP PVE 5.4.78-2 (Thu, 03 Dec 2020 14:26:17 +0100) x86_64 x86_64 x86_64 GNU/Linux
has not been tested, continue at own risk
This will update system packages, install signal-cli and help to register with Signal service

To do this rather step by step use the command line arguments or just proceed to do system,install,register:
system   : prepare required system package (except signal-cli) - make sure you ran this before you do anything else!
install  : install signal-cli and setup as dbus system service
register : register a NEW number with Signal
link     : link an EXISTING number with Signal (e.g. you Smartphone)
test     : run a basic test if everything is installed and registered correctly
remove   : Remove signal-cli and all configurations
join     : Join current number to an existing group (invite by group link)

!!! Everything needs to run with sudo !!!

Proceed (Y/n)? signal.sh: 432: read: arg count
Checking for /usr/lib...found
Checking for /etc/dbus-1/system.d...found
Checking for /usr/share/dbus-1/system-services...found
Checking for /etc/systemd/system...found
Checking for wget...available
Checking for haveged...installing (haveged)done
Checking for java...installing (default-jre)done
Checking for diff...available
Checking for dbus-send...available
Checking for cpan...available
Checking for qrencode...installing (qrencode)done
Checking for pkg-config...installing (pkg-config)done
Checking for dbus devel...installingdone
Checking for Net:DBus...Can't locate Net/DBus.pm in @INC (you may need to install the Net::DBus module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.30.3 /usr/local/share/perl/5.30.3 /usr/lib/x86_64-linux-gnu/perl5/5.30 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl-base /usr/lib/x86_64-linux-gnu/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl) at /tmp/signal400.tmp line 5.
BEGIN failed--compilation aborted at /tmp/signal400.tmp line 5.
Installing latest NET::DBus...done
Checking user fhem ...found
Checking for /opt/fhem...found
Checking for /var/lib/fhem...created
Checking for existing signal-cli installation...not found
Proceed with signal cli installation
Downloading signal-cli 0.7.4...uid=998(fhem) gid=20(dialout) groups=20(dialout)
done
Unpacking ...
done
Changing file ownership ...done
Checking for /etc/dbus-1/system.d/org.asamk.Signal.conf.../etc/dbus-1/system.d/org.asamk.Signal.conf installed
Checking for /usr/share/dbus-1/system-services/org.asamk.Signal.service.../usr/share/dbus-1/system-services/org.asamk.Signal.service installed
Checking for /etc/systemd/system/signal.service.../etc/systemd/system/signal.service installed
Created symlink /etc/systemd/system/dbus-org.asamk.Signal.service -> /etc/systemd/system/signal.service.
Registering for +49yyyy

Receive registration code for +49yyyyyyyyyy by (S)MS or (V)oice (s/v)? signal.sh: 331: read: arg count
Unknown option , exiting

Die Registrierung hat erst mal nicht geklappt.

Gruss
  Enno
Einfacher FHEM Anwender auf Intel®NUC

Offline Adimarantis

  • Developer
  • Full Member
  • ****
  • Beiträge: 442
Hi Enno,

Danke. Deine Shell verhält sich etwas anders. In der Hauptsache hat er deine Eingabe nicht erkannt.
Update im ersten Post.
Mich besorgt mehr die Net::DBus installation (erstmal irrelevant für die Registrierung)
ist das ein logfile /tmp/signal_install.log - dann hätte ich das gerne.

Jörg

Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , (50_SPI_MAX31865)

Offline enno

  • Sr. Member
  • ****
  • Beiträge: 763
ok, mit der neuen Version fragt das Script schon mal. Ich kann eingeben, alles läuft durch, allerdings noch kein Anruf mit dem Code. Daher habe ich an der Postion an der ich den Code eingeben müsste abgebrochen. Hier das /tmp/signal_install.log

Loading internal logger. Log::Log4perl recommended for better logging
Reading '/root/.cpan/Metadata'
  Database was generated on Wed, 03 Feb 2021 08:17:03 GMT
Running install for module 'Net::DBus'
Checksum for /root/.cpan/sources/authors/id/D/DA/DANBERR/Net-DBus-1.2.0.tar.gz ok
'YAML' not installed, will not store persistent state
Configuring D/DA/DANBERR/Net-DBus-1.2.0.tar.gz with Makefile.PL
Warning: prerequisite Test::CPAN::Changes 0 not found.
Warning: prerequisite Test::Pod 0 not found.
Warning: prerequisite Test::Pod::Coverage 0 not found.
Warning: prerequisite XML::Twig 0 not found.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Net::DBus
Writing MYMETA.yml and MYMETA.json
  DANBERR/Net-DBus-1.2.0.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for D/DA/DANBERR/Net-DBus-1.2.0.tar.gz
---- Unsatisfied dependencies detected during ----
----       DANBERR/Net-DBus-1.2.0.tar.gz      ----
    Test::CPAN::Changes [requires]
    Test::Pod [requires]
    Test::Pod::Coverage [requires]
    XML::Twig [requires]
Running install for module 'Test::CPAN::Changes'
2BChecksum for /root/.cpan/sources/authors/id/H/HA/HAARG/CPAN-Changes-0.400002.tar.gz ok
Configuring H/HA/HAARG/CPAN-Changes-0.400002.tar.gz with Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for CPAN::Changes
Writing MYMETA.yml and MYMETA.json
  HAARG/CPAN-Changes-0.400002.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for H/HA/HAARG/CPAN-Changes-0.400002.tar.gz
  HAARG/CPAN-Changes-0.400002.tar.gz
  make -- NOT OK
  No such file or directory
Running install for module 'Test::Pod'
Checksum for /root/.cpan/sources/authors/id/E/ET/ETHER/Test-Pod-1.52.tar.gz ok
Configuring E/ET/ETHER/Test-Pod-1.52.tar.gz with Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Test::Pod
Writing MYMETA.yml and MYMETA.json
  ETHER/Test-Pod-1.52.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for E/ET/ETHER/Test-Pod-1.52.tar.gz
  ETHER/Test-Pod-1.52.tar.gz
  make -- NOT OK
  No such file or directory
Running install for module 'Test::Pod::Coverage'
Checksum for /root/.cpan/sources/authors/id/N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz ok
Configuring N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz with Makefile.PL
Warning: prerequisite Pod::Coverage 0 not found.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Test::Pod::Coverage
Writing MYMETA.yml and MYMETA.json
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz
---- Unsatisfied dependencies detected during ----
----    NEILB/Test-Pod-Coverage-1.10.tar.gz   ----
    Pod::Coverage [requires]
Running install for module 'Pod::Coverage'
Checksum for /root/.cpan/sources/authors/id/R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz ok
Configuring R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz with Makefile.PL
Warning: prerequisite Devel::Symdump 2.01 not found.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Pod::Coverage
Writing MYMETA.yml and MYMETA.json
  RCLAMP/Pod-Coverage-0.23.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz
---- Unsatisfied dependencies detected during ----
----      RCLAMP/Pod-Coverage-0.23.tar.gz     ----
    Devel::Symdump [requires]
Running install for module 'Devel::Symdump'
Checksum for /root/.cpan/sources/authors/id/A/AN/ANDK/Devel-Symdump-2.18.tar.gz ok
Configuring A/AN/ANDK/Devel-Symdump-2.18.tar.gz with Makefile.PL
Require Devel::Symdump from the local tarball.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Devel::Symdump
Writing MYMETA.yml and MYMETA.json
  ANDK/Devel-Symdump-2.18.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for A/AN/ANDK/Devel-Symdump-2.18.tar.gz
  ANDK/Devel-Symdump-2.18.tar.gz
  make -- NOT OK
  No such file or directory
  RCLAMP/Pod-Coverage-0.23.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/Pod-Coverage-0.23-5
  RCLAMP/Pod-Coverage-0.23.tar.gz
  Has already been prepared
Running make for R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz
Warning: Prerequisite 'Devel::Symdump => 2.01' for 'RCLAMP/Pod-Coverage-0.23.tar.gz' failed when processing 'ANDK/Devel-Symdump-2.18.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
  RCLAMP/Pod-Coverage-0.23.tar.gz
  make -- NOT OK
  No such file or directory
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/Test-Pod-Coverage-1.10-5
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  Has already been prepared
Running make for N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz
Warning: Prerequisite 'Pod::Coverage => 0' for 'NEILB/Test-Pod-Coverage-1.10.tar.gz' failed when processing 'RCLAMP/Pod-Coverage-0.23.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  make -- NOT OK
  No such file or directory
Running install for module 'XML::Twig'
Checksum for /root/.cpan/sources/authors/id/M/MI/MIROD/XML-Twig-3.52.tar.gz ok
Configuring M/MI/MIROD/XML-Twig-3.52.tar.gz with Makefile.PL
Warning: prerequisite XML::Parser 2.23 not found.
Checking if your kit is complete...
Looks good
updated prereqs in META.json
Generating a Unix-style Makefile
Writing Makefile for XML::Twig
Writing MYMETA.yml and MYMETA.json
  MIROD/XML-Twig-3.52.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for M/MI/MIROD/XML-Twig-3.52.tar.gz
---- Unsatisfied dependencies detected during ----
----        MIROD/XML-Twig-3.52.tar.gz        ----
    XML::Parser [requires]
Running install for module 'XML::Parser'
Checksum for /root/.cpan/sources/authors/id/T/TO/TODDR/XML-Parser-2.46.tar.gz ok
Configuring T/TO/TODDR/XML-Parser-2.46.tar.gz with Makefile.PL
Couldn't find your C compiler
Compilation failed in require at Makefile.PL line 4.
BEGIN failed--compilation aborted at Makefile.PL line 4.
Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site]
  TODDR/XML-Parser-2.46.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
  MIROD/XML-Twig-3.52.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/XML-Twig-3.52-5
  MIROD/XML-Twig-3.52.tar.gz
  Has already been prepared
Running make for M/MI/MIROD/XML-Twig-3.52.tar.gz
Warning: Prerequisite 'XML::Parser => 2.23' for 'MIROD/XML-Twig-3.52.tar.gz' failed when processing 'TODDR/XML-Parser-2.46.tar.gz' with 'writemakefile => NO '/usr/bin/perl Makefile.PL INSTALLDIRS=site' returned status 512'. Continuing, but chances to succeed are limited.
  MIROD/XML-Twig-3.52.tar.gz
  make -- NOT OK
  No such file or directory
  DANBERR/Net-DBus-1.2.0.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/Net-DBus-1.2.0-5
  DANBERR/Net-DBus-1.2.0.tar.gz
  Has already been prepared
Running make for D/DA/DANBERR/Net-DBus-1.2.0.tar.gz
Warning: Prerequisite 'Test::CPAN::Changes => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'HAARG/CPAN-Changes-0.400002.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'Test::Pod => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'ETHER/Test-Pod-1.52.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'Test::Pod::Coverage => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'NEILB/Test-Pod-Coverage-1.10.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'XML::Twig => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'MIROD/XML-Twig-3.52.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
  DANBERR/Net-DBus-1.2.0.tar.gz
  make -- NOT OK

Gruss
  Enno
Einfacher FHEM Anwender auf Intel®NUC

Offline Adimarantis

  • Developer
  • Full Member
  • ****
  • Beiträge: 442
Hi Enno,

ok, auf die schnelle sehe ich schon mal, das er sich beschwert, dass kein C-Compiler auf dem system ist. Kannst du mal einen nachinstallieren (gcc?)? (sollte ich dann wohl mit in die dependencies einbauen).
Wie ist die Bildschirmausgabe bei der Registrierung?

Jörg
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , (50_SPI_MAX31865)

Offline enno

  • Sr. Member
  • ****
  • Beiträge: 763
ok apt install gcc dann noch mal gestartet. Hier die Ausgabe in der Konsole. Der Anruf mit dem Code fehlt immernoch. root@Test:~# sh signal.sh
signal.sh: 19: source: not found
This script will help you to install signal-cli as system dbus service
and prepare the use of the FHEM Signalbot module

Please verify that these settigns are correct:
Signal-cli User:              fhem
Signal-cli Install directory: /opt/fhem
Signal config storage:        /var/lib/fhem
Signal version:               0.7.4
System library path:          /usr/lib
Phone number to be used:      +49yyyyy
Your configuration
Linux Test 5.4.78-2-pve #1 SMP PVE 5.4.78-2 (Thu, 03 Dec 2020 14:26:17 +0100) x86_64 x86_64 x86_64 GNU/Linux
has not been tested, continue at own risk
This will update system packages, install signal-cli and help to register with Signal service

To do this rather step by step use the command line arguments or just proceed to do system,install,register:
system   : prepare required system package (except signal-cli) - make sure you ran this before you do anything else!
install  : install signal-cli and setup as dbus system service
register : register a NEW number with Signal
link     : link an EXISTING number with Signal (e.g. you Smartphone)
test     : run a basic test if everything is installed and registered correctly
remove   : Remove signal-cli and all configurations
join     : Join current number to an existing group (invite by group link)

!!! Everything needs to run with sudo !!!

Proceed (Y/n)? y
Checking for /usr/lib...found
Checking for /etc/dbus-1/system.d...found
Checking for /usr/share/dbus-1/system-services...found
Checking for /etc/systemd/system...found
Checking for wget...available
Checking for haveged...available
Checking for java...available
Checking for diff...available
Checking for dbus-send...available
Checking for cpan...available
Checking for qrencode...available
Checking for pkg-config...available
Checking for dbus devel...available
Checking for Net:DBus...Can't locate Net/DBus.pm in @INC (you may need to install the Net::DBus module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.30.3 /usr/local/share/perl/5.30.3 /usr/lib/x86_64-linux-gnu/perl5/5.30 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl-base /usr/lib/x86_64-linux-gnu/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl) at /tmp/signal4358.tmp line 5.
BEGIN failed--compilation aborted at /tmp/signal4358.tmp line 5.
Installing latest NET::DBus...done
Checking user fhem ...found
Checking for /opt/fhem...found
Checking for /var/lib/fhem...found
Checking for existing signal-cli installation...found
Checking signal-cli version...uid=998(fhem) gid=20(dialout) groups=20(dialout)
signal-cli 0.7.4
signal.sh: 208: [: signal-cli 0.7.4: unexpected operator
Update to current version (y/N)? y
Proceed with signal cli installation
Downloading signal-cli 0.7.4...done
Unpacking ...
done
Changing file ownership ...done
Checking for /etc/dbus-1/system.d/org.asamk.Signal.conf...found
Checking for /usr/share/dbus-1/system-services/org.asamk.Signal.service...found
Checking for /etc/systemd/system/signal.service...found
Registering for +49yyyyyy

Receive registration code for +49yyyyy by (S)MS or (V)oice (s/v)? v
Registering +4951170035840 with Voice call
Stopping Signal service to get exclusive access to configuration
Captcha invalid or required for verification (null)
You should get a call or SMS now providing a 6 digit code
Enter this code here:
und hier das Log:
Loading internal logger. Log::Log4perl recommended for better logging
Reading '/root/.cpan/Metadata'
  Database was generated on Wed, 03 Feb 2021 08:17:03 GMT
Running install for module 'Net::DBus'
Checksum for /root/.cpan/sources/authors/id/D/DA/DANBERR/Net-DBus-1.2.0.tar.gz ok
'YAML' not installed, will not store persistent state
Configuring D/DA/DANBERR/Net-DBus-1.2.0.tar.gz with Makefile.PL
Warning: prerequisite Test::CPAN::Changes 0 not found.
Warning: prerequisite Test::Pod 0 not found.
Warning: prerequisite Test::Pod::Coverage 0 not found.
Warning: prerequisite XML::Twig 0 not found.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Net::DBus
Writing MYMETA.yml and MYMETA.json
  DANBERR/Net-DBus-1.2.0.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for D/DA/DANBERR/Net-DBus-1.2.0.tar.gz
---- Unsatisfied dependencies detected during ----
----       DANBERR/Net-DBus-1.2.0.tar.gz      ----
    Test::CPAN::Changes [requires]
    Test::Pod [requires]
    Test::Pod::Coverage [requires]
    XML::Twig [requires]
Running install for module 'Test::CPAN::Changes'
Checksum for /root/.cpan/sources/authors/id/H/HA/HAARG/CPAN-Changes-0.400002.tar.gz ok
Configuring H/HA/HAARG/CPAN-Changes-0.400002.tar.gz with Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for CPAN::Changes
Writing MYMETA.yml and MYMETA.json
  HAARG/CPAN-Changes-0.400002.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for H/HA/HAARG/CPAN-Changes-0.400002.tar.gz
  HAARG/CPAN-Changes-0.400002.tar.gz
  make -- NOT OK
  No such file or directory
Running install for module 'Test::Pod'
Checksum for /root/.cpan/sources/authors/id/E/ET/ETHER/Test-Pod-1.52.tar.gz ok
Configuring E/ET/ETHER/Test-Pod-1.52.tar.gz with Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Test::Pod
Writing MYMETA.yml and MYMETA.json
  ETHER/Test-Pod-1.52.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for E/ET/ETHER/Test-Pod-1.52.tar.gz
  ETHER/Test-Pod-1.52.tar.gz
  make -- NOT OK
  No such file or directory
Running install for module 'Test::Pod::Coverage'
Checksum for /root/.cpan/sources/authors/id/N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz ok
Configuring N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz with Makefile.PL
Warning: prerequisite Pod::Coverage 0 not found.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Test::Pod::Coverage
Writing MYMETA.yml and MYMETA.json
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz
---- Unsatisfied dependencies detected during ----
----    NEILB/Test-Pod-Coverage-1.10.tar.gz   ----
    Pod::Coverage [requires]
Running install for module 'Pod::Coverage'
Checksum for /root/.cpan/sources/authors/id/R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz ok
Configuring R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz with Makefile.PL
Warning: prerequisite Devel::Symdump 2.01 not found.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Pod::Coverage
Writing MYMETA.yml and MYMETA.json
  RCLAMP/Pod-Coverage-0.23.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz
---- Unsatisfied dependencies detected during ----
----      RCLAMP/Pod-Coverage-0.23.tar.gz     ----
    Devel::Symdump [requires]
Running install for module 'Devel::Symdump'
Checksum for /root/.cpan/sources/authors/id/A/AN/ANDK/Devel-Symdump-2.18.tar.gz ok
Configuring A/AN/ANDK/Devel-Symdump-2.18.tar.gz with Makefile.PL
Require Devel::Symdump from the local tarball.
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Devel::Symdump
Writing MYMETA.yml and MYMETA.json
  ANDK/Devel-Symdump-2.18.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for A/AN/ANDK/Devel-Symdump-2.18.tar.gz
  ANDK/Devel-Symdump-2.18.tar.gz
  make -- NOT OK
  No such file or directory
  RCLAMP/Pod-Coverage-0.23.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/Pod-Coverage-0.23-2
  RCLAMP/Pod-Coverage-0.23.tar.gz
  Has already been prepared
Running make for R/RC/RCLAMP/Pod-Coverage-0.23.tar.gz
Warning: Prerequisite 'Devel::Symdump => 2.01' for 'RCLAMP/Pod-Coverage-0.23.tar.gz' failed when processing 'ANDK/Devel-Symdump-2.18.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
  RCLAMP/Pod-Coverage-0.23.tar.gz
  make -- NOT OK
  No such file or directory
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/Test-Pod-Coverage-1.10-2
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  Has already been prepared
Running make for N/NE/NEILB/Test-Pod-Coverage-1.10.tar.gz
Warning: Prerequisite 'Pod::Coverage => 0' for 'NEILB/Test-Pod-Coverage-1.10.tar.gz' failed when processing 'RCLAMP/Pod-Coverage-0.23.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
  NEILB/Test-Pod-Coverage-1.10.tar.gz
  make -- NOT OK
  No such file or directory
Running install for module 'XML::Twig'
Checksum for /root/.cpan/sources/authors/id/M/MI/MIROD/XML-Twig-3.52.tar.gz ok
Configuring M/MI/MIROD/XML-Twig-3.52.tar.gz with Makefile.PL
Warning: prerequisite XML::Parser 2.23 not found.
Checking if your kit is complete...
Looks good
updated prereqs in META.json
Generating a Unix-style Makefile
Writing Makefile for XML::Twig
Writing MYMETA.yml and MYMETA.json
  MIROD/XML-Twig-3.52.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for M/MI/MIROD/XML-Twig-3.52.tar.gz
---- Unsatisfied dependencies detected during ----
----        MIROD/XML-Twig-3.52.tar.gz        ----
    XML::Parser [requires]
Running install for module 'XML::Parser'
Checksum for /root/.cpan/sources/authors/id/T/TO/TODDR/XML-Parser-2.46.tar.gz ok
Configuring T/TO/TODDR/XML-Parser-2.46.tar.gz with Makefile.PL

Expat must be installed prior to building XML::Parser and I can't find
it in the standard library directories. Install 'expat-devel' (or
'libexpat1-dev') package with your OS package manager. See 'README'.

Or you can download expat from:

http://sourceforge.net/projects/expat/

If expat is installed, but in a non-standard directory, then use the
following options to Makefile.PL:

    EXPATLIBPATH=...  To set the directory in which to find libexpat

    EXPATINCPATH=...  To set the directory in which to find expat.h

For example:

    perl Makefile.PL EXPATLIBPATH=/home/me/lib EXPATINCPATH=/home/me/include

Note that if you build against a shareable library in a non-standard location
you may (on some platforms) also have to set your LD_LIBRARY_PATH environment
variable at run time for perl to find the library.

No 'Makefile' created  TODDR/XML-Parser-2.46.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
  MIROD/XML-Twig-3.52.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/XML-Twig-3.52-2
  MIROD/XML-Twig-3.52.tar.gz
  Has already been prepared
Running make for M/MI/MIROD/XML-Twig-3.52.tar.gz
Warning: Prerequisite 'XML::Parser => 2.23' for 'MIROD/XML-Twig-3.52.tar.gz' failed when processing 'TODDR/XML-Parser-2.46.tar.gz' with 'writemakefile => NO -- No 'Makefile' created
'. Continuing, but chances to succeed are limited.
  MIROD/XML-Twig-3.52.tar.gz
  make -- NOT OK
  No such file or directory
  DANBERR/Net-DBus-1.2.0.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/Net-DBus-1.2.0-2
  DANBERR/Net-DBus-1.2.0.tar.gz
  Has already been prepared
Running make for D/DA/DANBERR/Net-DBus-1.2.0.tar.gz
Warning: Prerequisite 'Test::CPAN::Changes => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'HAARG/CPAN-Changes-0.400002.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'Test::Pod => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'ETHER/Test-Pod-1.52.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'Test::Pod::Coverage => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'NEILB/Test-Pod-Coverage-1.10.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'XML::Twig => 0' for 'DANBERR/Net-DBus-1.2.0.tar.gz' failed when processing 'MIROD/XML-Twig-3.52.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
  DANBERR/Net-DBus-1.2.0.tar.gz
  make -- NOT OK
  No such file or directory
Einfacher FHEM Anwender auf Intel®NUC

Offline Adimarantis

  • Developer
  • Full Member
  • ****
  • Beiträge: 442
Danke Enno.
Das Net::DBus Problem muss ich mir nach der Arbeit mal in Ruhe anschauen.
Zur Registrierung:
Anscheinend verlangt Signal bei dir ein Captcha - könnte an der VM liegen, oder daran, dass du evtl. ein VPN benutzt (oder einfach Zufall).
Im aktuellen signal-cli Entwicklungsbaum gibt es einen Patch der es ermöglicht Captchas zu übergeben. Leider nicht in der aktuelle 0.7.4 Release - d.h. hier ist erstmal Sackgasse, außer du schaffst es durch Änderungen an deinem Netzwerk zu verhindern, dass Signal ein Captcha will.

Aber immerhin wissen wir jetzt das es sowas gibt und ich kann gleich mal schauen das ich das abfange, eine Info dazu gebe und die Lösung mit der nächsten signal-cli Version unterstütze.

Gruß,
Jörg

Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , (50_SPI_MAX31865)

Offline Adimarantis

  • Developer
  • Full Member
  • ****
  • Beiträge: 442
Enno, noch was:
Es sieht so aus, als wäre dein System ziemlich "nackt" was Pakete angeht. Daher schlägt wahrscheinlich auch das DBus install fehl.
Kannst du mal folgendes machen:
apt list --installed >installed.txtund die Datei installed.txt anhängen.
Außerdem bitte noch die Ausgabe von
cat /etc/os-release
Danke,
Jörg
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , (50_SPI_MAX31865)

Offline Jamo

  • Hero Member
  • *****
  • Beiträge: 1423
Hallo Joerg,
bei der Installation von Net:DBus bekomme ich folgende meldung, hier der gesamte log. Muss ich irgendwas setzten?
user@inuc:/opt/fhem/FHEM$ sudo cpan install -f Net:DBus
Loading internal logger. Log::Log4perl recommended for better logging
Reading '/root/.cpan/Metadata'
  Database was generated on Wed, 03 Feb 2021 11:29:03 GMT
Running install for module 'Net::DBus'
Checksum for /root/.cpan/sources/authors/id/D/DA/DANBERR/Net-DBus-1.2.0.tar.gz ok
'YAML' not installed, will not store persistent state
Configuring D/DA/DANBERR/Net-DBus-1.2.0.tar.gz with Makefile.PL
cannot run pkg-config to check dbus version at Makefile.PL line 8.
Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site]
  DANBERR/Net-DBus-1.2.0.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
user@inuc:/opt/fhem/FHEM$
cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
« Letzte Änderung: 03 Februar 2021, 13:21:11 von Jamo »
Linux Debian, Homematic (UART/HMUSB), HUEBridge, Zigbee, FB, Alexa (fhem-lazy), livetracking, fhemApp Frontend für FHEM

Offline BAfH

  • Jr. Member
  • **
  • Beiträge: 60
Danke, für das neue Modul.
Ich versuche auch schon länger den Signal-cli zum laufen zu bekomme.
Jetzt setze ich auf Dein Modul.
Ich nutzen einen Pi 3 mit Docker mein Testsystem, Produktion ist auf einen Pi4 4GB

Auszug von cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
VERSION_CODENAME=stretch
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

Datei mit den installierten Paketen ist angehangen.

Was ich nur installiert habe, Java 11
wget https://download.bell-sw.com/java/11.0.10+9/bellsoft-jdk11.0.10+9-linux-arm32-vfp-hflt.deb \
sudo apt-get install -qqy --no-install-recommends ./bellsoft-jdk11.0.10+9-linux-arm32-vfp-hflt.deb \
sudo apt-get install systemd

Script Start

Checking for /usr/lib...found
Checking for /etc/dbus-1/system.d...found
Checking for /usr/share/dbus-1/system-services...found
Checking for /etc/systemd/system...found
Checking for wget...available
Checking for haveged...available
Checking for java...available
Checking for diff...available
Checking for dbus-send...available
Checking for cpan...available
Checking for qrencode...available
Checking for pkg-config...available
Checking for dbus devel...available
Checking for Net:DBus...Can't locate Net/DBus.pm in @INC (you may need to install the Net::DBus module) (@INC contains: /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/arm-linux-gnueabihf/perl5/5.24 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base) at /tmp/signal16303.tmp line 5.
BEGIN failed--compilation aborted at /tmp/signal16303.tmp line 5.
Installing latest NET::DBus...done
Checking user signal-cli ...found
Checking for /opt...found
Checking for /var/lib/signal-cli...found
Checking for existing signal-cli installation...found
Checking signal-cli version...signal-cli 0.7.4
signal-cli matches target version...ok
Checking for /etc/dbus-1/system.d/org.asamk.Signal.conf...found
Checking for /usr/share/dbus-1/system-services/org.asamk.Signal.service...found
Checking for /etc/systemd/system/signal.service...found
Failed to connect to bus: No such file or directory
Created symlink /etc/systemd/system/dbus-org.asamk.Signal.service → /etc/systemd/system/signal.service.
Failed to connect to bus: No such file or directory
Registering for +49xxxx

Receive registration code for +493xxxxx by (S)MS or (V)oice (s/v)? v
Registering +493xxxxx  with Voice call
Stopping Signal service to get exclusive access to configuration
signal: unrecognized service
OpenJDK 32-Bit Server VM warning: You have loaded library /tmp/resource17469578394760016723.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
WARN App - WARNING: Support for new group V2 is disabled, because the required native library dependency is missing: libzkgroup
Captcha invalid or required for verification (null)
You should get a call or SMS now providing a 6 digit code
Enter this code here:

Das war es, kein Anruf oder sonstiges.

Mich wundert diese Fehlermeldung  Captcha invalid or required for verification (null)

Hast Du eine Idee?

Danke
« Letzte Änderung: 29 Juli 2021, 10:47:22 von BAfH »
Gruß Thorben
mit sonnige Grüße aus Schönow

Offline enno

  • Sr. Member
  • ****
  • Beiträge: 763
apt list --installed >installed.txt
Listing...
accountsservice/groovy-updates,groovy-security,now 0.6.55-0ubuntu13.2 amd64 [installed]
adduser/groovy,now 3.118ubuntu2 all [installed]
alsa-topology-conf/groovy,now 1.2.3-1 all [installed,automatic]
alsa-ucm-conf/groovy-updates,now 1.2.2-1ubuntu5.1 all [installed,automatic]
anacron/groovy,now 2.3-29 amd64 [installed,automatic]
apparmor/groovy,now 3.0.0-0ubuntu1 amd64 [installed]
apt-utils/groovy-updates,now 2.1.10ubuntu0.2 amd64 [installed]
apt/groovy-updates,now 2.1.10ubuntu0.2 amd64 [installed]
at-spi2-core/groovy,now 2.38.0-2 amd64 [installed,automatic]
base-files/groovy,now 11ubuntu14 amd64 [installed]
base-passwd/groovy,now 3.5.47 amd64 [installed]
bash-completion/groovy,now 1:2.11-2ubuntu1 all [installed]
bash/groovy,now 5.0-6ubuntu2 amd64 [installed]
bind9-dnsutils/groovy,now 1:9.16.6-3ubuntu1 amd64 [installed]
bind9-host/groovy,now 1:9.16.6-3ubuntu1 amd64 [installed]
bind9-libs/groovy,now 1:9.16.6-3ubuntu1 amd64 [installed]
binutils-common/groovy,now 2.35.1-1ubuntu1 amd64 [installed,automatic]
binutils-x86-64-linux-gnu/groovy,now 2.35.1-1ubuntu1 amd64 [installed,automatic]
binutils/groovy,now 2.35.1-1ubuntu1 amd64 [installed,automatic]
bsdextrautils/groovy,now 2.36-3ubuntu1 amd64 [installed]
bsdutils/groovy,now 1:2.36-3ubuntu1 amd64 [installed]
busybox-static/groovy-updates,now 1:1.30.1-4ubuntu9.1 amd64 [installed]
bzip2/groovy,now 1.0.8-4ubuntu2 amd64 [installed]
ca-certificates-java/groovy,now 20190405ubuntu1 all [installed,automatic]
ca-certificates/groovy-updates,groovy-security,now 20210119~20.10.1 all [installed]
command-not-found/groovy,now 20.10.1 all [installed]
console-setup-linux/groovy,now 1.195ubuntu2 all [installed]
console-setup/groovy,now 1.195ubuntu2 all [installed]
coreutils/groovy,now 8.32-3ubuntu1 amd64 [installed]
cpio/groovy,now 2.13+dfsg-3 amd64 [installed]
cpp-10/groovy,now 10.2.0-13ubuntu1 amd64 [installed]
cpp/groovy,now 4:10.2.0-1ubuntu1 amd64 [installed]
cron/groovy,now 3.0pl1-136ubuntu1 amd64 [installed]
dash/groovy,now 0.5.10.2-7 amd64 [installed]
dbus/groovy,now 1.12.20-1ubuntu1 amd64 [installed]
debconf-i18n/groovy,now 1.5.74 all [installed]
debconf/groovy,now 1.5.74 all [installed]
debianutils/groovy,now 4.11.2 amd64 [installed]
default-jre-headless/groovy,now 2:1.11-72 amd64 [installed,automatic]
default-jre/groovy,now 2:1.11-72 amd64 [installed]
diffutils/groovy,now 1:3.7-3ubuntu1 amd64 [installed]
dirmngr/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
distro-info-data/groovy-updates,groovy-security,now 0.44ubuntu1.3 all [installed]
dmidecode/groovy,now 3.2-3 amd64 [installed]
dmsetup/groovy,now 2:1.02.167-1ubuntu3 amd64 [installed]
dosfstools/groovy,now 4.1-2build1 amd64 [installed]
dpkg/groovy,now 1.20.5ubuntu2 amd64 [installed]
e2fsprogs/groovy,now 1.45.6-1ubuntu1 amd64 [installed]
ed/groovy,now 1.16-1 amd64 [installed]
eject/groovy,now 2.36-3ubuntu1 amd64 [installed]
fhem/now 6.0.23659 all [installed,local]
file/groovy,now 1:5.38-5 amd64 [installed]
findutils/groovy,now 4.7.0-1ubuntu2 amd64 [installed]
fontconfig-config/groovy,now 2.13.1-2ubuntu3 all [installed]
fonts-dejavu-core/groovy,now 2.37-2 all [installed]
fonts-dejavu-extra/groovy,now 2.37-2 all [installed,automatic]
friendly-recovery/groovy,now 0.2.41 all [installed]
ftp/groovy,now 0.17-34.1.1 amd64 [installed]
fuse/groovy,now 2.9.9-3 amd64 [installed]
gcc-10-base/groovy,now 10.2.0-13ubuntu1 amd64 [installed]
gcc-10/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
gcc/groovy,now 4:10.2.0-1ubuntu1 amd64 [installed]
gettext-base/groovy,now 0.19.8.1-10build1 amd64 [installed]
gir1.2-glib-2.0/groovy,now 1.66.1-1 amd64 [installed]
gnupg-l10n/groovy-updates,now 2.2.20-1ubuntu1.1 all [installed,automatic]
gnupg-utils/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gnupg/groovy-updates,now 2.2.20-1ubuntu1.1 all [installed]
gpg-agent/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gpg-wks-client/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gpg-wks-server/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gpg/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gpgconf/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gpgsm/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed,automatic]
gpgv/groovy-updates,now 2.2.20-1ubuntu1.1 amd64 [installed]
grep/groovy,now 3.4-1 amd64 [installed]
groff-base/groovy,now 1.22.4-5 amd64 [installed]
gzip/groovy-updates,now 1.10-2ubuntu1.1 amd64 [installed]
haveged/groovy,now 1.9.8-4ubuntu3 amd64 [installed]
hdparm/groovy,now 9.58+ds-5 amd64 [installed]
hostname/groovy,now 3.23 amd64 [installed]
info/groovy,now 6.7.0.dfsg.2-5 amd64 [installed]
init-system-helpers/groovy,now 1.58 all [installed]
init/groovy,now 1.58 amd64 [installed]
install-info/groovy,now 6.7.0.dfsg.2-5 amd64 [installed]
ipmiutil/groovy,now 3.1.6-1 amd64 [installed]
iproute2/groovy,now 5.7.0-1ubuntu1 amd64 [installed]
iptables/groovy-updates,now 1.8.5-3ubuntu2.20.10.2 amd64 [installed]
iputils-ping/groovy,now 3:20200821-2 amd64 [installed]
iputils-tracepath/groovy,now 3:20200821-2 amd64 [installed]
irqbalance/groovy,now 1.7.0-1 amd64 [installed]
isc-dhcp-client/groovy,now 4.4.1-2.1ubuntu9 amd64 [installed]
isc-dhcp-common/groovy,now 4.4.1-2.1ubuntu9 amd64 [installed]
iso-codes/groovy,now 4.5.0-1 all [installed]
java-common/groovy,now 0.72 all [installed,automatic]
kbd/groovy,now 2.0.4-4ubuntu4 amd64 [installed]
keyboard-configuration/groovy,now 1.195ubuntu2 all [installed]
kmod/groovy,now 27+20200310-2ubuntu1 amd64 [installed]
language-selector-common/groovy,now 0.211 all [installed]
less/groovy,now 551-2 amd64 [installed]
libaccountsservice0/groovy-updates,groovy-security,now 0.6.55-0ubuntu13.2 amd64 [installed]
libacl1/groovy,now 2.2.53-8 amd64 [installed]
libalgorithm-diff-perl/groovy,now 1.19.03-2 all [installed,automatic]
libalgorithm-diff-xs-perl/groovy,now 0.04-6 amd64 [installed,automatic]
libapparmor1/groovy,now 3.0.0-0ubuntu1 amd64 [installed]
libapt-pkg6.0/groovy-updates,now 2.1.10ubuntu0.2 amd64 [installed]
libargon2-1/groovy,now 0~20171227-0.2build20.10.0 amd64 [installed]
libasan6/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libasn1-8-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libasound2-data/groovy-updates,now 1.2.3.2-1ubuntu3.1 all [installed,automatic]
libasound2/groovy-updates,now 1.2.3.2-1ubuntu3.1 amd64 [installed,automatic]
libassuan0/groovy,now 2.5.3-7.1 amd64 [installed,automatic]
libatk-bridge2.0-0/groovy,now 2.38.0-1 amd64 [installed,automatic]
libatk-wrapper-java-jni/groovy,now 0.38.0-1 amd64 [installed,automatic]
libatk-wrapper-java/groovy,now 0.38.0-1 all [installed,automatic]
libatk1.0-0/groovy,now 2.36.0-0ubuntu1 amd64 [installed,automatic]
libatk1.0-data/groovy,now 2.36.0-0ubuntu1 all [installed,automatic]
libatm1/groovy,now 1:2.5.1-4 amd64 [installed]
libatomic1/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libatspi2.0-0/groovy,now 2.38.0-2 amd64 [installed,automatic]
libattr1/groovy,now 1:2.4.48-5 amd64 [installed]
libaudit-common/groovy,now 1:2.8.5-3ubuntu1 all [installed]
libaudit1/groovy,now 1:2.8.5-3ubuntu1 amd64 [installed]
libauthen-sasl-perl/groovy,now 2.1600-1 all [installed,automatic]
libavahi-client3/groovy,now 0.8-3ubuntu1 amd64 [installed,automatic]
libavahi-common-data/groovy,now 0.8-3ubuntu1 amd64 [installed,automatic]
libavahi-common3/groovy,now 0.8-3ubuntu1 amd64 [installed,automatic]
libbinutils/groovy,now 2.35.1-1ubuntu1 amd64 [installed,automatic]
libblkid1/groovy,now 2.36-3ubuntu1 amd64 [installed]
libbrotli1/groovy,now 1.0.9-2 amd64 [installed]
libbsd0/groovy,now 0.10.0-1 amd64 [installed]
libbz2-1.0/groovy,now 1.0.8-4ubuntu2 amd64 [installed]
libc-bin/groovy,now 2.32-0ubuntu3 amd64 [installed]
libc-dev-bin/groovy,now 2.32-0ubuntu3 amd64 [installed,automatic]
libc6-dev/groovy,now 2.32-0ubuntu3 amd64 [installed,automatic]
libc6/groovy,now 2.32-0ubuntu3 amd64 [installed]
libcap-ng0/groovy,now 0.7.9-2.2 amd64 [installed]
libcap2-bin/groovy,now 1:2.43-1 amd64 [installed]
libcap2/groovy,now 1:2.43-1 amd64 [installed]
libcbor0.6/groovy,now 0.6.0-0ubuntu3 amd64 [installed]
libcc1-0/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libcgi-fast-perl/groovy,now 1:2.15-1 all [installed,automatic]
libcgi-pm-perl/groovy,now 4.50-1 all [installed,automatic]
libclone-perl/groovy,now 0.45-1 amd64 [installed,automatic]
libcom-err2/groovy,now 1.45.6-1ubuntu1 amd64 [installed]
libcommon-sense-perl/groovy,now 3.75-1build2 amd64 [installed,automatic]
libcrypt-dev/groovy,now 1:4.4.16-1ubuntu1 amd64 [installed,automatic]
libcrypt1/groovy,now 1:4.4.16-1ubuntu1 amd64 [installed]
libcryptsetup12/groovy,now 2:2.3.3-1ubuntu6 amd64 [installed]
libctf-nobfd0/groovy,now 2.35.1-1ubuntu1 amd64 [installed,automatic]
libctf0/groovy,now 2.35.1-1ubuntu1 amd64 [installed,automatic]
libcups2/groovy,now 2.3.3-3ubuntu1 amd64 [installed,automatic]
libdata-dump-perl/groovy,now 1.23-1 all [installed,automatic]
libdb5.3/groovy,now 5.3.28+dfsg1-0.6ubuntu3 amd64 [installed]
libdbd-sqlite3-perl/groovy,now 1.66-1 amd64 [installed,automatic]
libdbi-perl/groovy,now 1.643-2 amd64 [installed,automatic]
libdbus-1-3/groovy,now 1.12.20-1ubuntu1 amd64 [installed]
libdbus-1-dev/groovy,now 1.12.20-1ubuntu1 amd64 [installed]
libdebconfclient0/groovy,now 0.252ubuntu1 amd64 [installed]
libdevice-serialport-perl/groovy,now 1.04-3build6 amd64 [installed,automatic]
libdevmapper1.02.1/groovy,now 2:1.02.167-1ubuntu3 amd64 [installed]
libdns-export1110/groovy,now 1:9.11.19+dfsg-1ubuntu1 amd64 [installed]
libdpkg-perl/groovy,now 1.20.5ubuntu2 all [installed,automatic]
libdrm-amdgpu1/groovy,now 2.4.102-1ubuntu1 amd64 [installed]
libdrm-common/groovy,now 2.4.102-1ubuntu1 all [installed]
libdrm-intel1/groovy,now 2.4.102-1ubuntu1 amd64 [installed]
libdrm-nouveau2/groovy,now 2.4.102-1ubuntu1 amd64 [installed]
libdrm-radeon1/groovy,now 2.4.102-1ubuntu1 amd64 [installed]
libdrm2/groovy,now 2.4.102-1ubuntu1 amd64 [installed]
libedit2/groovy,now 3.1-20191231-1 amd64 [installed]
libelf1/groovy-updates,now 0.181-1ubuntu0.1 amd64 [installed]
libencode-locale-perl/groovy,now 1.05-1 all [installed,automatic]
libestr0/groovy,now 0.1.10-2.1build1 amd64 [installed]
libexpat1/groovy,now 2.2.9-1build1 amd64 [installed]
libext2fs2/groovy,now 1.45.6-1ubuntu1 amd64 [installed]
libfastjson4/groovy,now 0.99.8-2build1 amd64 [installed]
libfcgi-perl/groovy,now 0.79-1 amd64 [installed,automatic]
libffi8ubuntu1/groovy,now 3.4~20200819gead65ca871-0ubuntu3 amd64 [installed]
libfido2-1/groovy,now 1.4.0-2 amd64 [installed]
libfile-fcntllock-perl/groovy,now 0.22-3build4 amd64 [installed,automatic]
libfile-listing-perl/groovy,now 6.04-1 all [installed,automatic]
libfont-afm-perl/groovy,now 1.20-2 all [installed,automatic]
libfontconfig1/groovy,now 2.13.1-2ubuntu3 amd64 [installed]
libfontenc1/groovy,now 1:1.1.4-1 amd64 [installed]
libfreetype6/groovy-updates,groovy-security,now 2.10.2+dfsg-3ubuntu1 amd64 [installed]
libfribidi0/groovy,now 1.0.8-2 amd64 [installed]
libfuse2/groovy,now 2.9.9-3 amd64 [installed]
libgcc-10-dev/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libgcc-s1/groovy,now 10.2.0-13ubuntu1 amd64 [installed]
libgcrypt20/groovy,now 1.8.5-5ubuntu2 amd64 [installed]
libgdbm-compat4/groovy,now 1.18.1-5.1 amd64 [installed,automatic]
libgdbm6/groovy,now 1.18.1-5.1 amd64 [installed]
libgif7/groovy,now 5.1.9-1 amd64 [installed,automatic]
libgirepository-1.0-1/groovy,now 1.66.1-1 amd64 [installed]
libgl1-mesa-dri/groovy-updates,now 20.2.6-0ubuntu0.20.10.1 amd64 [installed]
libgl1/groovy,now 1.3.2-1 amd64 [installed]
libglapi-mesa/groovy-updates,now 20.2.6-0ubuntu0.20.10.1 amd64 [installed]
libglib2.0-0/groovy,now 2.66.1-2 amd64 [installed]
libglib2.0-data/groovy,now 2.66.1-2 all [installed]
libglvnd0/groovy,now 1.3.2-1 amd64 [installed]
libglx-mesa0/groovy-updates,now 20.2.6-0ubuntu0.20.10.1 amd64 [installed]
libglx0/groovy,now 1.3.2-1 amd64 [installed]
libgmp10/groovy,now 2:6.2.0+dfsg-6ubuntu1 amd64 [installed]
libgnutls30/groovy,now 3.6.15-4ubuntu2 amd64 [installed]
libgomp1/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libgpg-error0/groovy,now 1.38-2 amd64 [installed]
libgssapi-krb5-2/groovy-updates,groovy-security,now 1.17-10ubuntu0.1 amd64 [installed]
libgssapi3-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libhavege2/groovy,now 1.9.8-4ubuntu3 amd64 [installed,automatic]
libhcrypto4-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libheimbase1-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libheimntlm0-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libhogweed6/groovy,now 3.6-2 amd64 [installed]
libhtml-form-perl/groovy,now 6.07-1 all [installed,automatic]
libhtml-format-perl/groovy,now 2.12-1 all [installed,automatic]
libhtml-parser-perl/groovy,now 3.73-1 amd64 [installed,automatic]
libhtml-tagset-perl/groovy,now 3.20-4 all [installed,automatic]
libhtml-tree-perl/groovy,now 5.07-2 all [installed,automatic]
libhttp-cookies-perl/groovy,now 6.08-1 all [installed,automatic]
libhttp-daemon-perl/groovy,now 6.12-1 all [installed,automatic]
libhttp-date-perl/groovy,now 6.05-1 all [installed,automatic]
libhttp-message-perl/groovy,now 6.25-1 all [installed,automatic]
libhttp-negotiate-perl/groovy,now 6.01-1 all [installed,automatic]
libhx509-5-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libice6/groovy,now 2:1.0.10-1 amd64 [installed]
libicu67/groovy,now 67.1-4 amd64 [installed]
libidn2-0/groovy,now 2.3.0-1 amd64 [installed]
libio-html-perl/groovy,now 1.001-1 all [installed,automatic]
libio-socket-ssl-perl/groovy,now 2.067-1 all [installed,automatic]
libip4tc2/groovy-updates,now 1.8.5-3ubuntu2.20.10.2 amd64 [installed]
libip6tc2/groovy-updates,now 1.8.5-3ubuntu2.20.10.2 amd64 [installed]
libisc-export1105/groovy,now 1:9.11.19+dfsg-1ubuntu1 amd64 [installed]
libisl22/groovy,now 0.22.1-1 amd64 [installed]
libitm1/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libjpeg-turbo8/groovy,now 2.0.3-0ubuntu2 amd64 [installed,automatic]
libjpeg8/groovy,now 8c-2ubuntu8 amd64 [installed,automatic]
libjson-c5/groovy,now 0.15-1 amd64 [installed]
libjson-perl/groovy,now 4.02000-2 all [installed,automatic]
libjson-xs-perl/groovy,now 4.020-1build1 amd64 [installed,automatic]
libk5crypto3/groovy-updates,groovy-security,now 1.17-10ubuntu0.1 amd64 [installed]
libkeyutils1/groovy,now 1.6.1-2ubuntu1 amd64 [installed]
libkmod2/groovy,now 27+20200310-2ubuntu1 amd64 [installed]
libkrb5-26-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libkrb5-3/groovy-updates,groovy-security,now 1.17-10ubuntu0.1 amd64 [installed]
libkrb5support0/groovy-updates,groovy-security,now 1.17-10ubuntu0.1 amd64 [installed]
libksba8/groovy,now 1.4.0-2 amd64 [installed,automatic]
liblcms2-2/groovy,now 2.9-4 amd64 [installed,automatic]
libldap-2.4-2/groovy-updates,groovy-security,now 2.4.53+dfsg-1ubuntu1.2 amd64 [installed,automatic]
libldap-common/groovy-updates,groovy-security,now 2.4.53+dfsg-1ubuntu1.2 all [installed,automatic]
libllvm11/groovy,now 1:11.0.0-2 amd64 [installed]
liblmdb0/groovy,now 0.9.24-1 amd64 [installed]
liblocale-gettext-perl/groovy,now 1.07-4 amd64 [installed]
liblsan0/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
liblwp-mediatypes-perl/groovy,now 6.04-1 all [installed,automatic]
liblwp-protocol-https-perl/groovy,now 6.09-1 all [installed,automatic]
liblz4-1/groovy,now 1.9.2-2 amd64 [installed]
liblzma5/groovy,now 5.2.4-1ubuntu1 amd64 [installed]
libmagic-mgc/groovy,now 1:5.38-5 amd64 [installed]
libmagic1/groovy,now 1:5.38-5 amd64 [installed]
libmailtools-perl/groovy,now 2.21-1 all [installed,automatic]
libmaxminddb0/groovy-updates,groovy-security,now 1.4.2-0ubuntu1.20.10.1 amd64 [installed]
libmnl0/groovy,now 1.0.4-3 amd64 [installed]
libmount1/groovy,now 2.36-3ubuntu1 amd64 [installed]
libmpc3/groovy,now 1.2.0~rc1-1 amd64 [installed]
libmpfr6/groovy,now 4.1.0-3 amd64 [installed]
libncurses6/groovy,now 6.2-1 amd64 [installed]
libncursesw6/groovy,now 6.2-1 amd64 [installed]
libnet-http-perl/groovy,now 6.19-1 all [installed,automatic]
libnet-smtp-ssl-perl/groovy,now 1.04-1 all [installed,automatic]
libnet-ssleay-perl/groovy,now 1.88-2ubuntu1 amd64 [installed,automatic]
libnetfilter-conntrack3/groovy,now 1.0.8-1 amd64 [installed]
libnetplan0/groovy-updates,now 0.101-0ubuntu3~20.10.1 amd64 [installed]
libnettle8/groovy,now 3.6-2 amd64 [installed]
libnewt0.52/groovy,now 0.52.21-4ubuntu2 amd64 [installed]
libnfnetlink0/groovy,now 1.0.1-3build1 amd64 [installed]
libnftnl11/groovy,now 1.1.7-1 amd64 [installed]
libnpth0/groovy,now 1.6-2 amd64 [installed,automatic]
libnsl-dev/groovy,now 1.3.0-0ubuntu3 amd64 [installed,automatic]
libnsl2/groovy,now 1.3.0-0ubuntu3 amd64 [installed]
libnspr4/groovy,now 2:4.27-1 amd64 [installed,automatic]
libnss-nis/groovy,now 3.1-0ubuntu4 amd64 [installed]
libnss-nisplus/groovy,now 1.3-0ubuntu4 amd64 [installed]
libnss-systemd/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
libnss3/groovy,now 2:3.55-1ubuntu3 amd64 [installed,automatic]
libntfs-3g883/groovy,now 1:2017.3.23AR.3-3ubuntu2 amd64 [installed]
libnuma1/groovy,now 2.0.12-1build1 amd64 [installed]
libp11-kit0/groovy-updates,groovy-security,now 0.23.21-2ubuntu0.1 amd64 [installed]
libpam-cap/groovy,now 1:2.43-1 amd64 [installed]
libpam-modules-bin/groovy,now 1.3.1-5ubuntu6 amd64 [installed]
libpam-modules/groovy,now 1.3.1-5ubuntu6 amd64 [installed]
libpam-runtime/groovy,now 1.3.1-5ubuntu6 all [installed]
libpam-systemd/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
libpam0g/groovy,now 1.3.1-5ubuntu6 amd64 [installed]
libparted2/groovy-updates,now 3.3-4ubuntu0.20.10.1 amd64 [installed]
libpcap0.8/groovy,now 1.9.1-4 amd64 [installed]
libpci3/groovy,now 1:3.7.0-2 amd64 [installed]
libpciaccess0/groovy,now 0.16-1 amd64 [installed]
libpcre2-8-0/groovy,now 10.34-7 amd64 [installed]
libpcre3/groovy,now 2:8.39-13 amd64 [installed]
libpcsclite1/groovy,now 1.9.0-1 amd64 [installed,automatic]
libperl5.30/groovy,now 5.30.3-4 amd64 [installed,automatic]
libpipeline1/groovy,now 1.5.3-1 amd64 [installed]
libplymouth5/groovy-updates,now 0.9.5-0ubuntu2.1 amd64 [installed]
libpng16-16/groovy,now 1.6.37-3 amd64 [installed]
libpolkit-gobject-1-0/groovy,now 0.105-29 amd64 [installed]
libpopt0/groovy,now 1.18-1 amd64 [installed]
libprocps8/groovy,now 2:3.3.16-5ubuntu2 amd64 [installed]
libpsl5/groovy,now 0.21.0-1.1ubuntu1 amd64 [installed]
libpython3-stdlib/groovy,now 3.8.6-0ubuntu1 amd64 [installed]
libpython3.8-minimal/groovy,now 3.8.6-1 amd64 [installed]
libpython3.8-stdlib/groovy,now 3.8.6-1 amd64 [installed]
libqrencode4/groovy,now 4.0.2-2 amd64 [installed,automatic]
libquadmath0/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libreadline8/groovy,now 8.0-4 amd64 [installed]
libroken18-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libsasl2-2/groovy,now 2.1.27+dfsg-2ubuntu1 amd64 [installed]
libsasl2-modules-db/groovy,now 2.1.27+dfsg-2ubuntu1 amd64 [installed]
libseccomp2/groovy,now 2.4.3-1ubuntu4 amd64 [installed]
libselinux1/groovy,now 3.1-2 amd64 [installed]
libsemanage-common/groovy,now 3.1-1 all [installed]
libsemanage1/groovy,now 3.1-1 amd64 [installed]
libsensors-config/groovy,now 1:3.6.0-2ubuntu1 all [installed]
libsensors5/groovy,now 1:3.6.0-2ubuntu1 amd64 [installed]
libsepol1/groovy,now 3.1-1 amd64 [installed]
libslang2/groovy,now 2.3.2-5 amd64 [installed]
libsm6/groovy,now 2:1.2.3-1 amd64 [installed]
libsmartcols1/groovy,now 2.36-3ubuntu1 amd64 [installed]
libsqlite3-0/groovy,now 3.33.0-1 amd64 [installed]
libss2/groovy,now 1.45.6-1ubuntu1 amd64 [installed]
libssl1.1/groovy-updates,groovy-security,now 1.1.1f-1ubuntu4.1 amd64 [installed]
libstdc++6/groovy,now 10.2.0-13ubuntu1 amd64 [installed]
libsystemd0/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
libtasn1-6/groovy,now 4.16.0-2 amd64 [installed]
libtext-charwidth-perl/groovy,now 0.04-10 amd64 [installed]
libtext-diff-perl/groovy,now 1.45-1 all [installed,automatic]
libtext-iconv-perl/groovy,now 1.7-7 amd64 [installed]
libtext-wrapi18n-perl/groovy,now 0.06-9 all [installed]
libtimedate-perl/groovy,now 2.3300-1 all [installed,automatic]
libtinfo6/groovy,now 6.2-1 amd64 [installed]
libtirpc-common/groovy,now 1.2.6-1build1 all [installed]
libtirpc-dev/groovy,now 1.2.6-1build1 amd64 [installed,automatic]
libtirpc3/groovy,now 1.2.6-1build1 amd64 [installed]
libtry-tiny-perl/groovy,now 0.30-1 all [installed,automatic]
libtsan0/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libtypes-serialiser-perl/groovy,now 1.0-1 all [installed,automatic]
libubsan1/groovy,now 10.2.0-13ubuntu1 amd64 [installed,automatic]
libuchardet0/groovy,now 0.0.7-1 amd64 [installed]
libudev1/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
libunistring2/groovy,now 0.9.10-4 amd64 [installed]
libunwind8/groovy,now 1.3.2-2 amd64 [installed]
liburi-perl/groovy,now 1.76-2 all [installed,automatic]
libusb-1.0-0/groovy,now 2:1.0.23-2build1 amd64 [installed]
libuuid1/groovy,now 2.36-3ubuntu1 amd64 [installed]
libuv1/groovy,now 1.38.0-2ubuntu2 amd64 [installed]
libvulkan1/groovy,now 1.2.141.0-1 amd64 [installed]
libwind0-heimdal/groovy,now 7.7.0+dfsg-2 amd64 [installed,automatic]
libwrap0/groovy,now 7.6.q-30 amd64 [installed]
libwww-perl/groovy,now 6.47-1 all [installed,automatic]
libwww-robotrules-perl/groovy,now 6.02-1 all [installed,automatic]
libx11-6/groovy,now 2:1.6.12-1 amd64 [installed]
libx11-data/groovy,now 2:1.6.12-1 all [installed]
libx11-xcb1/groovy,now 2:1.6.12-1 amd64 [installed]
libxau6/groovy,now 1:1.0.9-0ubuntu1 amd64 [installed]
libxaw7/groovy,now 2:1.0.13-1 amd64 [installed]
libxcb-dri2-0/groovy,now 1.14-2 amd64 [installed]
libxcb-dri3-0/groovy,now 1.14-2 amd64 [installed]
libxcb-glx0/groovy,now 1.14-2 amd64 [installed]
libxcb-present0/groovy,now 1.14-2 amd64 [installed]
libxcb-shape0/groovy,now 1.14-2 amd64 [installed]
libxcb-sync1/groovy,now 1.14-2 amd64 [installed]
libxcb-xfixes0/groovy,now 1.14-2 amd64 [installed]
libxcb1/groovy,now 1.14-2 amd64 [installed]
libxcomposite1/groovy,now 1:0.4.5-1 amd64 [installed]
libxcursor1/groovy,now 1:1.2.0-2 amd64 [installed]
libxdamage1/groovy,now 1:1.1.5-2 amd64 [installed]
libxdmcp6/groovy,now 1:1.1.3-0ubuntu1 amd64 [installed]
libxext6/groovy,now 2:1.3.4-0ubuntu1 amd64 [installed]
libxfixes3/groovy,now 1:5.0.3-2 amd64 [installed]
libxft2/groovy,now 2.3.3-0ubuntu1 amd64 [installed]
libxi6/groovy,now 2:1.7.10-1 amd64 [installed]
libxinerama1/groovy,now 2:1.1.4-2 amd64 [installed]
libxkbfile1/groovy,now 1:1.1.0-1 amd64 [installed]
libxml2/groovy,now 2.9.10+dfsg-5build1 amd64 [installed]
libxmu6/groovy,now 2:1.1.3-0ubuntu1 amd64 [installed]
libxmuu1/groovy,now 2:1.1.3-0ubuntu1 amd64 [installed]
libxpm4/groovy,now 1:3.5.12-1 amd64 [installed]
libxrandr2/groovy,now 2:1.5.2-0ubuntu1 amd64 [installed]
libxrender1/groovy,now 1:0.9.10-1 amd64 [installed]
libxshmfence1/groovy,now 1.3-1 amd64 [installed]
libxt6/groovy,now 1:1.2.0-1 amd64 [installed]
libxtables12/groovy-updates,now 1.8.5-3ubuntu2.20.10.2 amd64 [installed]
libxtst6/groovy,now 2:1.2.3-1 amd64 [installed]
libxv1/groovy,now 2:1.0.11-1 amd64 [installed]
libxxf86dga1/groovy,now 2:1.1.5-0ubuntu1 amd64 [installed]
libxxf86vm1/groovy,now 1:1.1.4-1build1 amd64 [installed]
libxxhash0/groovy-updates,now 0.8.0-1ubuntu1.20.10.1 amd64 [installed]
libyaml-0-2/groovy,now 0.2.2-1 amd64 [installed]
libzstd1/groovy,now 1.4.5+dfsg-4 amd64 [installed]
linux-libc-dev/groovy-updates,groovy-security,now 5.8.0-41.46 amd64 [installed,automatic]
locales/groovy,now 2.32-0ubuntu3 all [installed]
login/groovy,now 1:4.8.1-1ubuntu6 amd64 [installed]
logrotate/groovy,now 3.14.0-4ubuntu5 amd64 [installed]
logsave/groovy,now 1.45.6-1ubuntu1 amd64 [installed]
lsb-base/groovy,now 11.1.0ubuntu2 all [installed]
lsb-release/groovy,now 11.1.0ubuntu2 all [installed]
lshw/groovy-updates,now 02.18.85-0.3ubuntu2.20.10.1 amd64 [installed]
lsof/groovy-updates,now 4.93.2+dfsg-1ubuntu0.20.10.1 amd64 [installed]
ltrace/groovy,now 0.7.3-6.1ubuntu2 amd64 [installed]
man-db/groovy,now 2.9.3-2 amd64 [installed]
manpages-dev/groovy,now 5.08-1 all [installed,automatic]
manpages/groovy,now 5.08-1 all [installed]
mawk/groovy,now 1.3.4.20200120-2 amd64 [installed]
mime-support/groovy,now 3.64ubuntu1 all [installed]
mount/groovy,now 2.36-3ubuntu1 amd64 [installed]
mtr-tiny/groovy,now 0.93-2 amd64 [installed]
nano/groovy,now 5.2-1 amd64 [installed]
ncurses-base/groovy,now 6.2-1 all [installed]
ncurses-bin/groovy,now 6.2-1 amd64 [installed]
net-tools/groovy,now 1.60+git20180626.aebd88e-1ubuntu2 amd64 [installed]
netbase/groovy,now 6.1 all [installed]
netcat-openbsd/groovy,now 1.217-2ubuntu1 amd64 [installed]
netplan.io/groovy-updates,now 0.101-0ubuntu3~20.10.1 amd64 [installed]
networkd-dispatcher/groovy,now 2.0.1-1 all [installed]
ntfs-3g/groovy,now 1:2017.3.23AR.3-3ubuntu2 amd64 [installed]
openjdk-11-jre-headless/groovy-updates,groovy-security,now 11.0.9.1+1-0ubuntu1~20.10 amd64 [installed,automatic]
openjdk-11-jre/groovy-updates,groovy-security,now 11.0.9.1+1-0ubuntu1~20.10 amd64 [installed,automatic]
openssh-client/groovy,now 1:8.3p1-1 amd64 [installed]
openssh-server/groovy,now 1:8.3p1-1 amd64 [installed]
openssh-sftp-server/groovy,now 1:8.3p1-1 amd64 [installed]
openssl/groovy-updates,groovy-security,now 1.1.1f-1ubuntu4.1 amd64 [installed]
parted/groovy-updates,now 3.3-4ubuntu0.20.10.1 amd64 [installed]
passwd/groovy,now 1:4.8.1-1ubuntu6 amd64 [installed]
pci.ids/groovy,now 0.0~2020.07.21-1 all [installed]
pciutils/groovy,now 1:3.7.0-2 amd64 [installed]
perl-base/groovy,now 5.30.3-4 amd64 [installed]
perl-modules-5.30/groovy,now 5.30.3-4 all [installed,automatic]
perl-openssl-defaults/groovy,now 5 amd64 [installed,automatic]
perl/groovy,now 5.30.3-4 amd64 [installed,automatic]
pinentry-curses/groovy,now 1.1.0-4build1 amd64 [installed,automatic]
pkg-config/groovy,now 0.29.2-1ubuntu1 amd64 [installed]
plymouth-theme-ubuntu-text/groovy-updates,now 0.9.5-0ubuntu2.1 amd64 [installed]
plymouth/groovy-updates,now 0.9.5-0ubuntu2.1 amd64 [installed]
postfix/groovy,now 3.5.6-1 amd64 [installed]
powermgmt-base/groovy,now 1.36 all [installed]
procps/groovy,now 2:3.3.16-5ubuntu2 amd64 [installed]
psmisc/groovy,now 23.3-1 amd64 [installed]
publicsuffix/groovy,now 20200729.1725-1 all [installed]
python-apt-common/groovy-updates,groovy-security,now 2.1.3ubuntu1.3 all [installed]
python3-apt/groovy-updates,groovy-security,now 2.1.3ubuntu1.3 amd64 [installed]
python3-commandnotfound/groovy,now 20.10.1 all [installed]
python3-dbus/groovy,now 1.2.16-3 amd64 [installed]
python3-distro-info/groovy,now 0.23ubuntu1 all [installed]
python3-distupgrade/groovy-updates,now 1:20.10.14 all [installed]
python3-gdbm/groovy,now 3.8.6-1 amd64 [installed]
python3-gi/groovy,now 3.38.0-1 amd64 [installed]
python3-minimal/groovy,now 3.8.6-0ubuntu1 amd64 [installed]
python3-netifaces/groovy,now 0.10.4-1ubuntu4 amd64 [installed]
python3-pkg-resources/groovy,now 49.3.1-2 all [installed]
python3-update-manager/groovy-updates,now 1:20.10.4 all [installed]
python3-yaml/groovy,now 5.3.1-2 amd64 [installed]
python3.8-minimal/groovy,now 3.8.6-1 amd64 [installed]
python3.8/groovy,now 3.8.6-1 amd64 [installed]
python3/groovy,now 3.8.6-0ubuntu1 amd64 [installed]
qrencode/groovy,now 4.0.2-2 amd64 [installed]
readline-common/groovy,now 8.0-4 all [installed]
rpcbind/groovy,now 1.2.5-9 amd64 [installed,automatic]
rpcsvc-proto/groovy,now 1.4.2-0ubuntu4 amd64 [installed,automatic]
rsync/groovy,now 3.2.3-2ubuntu1 amd64 [installed]
rsyslog/groovy,now 8.2006.0-2ubuntu1 amd64 [installed]
sed/groovy,now 4.7-1ubuntu1 amd64 [installed]
sensible-utils/groovy,now 0.0.13 all [installed]
shared-mime-info/groovy,now 2.0-1 amd64 [installed]
sqlite3/groovy,now 3.33.0-1 amd64 [installed,automatic]
ssh/groovy,now 1:8.3p1-1 all [installed]
ssl-cert/groovy,now 1.0.39 all [installed]
strace/groovy,now 5.5-3ubuntu1 amd64 [installed]
sudo/groovy-updates,groovy-security,now 1.9.1-1ubuntu1.1 amd64 [installed]
systemd-sysv/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
systemd-timesyncd/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
systemd/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
sysvinit-utils/groovy,now 2.96-3ubuntu1 amd64 [installed]
tar/groovy-updates,groovy-security,now 1.30+dfsg-7ubuntu0.20.10.1 amd64 [installed]
tcpdump/groovy,now 4.9.3-6 amd64 [installed]
telnet/groovy,now 0.17-41.2build1 amd64 [installed]
time/groovy,now 1.7-25.1build2 amd64 [installed]
tzdata/groovy-updates,groovy-security,now 2021a-0ubuntu0.20.10 all [installed]
ubuntu-advantage-tools/groovy,now 24.4 amd64 [installed]
ubuntu-keyring/groovy,now 2020.06.17.1 all [installed]
ubuntu-minimal/groovy,now 1.459 amd64 [installed]
ubuntu-release-upgrader-core/groovy-updates,now 1:20.10.14 all [installed]
ubuntu-standard/groovy,now 1.459 amd64 [installed]
ucf/groovy,now 3.0043 all [installed]
udev/groovy-updates,now 246.6-1ubuntu1.1 amd64 [installed]
ufw/groovy,now 0.36-7 all [installed]
update-manager-core/groovy-updates,now 1:20.10.4 all [installed]
usb.ids/groovy,now 2020.08.26-1 all [installed]
usbutils/groovy,now 1:012-2 amd64 [installed]
util-linux/groovy,now 2.36-3ubuntu1 amd64 [installed]
uuid-runtime/groovy,now 2.36-3ubuntu1 amd64 [installed]
vim-common/groovy,now 2:8.2.0716-3ubuntu2 all [installed]
vim-tiny/groovy,now 2:8.2.0716-3ubuntu2 amd64 [installed]
wget/groovy,now 1.20.3-1ubuntu1 amd64 [installed]
whiptail/groovy,now 0.52.21-4ubuntu2 amd64 [installed]
x11-apps/groovy,now 7.7+8 amd64 [installed]
x11-common/groovy,now 1:7.7+19ubuntu15 all [installed]
x11-session-utils/groovy,now 7.7+4 amd64 [installed]
x11-utils/groovy,now 7.7+5 amd64 [installed]
x11-xkb-utils/groovy,now 7.7+5 amd64 [installed]
x11-xserver-utils/groovy,now 7.7+8 amd64 [installed]
xauth/groovy,now 1:1.1-0ubuntu1 amd64 [installed]
xbase-clients/groovy,now 1:7.7+19ubuntu15 all [installed]
xdg-user-dirs/groovy,now 0.17-2ubuntu2 amd64 [installed]
xinit/groovy,now 1.4.1-0ubuntu2 amd64 [installed]
xkb-data/groovy,now 2.29-2 all [installed]
xxd/groovy,now 2:8.2.0716-3ubuntu2 amd64 [installed]
xz-utils/groovy,now 5.2.4-1ubuntu1 amd64 [installed]
zlib1g/groovy,now 1:1.2.11.dfsg-2ubuntu4 amd64 [installed]

und

root@Test:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="20.10 (Groovy Gorilla)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.10"
VERSION_ID="20.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=groovy
UBUNTU_CODENAME=groovy
Gruss
  Enno
Einfacher FHEM Anwender auf Intel®NUC

Offline Adimarantis

  • Developer
  • Full Member
  • ****
  • Beiträge: 442
Danke für die Logfiles, das wird wohl ein iterativer Prozess, besonders mit den Net:DBus Abhängigkeiten. Ich versuche die jetzt soweit ich sie identifizieren kann per "apt install" vorzuinstallieren.

Bitte mit dem hier angehängten Script nochmal probieren und mir das /tmp/signal_install.log zukommen lassen, wenn es noch nicht geht.

@Bafh: Mach mal ein ein
sudo ./signal_install.sh removeund probiere ob eine Neuinstallation die Meldung
OpenJDK 32-Bit Server VM warning: You have loaded library /tmp/resource17469578394760016723.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
WARN App - WARNING: Support for new group V2 is disabled, because the required native library dependency is missing: libzkgroup
verschwinden lässt. Da hatte noch was in der "Rapsi" Erkennung nicht funktioniert.

Wegen CAPTCHA:
Das muss ein neues "Feature" von Signal sein und wird wahrscheinlich getriggert wenn man aus einer VM kommt. Wird von signal-cli derzeit noch nicht unterstützt.
Habe jetzt dazu einen Hinweis eingebaut.
Workaround:
- Auf einem anderen System probieren und versuchen ob die Registrierung kopiert werden kann (not tested)
- Bereits bestehende Device (Smartphone) linken

Jörg

Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , (50_SPI_MAX31865)

Offline enno

  • Sr. Member
  • ****
  • Beiträge: 763
ok, hier die Fehlermeldung auf der Konsole mit dem neuen Script:

Proceed (Y/n)? y
Checking for /usr/lib...found
Checking for /etc/dbus-1/system.d...found
Checking for /usr/share/dbus-1/system-services...found
Checking for /etc/systemd/system...found
Checking for wget...available
Checking for haveged...available
Checking for java...available
Checking for diff...available
Checking for dbus-send...available
Checking for cpan...available
Checking for qrencode...available
Checking for pkg-config...available
Checking for gcc...available
Checking for /usr/include/dbus-1.0/dbus/dbus.h...available
Checking for /usr/share/perl5/Test/CPAN/Changes.pm...installing (libcpan-changes-perl)done
Checking for /usr/lib/arm-linux-gnueabihf/libexpat.a...installing (libexpat1-dev)Failed to install /usr/lib/arm-linux-gnueabihf/libexpat.a

und hier das Log:
NAME="Ubuntu"
VERSION="20.10 (Groovy Gorilla)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.10"
VERSION_ID="20.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=groovy
UBUNTU_CODENAME=groovy
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  libcpan-changes-perl
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 32.0 kB of archives.
After this operation, 125 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu groovy/universe amd64 libcpan-changes-perl all 0.400002-1 [32.0 kB]
Fetched 32.0 kB in 0s (208 kB/s)
Selecting previously unselected package libcpan-changes-perl.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 29729 files and directories currently installed.)
Preparing to unpack .../libcpan-changes-perl_0.400002-1_all.deb ...
Unpacking libcpan-changes-perl (0.400002-1) ...
Setting up libcpan-changes-perl (0.400002-1) ...
Processing triggers for man-db (2.9.3-2) ...
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  libexpat1-dev
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 116 kB of archives.
After this operation, 867 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu groovy/main amd64 libexpat1-dev amd64 2.2.9-1build1 [116 kB]
Fetched 116 kB in 0s (811 kB/s)
Selecting previously unselected package libexpat1-dev:amd64.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 29749 files and directories currently installed.)
Preparing to unpack .../libexpat1-dev_2.2.9-1build1_amd64.deb ...
Unpacking libexpat1-dev:amd64 (2.2.9-1build1) ...
Setting up libexpat1-dev:amd64 (2.2.9-1build1) ...

Gruss
  Enno
Einfacher FHEM Anwender auf Intel®NUC

Offline BAfH

  • Jr. Member
  • **
  • Beiträge: 60
Hallo Jörg,

also das Script mit remove ausgeführt.
Neuinstallation
This script will help you to install signal-cli as system dbus service
and prepare the use of the FHEM Signalbot module

Please verify that these settigns are correct:
Signal-cli User:              signal-cli
Signal-cli Install directory: /opt
Signal config storage:        /var/lib/signal-cli
Signal version:               0.7.4
System library path:          /usr/lib
Phone number to be used:      +493xxx
Your configuration
Linux 6f3985224938 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
has not been tested, continue at own risk
This will update system packages, install signal-cli and help to register with Signal service

To do this rather step by step use the command line arguments or just proceed to do system,install,register:
system   : prepare required system package (except signal-cli) - make sure you ran this before you do anything else!
install  : install signal-cli and setup as dbus system service
register : register a NEW number with Signal
link     : link an EXISTING number with Signal (e.g. you Smartphone)
test     : run a basic test if everything is installed and registered correctly
remove   : Remove signal-cli and all configurations
join     : Join current number to an existing group (invite by group link)

!!! Everything needs to run with sudo !!!

Proceed (Y/n)? y
Checking for /usr/lib...found
Checking for /etc/dbus-1/system.d...found
Checking for /usr/share/dbus-1/system-services...found
Checking for /etc/systemd/system...found
Checking for wget...available
Checking for haveged...installing (haveged)E: Unable to locate package haveged
done
Checking for java...installing (default-jre)E: Unable to locate package default-jre
done
Checking for diff...available
Checking for dbus-send...available
Checking for cpan...available
Checking for qrencode...installing (qrencode)E: Unable to locate package qrencode
done
Checking for pkg-config...available
Checking for gcc...available
Checking for /usr/include/dbus-1.0/dbus/dbus.h...available
Checking for /usr/share/perl5/Test/CPAN/Changes.pm...installing (libcpan-changes-perl)E: Unable to locate package libcpan-changes-perl
Failed to install /usr/share/perl5/Test/CPAN/Changes.pm
root@6f3985224938:/opt/fhem#

hier die signal_install.log
root@6f3985224938:/opt/fhem# more /tmp/signal_install.log
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
Reading package lists...
Building dependency tree...
Reading state information...
Reading package lists...
Building dependency tree...
Reading state information...
Reading package lists...
Building dependency tree...
Reading state information...
Reading package lists...
Building dependency tree...
Reading state information...
root@6f3985224938:/opt/fhem#
Bin verwirrt.
Ich werde morgen mal, alles ohne Docker aufzusetzen und ggf alle  Daten zu kopieren.
Gebe hier bescheid.
Gruß Thorben
mit sonnige Grüße aus Schönow

Offline enno

  • Sr. Member
  • ****
  • Beiträge: 763
Moin Jörg,

ich habe einen Container mit FHEM und den gleichen Einstellungen wie das Testsystem laufen. Dort habe ich signal-cli laufen und auch die Nummer registriert. Das ging ohne CAPTCHA. Entweder ist das in den letzten 4 Tagen eingeführt worden oder es liegt doch noch an irgend etwas anderem. Ausser der IP ist ja alles identisch. Ok, vielleicht nicht ganz, ich hatte auf der Telefonnummer schon mal ein Signal App registriert. Mal schauen, ob ich das von einem Handy ordentlich löschen kann und werde es dann noch mal mit deinem Script versuchen.

Gruss
  Enno
Einfacher FHEM Anwender auf Intel®NUC

Offline Adimarantis

  • Developer
  • Full Member
  • ****
  • Beiträge: 442
Bin verwirrt.
Ich auch etwas. Ist das das selbe System? Schaut jetzt anders aus als vorher. Ich glaube außerdem nicht, dass man diese Installation im Docker laufen lassen kann, da ja ein Systemservice aufgesetzt wird und systemweite Pakete installiert werden.
FHEM kann dann später wahrscheinlich im Docker laufen, aber signal-cli muss ins Hauptsystem.

Zitat von: enno
ich habe einen Container mit FHEM und den gleichen Einstellungen wie das Testsystem laufen. Dort habe ich signal-cli laufen und auch die Nummer registriert. Das ging ohne CAPTCHA. Entweder ist das in den letzten 4 Tagen eingeführt worden oder es liegt doch noch an irgend etwas anderem. Ausser der IP ist ja alles identisch. Ok, vielleicht nicht ganz, ich hatte auf der Telefonnummer schon mal ein Signal App registriert. Mal schauen, ob ich das von einem Handy ordentlich löschen kann und werde es dann noch mal mit deinem Script versuchen.
Das Captcha muss es schon länger geben. Der Diskussionsthread bei signal-cli reicht zurück nach 2019 - aber vielleicht wird das jetzt häufiger getriggert. Meine Test VM unter Ubuntu mit einer komplett neuen Nummer fragt auch nach einem Captcha.

Grundsätzlich müsste man die Registrierung auf jedem Linux System auch mit jedem Standarduser ohne große Installation machen können.
Einfach:
wget https://github.com/AsamK/signal-cli/releases/download/v0.7.4/signal-cli-0.7.4.tar.gz
tar xf signal-cli-0.7.4.tar.gz
cd signal-cli-0.7.4
bin/signal-cli -u +49xxxxxx register --voice
bin/signal-cli -u +49xxxxxx receive

Dann sollte in ~/.local/share/signal-cli ein Verzeichnis "data" aufgetaucht sein.
Das dann auf dem Ziel-PC in /var/lib/signal-cli kopieren.
Nicht vergessen ein
chown -R signal-cli: data zu machen
Danach kann das Verzeichnis signal-cli-0-7.4 und ~/.local/share/signal-cli wieder gelöscht werden und alles wieder restlos weg sein.
Wie gesagt - theoretisch - hab nicht getestet ob diese Daten irgendwie an das System geknüpft sind - Erfahrungsberichte willkommen.

Jörg
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , (50_SPI_MAX31865)