FHEM - Hausautomations-Systeme > KNX/EIB

10_KNX.pm - off-for-timer fehlerhaft implementiert

(1/1)

lichtimc:
Hallo,


scheinbar wird nur on-for-timer richtig ein und wieder ausgeschalten.


Bei off-for-timer wird hingegen 2 mal ausgeschalten.


lg

erwin:
Hi,

--- Code: ---Bei off-for-timer wird hingegen 2 mal ausgeschalten.
--- Ende Code ---
.. kann ich nicht nachstellen.
ein set <device> g1 on-for-timer 15:

--- Code: ---2021-02-01 15:50:33.765 at testdpt1_TIMER_0b7ff Next: 15:50:48
2021-02-01 15:50:33.906 Global global DEFINED testdpt1_TIMER_0b7ff
2021-02-01 15:50:33.933 KNX testdpt1 setG1: on
2021-02-01 15:50:33.933 KNX testdpt1 last-sender: fhem
2021-02-01 15:50:33.933 KNX testdpt1 on
2021-02-01 15:50:34.144 KNX testdpt1 getG1: on
2021-02-01 15:50:34.144 KNX testdpt1 last-sender: 0.0.5
2021-02-01 15:50:34.144 KNX testdpt1 on
2021-02-01 15:50:48.793 KNX testdpt1 setG1: off
2021-02-01 15:50:48.793 KNX testdpt1 last-sender: fhem
2021-02-01 15:50:48.793 KNX testdpt1 off
2021-02-01 15:50:48.834 KNX testdpt1 getG1: off
2021-02-01 15:50:48.834 KNX testdpt1 last-sender: 0.0.5
2021-02-01 15:50:48.834 KNX testdpt1 off

--- Ende Code ---
und ein set <device> g1 off-for-timer 15:

--- Code: ---2021-02-01 15:51:41.149 at testdpt1_TIMER_0b7ff Next: 15:51:56
2021-02-01 15:51:41.265 Global global DEFINED testdpt1_TIMER_0b7ff
2021-02-01 15:51:41.290 KNX testdpt1 setG1: off
2021-02-01 15:51:41.290 KNX testdpt1 last-sender: fhem
2021-02-01 15:51:41.290 KNX testdpt1 off
2021-02-01 15:51:41.528 KNX testdpt1 getG1: off
2021-02-01 15:51:41.528 KNX testdpt1 last-sender: 0.0.5
2021-02-01 15:51:41.528 KNX testdpt1 off
2021-02-01 15:51:56.180 KNX testdpt1 setG1: on
2021-02-01 15:51:56.180 KNX testdpt1 last-sender: fhem
2021-02-01 15:51:56.180 KNX testdpt1 on
2021-02-01 15:51:56.224 KNX testdpt1 getG1: on
2021-02-01 15:51:56.224 KNX testdpt1 last-sender: 0.0.5
2021-02-01 15:51:56.224 KNX testdpt1 on
--- Ende Code ---

bitte um ein list <device>
l.g. erwin

andremar6918:
Hallo,
ich kann das Problem bestätigen. Der off-for-timer funktioniert bei einem KNX-device nicht.

set AKK16_02_E g1 off-for-timer 10


--- Code: ---2021-10-14 14:41:37 KNX AKK16_02_E setG1: off
2021-10-14 14:41:37 KNX AKK16_02_E off
2021-10-14 14:41:37 KNX AKK16_02_E last-sender: fhem
2021-10-14 14:41:37 KNX AKK16_02_E getG1: off
2021-10-14 14:41:37 KNX AKK16_02_E last-sender: 1/0/201
2021-10-14 14:41:37 KNX AKK16_02_E off
2021-10-14 14:41:47 KNX AKK16_02_E setG1: off
2021-10-14 14:41:47 KNX AKK16_02_E off
2021-10-14 14:41:47 KNX AKK16_02_E last-sender: fhem
2021-10-14 14:41:47 KNX AKK16_02_E getG1: off
2021-10-14 14:41:47 KNX AKK16_02_E last-sender: 1/0/201
2021-10-14 14:41:47 KNX AKK16_02_E off
2021-10-14 14:57:15 KNX AKK16_01_D setG1: off
2021-10-14 14:57:15 KNX AKK16_01_D off
2021-10-14 14:57:15 KNX AKK16_01_D last-sender: fhem
2021-10-14 14:57:16 KNX AKK16_01_D getG1: off
2021-10-14 14:57:16 KNX AKK16_01_D last-sender: 1/0/201
2021-10-14 14:57:16 KNX AKK16_01_D off
--- Ende Code ---


--- Code: ---Internals:
   DEF        0/1/4:dpt1.001
   DEVNAME    AKK16_02_E
   FIRSTGADNAME g1
   FUUID      5f7ed7b6-f33f-0cec-1a4f-6d763960bdbf96a8
   GETSTRING  g1:noArg
   IODev      KNX
   LASTInputDev tul
   MSGCNT     40
   NAME       AKK16_02_E
   NR         79
   NTFY_ORDER 50-AKK16_02_E
   SETSTRING  g1:off,on
   STATE      off
   TYPE       KNX
   tul_MSGCNT 40
   tul_RAWMSG C010c9w0010400
   tul_TIME   2021-10-14 14:41:47
   GADDETAILS:
     g1:
       CODE       00104
       GROUP      0/1/4
       MODEL      dpt1.001
       NO         1
       OPTION     
       RDNAMEGET  getG1
       RDNAMEPUT  putG1
       RDNAMESET  setG1
       SETLIST    :off,on
   GADTABLE:
     00104      g1
   READINGS:
     2021-06-10 16:18:56   IODev           KNX
     2021-10-14 14:41:47   getG1           off
     2021-10-14 14:41:47   last-sender     1/0/201
     2021-10-14 14:41:47   setG1           off
     2021-10-14 14:41:47   state           off
Attributes:
   IODev      KNX
   alias      Trockner
   room       Erdgeschoss_EG,KNX
   userattr   power power_map structexclude
   webCmd     on:off
--- Ende Code ---

VG


erwin:
... das ging schon mal in der zwischenzeit...  :(
Fehler gefunden, gefixed, ab morgen im update!
l.g.erwin

andremar6918:
Hallo Erwin,

super, ich habe es getestet, es klappt jetzt. Auch der on-for-timer funktioniert.
Danke für die Hilfe.  :)

Viele Grüße, Andreas

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln