FHEM - Anwendungen > Multimedia

Neuentw. Modulpaket zu UPnP: Controller, Device, DLNA(Renderer-Ersatz)

<< < (23/24) > >>

Newbie:
Hallo Markus,

nach dem Hinweis aus dem Beitrag 3


--- Zitat ---Zusätzlich sind die Perlpakete ◾SOAP::Lite, ◾LWP::Simple, ◾XML::Simple, ◾XML::Parser::Lite, ◾LWP::UserAgent zu installieren
--- Ende Zitat ---

hab ich gedacht XML::Parser::Lite wird auf dem System nicht mehr gebraucht, also weg damit. Ergebnis = UPNPController platt


--- Zitat ---2021.05.16 13:30:34 1: reload: Error:Modul 98_UPNPController deactivated:
 Can't locate XML/Parser/Lite.pm in @INC (you may need to install the XML::Parser::Lite module)
--- Ende Zitat ---

Grüße Jens

KölnSolar:
Hi Jens,
wundert mich gerade. Ich gucke...
Grüße Markus
Edit: Oder liegt es daran ?  :-\

--- Zitat ---Edit2: Das
Code:

 ....<Event xmlns="urn:schemas-upnp-org:metadata-1-0/AVT/"><InstanceID val="0"><CurrentTrackMetaData ....

"behauptet, Du hast kein Update des 98_UPNPController gemacht ?  :-\  ???  ::)
--- Ende Zitat ---

Newbie:
Hallo Markus,


--- Zitat ---"behauptet, Du hast kein Update des 98_UPNPController gemacht ?  :-\  ??? 
--- Ende Zitat ---

 das war auch mein erster Verdacht, deshalb die Dateien aus Beitrag 1 & 3 heute noch einmal runtergeladen, installiert und dann erst gepostet.

KölnSolar:
Hi Jens,
ich hab nochmal ins Modul geguckt und auch versucht es nachzustellen.

"Direkt" wird nur XML::LibXML benutzt. Indirekt über das Perlpaket aber noch weitere(z.B. SOAP::Lite). Daher kann ich das nicht ausschließen.

Mich wundert aber, dass ich viel mehr Informationen im Log bei einem fehlenden Perlpaket bekomme als Du gepostet hast. Welches System nutzt Du ? Womit installierst/deinstallierst Du Perl-Pakete ? Im konkreten Fall ?

Grüße Markus

Newbie:
Hallo Markus,

vollständige Fehlermeldung:

--- Zitat ---2021.05.16 13:30:34 1: reload: Error:Modul 98_UPNPController deactivated:
 Can't locate XML/Parser/Lite.pm in @INC (you may need to install the XML::Parser::Lite module) (@INC contains: fhem.p/lib fhem.p/FHEM/lib ./FHEM/lib ./lib ./FHEM ./ /usr/local/FHEM/share/fhem/FHEM/lib . /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0 /usr/local/share/perl/5.30.0 /usr/lib/arm-linux-gnueabihf/perl5/5.30 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base) at FHEM/lib/UPnP/Common.pm line 752.
BEGIN failed--compilation aborted at FHEM/lib/UPnP/Common.pm line 752.
Compilation failed in require at FHEM/lib/UPnP/ControlPoint.pm line 39.
BEGIN failed--compilation aborted at FHEM/lib/UPnP/ControlPoint.pm line 39.
Compilation failed in require at ./FHEM/98_UPNPController.pm line 70.
BEGIN failed--compilation aborted at ./FHEM/98_UPNPController.pm line 70.
--- Ende Zitat ---

System = Ubuntu 20.xx
Perl-Version = 5.30
die meisten Perl-Module mit Cpanm installiert/deinstalliert (über FHEM Installer-Modul), aber ein paar auch mit apt-get

Grüße Jens

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln