Autor Thema: [gelöst] Sonoff Tasmota KNX Anbindung  (Gelesen 644 mal)

Offline xls

  • New Member
  • *
  • Beiträge: 23
[gelöst] Sonoff Tasmota KNX Anbindung
« am: 01 März 2021, 21:10:43 »
Moin,

ich habe ein Sonoff Pow R2 Modul über knxd TPUART in fhem eingebunden.
Alles funktioniert auch. Alle Adressen werden empfangen und verarbeitet.

Nur verursachen die beiden "Ausgang 1" Adressen (Empfangen 0/5/0 und Senden 0/5/1) von Tasmota in der fhem Log Datei ständig Einträge.

Folgendes habe ich definiert:
define Tasmota.AnAus KNX 0/5/0:dpt1 0/5/1:dpt1

Dies steht in der Log:
2021.03.01 20:41:17 2: decode model: , no valid model defined
2021.03.01 20:41:17 2: parse device hash (wpi): HASH(0x53223c8) name: Tasmota.AnAus, message could not be decoded - see log for details
2021.03.01 20:41:17 2: decode model: , no valid model defined
2021.03.01 20:41:17 2: parse device hash (wpi): HASH(0x3cf1f00) name: KNX_0005001, message could not be decoded - see log for details

KNX_0005001 ist gar nicht (mehr) definiert. Wurde nur kurz über das autocreate definiert.

Mache ich das aber und setze beide auf verbose:0 ist natürlich Ruhe.

Wieso hat sich fhem den Namen "KNX_0005001" gemerkt, obwohl der gar nicht mehr existiert und wie bekomme ich ohne verbose Ruhe?

Danke. ;)

Tim
« Letzte Änderung: 02 März 2021, 19:20:16 von xls »

Offline erwin

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 548
Antw:Sonoff Tasmota KNX Anbindung
« Antwort #1 am: 02 März 2021, 09:36:49 »
Hi xls,

ich denke ein shutdown restart löst das Problem!
Ursache: bei einem rename oder delete wurden bisher nicht alle internen strukturen sauber gelöscht.
Nachdem du kein list <device> geschickt hast, kann ich das allerdings nur vermuten.
l.g. erwin
FHEM aktuell auf RaspberryPI mit Busware ROT / Weinzirl IP731
Maintainer 10_KNX.pm
CUNO2 (868 SLOWRF) - HMS100xx, FS20, FHT
1-Wire  - 2401(iButton), 18x20, 2406, 2413 (AVR), 2450,...
MQTT2, KNX, SONOFF, mySENSORS,...
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline xls

  • New Member
  • *
  • Beiträge: 23
Antw:Sonoff Tasmota KNX Anbindung
« Antwort #2 am: 02 März 2021, 19:19:50 »
Tatsache! Danke.
Ist mir ja schon fast peinlich... einfach Neustarten.

Dieses Problem hatte ich jetzt nach 3 Jahren fhem zum ersten Mal.;)

 

decade-submarginal