Autor Thema: [gelöst] Template Bestätigungsbutton wird nicht angezeigt  (Gelesen 379 mal)

Offline Jan_H

  • New Member
  • *
  • Beiträge: 20
Hallo!

Ich habe das Problem, dass ich bei einem Shelly 2.5 ein Template benutzen möchte. Nach Auswahl des Templates wird mir bei einer Abfrage der "OK"-Button nicht angezeigt.
FHEM ist aktuell und der Browsercache geleert.

Siehe hier: https://forum.fhem.de/index.php/topic,94494.msg1136753.html#msg1136753

@rudolfkoenig

Hier habe ich die RAW-Definition des Gerätes. Ich habe das Gerät noch einmal gelöscht und durch einen Neustart wurde es wieder "frisch" angelegt:

defmod MQTT2_shellyswitch25_F4CFA2EC9AA0 MQTT2_DEVICE shellyswitch25_F4CFA2EC9AA0
attr MQTT2_shellyswitch25_F4CFA2EC9AA0 IODev myBroker
attr MQTT2_shellyswitch25_F4CFA2EC9AA0 readingList shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/online:.* online\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/announce:.* { json2nameValue($EVENT) }\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/relay/0:.* relay_0\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/relay/0/power:.* relay_0_power\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/relay/0/energy:.* relay_0_energy\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/relay/1:.* relay_1\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/relay/1/power:.* relay_1_power\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/relay/1/energy:.* relay_1_energy\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/input/0:.* input_0\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/input_event/0:.* { json2nameValue($EVENT) }\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/input/1:.* input_1\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/input_event/1:.* { json2nameValue($EVENT) }\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/temperature:.* temperature\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/temperature_f:.* temperature_f\
shellyswitch25_F4CFA2EC9AA0:shellies/shellyswitch25-F4CFA2EC9AA0/overtemperature:.* overtemperature
attr MQTT2_shellyswitch25_F4CFA2EC9AA0 room MQTT2_DEVICE

setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 event
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 event_cnt 0
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 fw_ver 20210115-103025/v1.9.4@e2732e05
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 id shellyswitch25-F4CFA2EC9AA0
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 input_0 1
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 input_1 1
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 ip 192.168.19.182
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 mac F4CFA2EC9AA0
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 model SHSW-25
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 new_fw false
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:50:32 online true
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 overtemperature 0
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 relay_0 off
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 relay_0_energy 202
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 relay_0_power 0.00
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 relay_1 off
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 relay_1_energy 294
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 relay_1_power 0.00
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 temperature 56.73
setstate MQTT2_shellyswitch25_F4CFA2EC9AA0 2021-03-03 12:53:02 temperature_f 134.11

Danke für die Hilfe!
« Letzte Änderung: 03 März 2021, 15:41:26 von Jan_H »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:Template Bestätigungsbutton wird nicht angezeigt
« Antwort #1 am: 03 März 2021, 14:09:20 »
Eine "RAW-Definition" von dem Ausgangsgerät sollte es tun.
Hab's mit der RAW-Definition versucht - kein Problem, das OK ist da...

Hast du denn "normale Dialogfelder" in anderen Bereichen von FHEMWEB? (Z.B. in der RAW-Def bzw. dem "grünen Plus"?

(Vermutlich wirst du die script-Console des Browsers brauchen, aber spätestens an der Stelle enden meine eigenen Kenntnisse).
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files

Offline Jan_H

  • New Member
  • *
  • Beiträge: 20
Antw:Template Bestätigungsbutton wird nicht angezeigt
« Antwort #2 am: 03 März 2021, 14:30:35 »
Vielen, vielen Dank, Beta-User.

Du hast mich auf die richtige Spur gebracht. Jetzt erhalte ich das Diaolgfeld.
Der Fehler lag daran, dass in meiner, bereits in die Tage gekommenen, Installation das Feature-Level 5.7 in global fest eingestellt war, warum auch immer.

Beste Grüße
Jan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:Template Bestätigungsbutton wird nicht angezeigt
« Antwort #3 am: 03 März 2021, 14:35:02 »
...immer wieder gerne...

Mal was "neues" ;D .

Markierst du den Thread dann bitte als [gelöst], damit Rudi das auch gleich sieht? (Bitte nicht schließen, auch, wenn vermutlich so schnell nicht wieder einer dasselbe Problem haben dürfte...)
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files
Gefällt mir Gefällt mir x 1 Liste anzeigen