Autor Thema: [­gelöst] Knxd/Buster  (Gelesen 609 mal)

Offline Schneewa

  • Full Member
  • ***
  • Beiträge: 111
[­gelöst] Knxd/Buster
« am: 29 März 2021, 13:04:10 »
Hi all

Ich habe folgendes Problem:

PI4 Buster light installiert

bin jetzt bei
https://wiki.fhem.de/wiki/Knxd

sudo apt-get update
sudo apt-get install debhelper cdbs automake libtool libusb-1.0-0-dev git-core build-essential libsystemd-dev dh-systemd libev-dev cmake

hat funktioniert - alles wurde installiert

git clone https://github.com/knxd/knxd.git
cd knxd

Verzeichnis wurde erstellt und der Inhalt wurde kopiert

git checkout deb

mit oder ohne root Rechte - das checkout funktioniert leider nicht - bin ein bisschen am verzweifeln  :-[

Fehlercode anbei

pi@raspberrypi:~ $ cd knxd
pi@raspberrypi:~/knxd $ dir
AUTHORS         contrib  Makefile.am  src
bootstrap.sh    doc      README.md    SubmittingPatches.md
CodingStyle.md  LICENSE  res          systemd
configure.ac    m4       rpm          tools
pi@raspberrypi:~/knxd $ git checkout deb
error: pathspec 'deb' did not match any file(s) known to git

hat jemand von den Experten eine Idee

besten Dank

P.S.: habe noch ein System mit Stretch am laufen - hatte eigentlich keine Probleme  :-\


« Letzte Änderung: 29 März 2021, 13:39:35 von Schneewa »

Offline Keule_09

  • Jr. Member
  • **
  • Beiträge: 61
Antw:Knxd/Buster
« Antwort #1 am: 29 März 2021, 13:23:41 »
Hallo,

seit Buster ist KNXD als Installationspaket in der Distribution enthalten:
sudo apt-get update
sudo apt-get install -t buster knxd knxd-tools
[code]


Gruß Marco
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline Schneewa

  • Full Member
  • ***
  • Beiträge: 111
Antw:Knxd/Buster
« Antwort #2 am: 29 März 2021, 13:37:24 »
Hi Keule_09

vielen Dank für die schnelle Antwort - sieht sehr gut aus  :)

 

decade-submarginal