FHEM - Hausautomations-Systeme > EnOcean

EnOcean Lösungen

<< < (2/2)

tobias6789:
Ich berichtige ... Die Lux-Werte Stimmen doch laut meinem Gefühl. Allerdings werden die Werte nicht richtig übernommen. Der Sensor übermittelt zwar richtig die motion also on aber die Lux-Werte sind noch die vorherigen, obwohl meine notify mit if-Bedingung die Schaltschwelle Festlegt und auch diese Werte richtig ankommen. Muss also dann an Fhem liegen.

Liebe Grüße

klaus.schauer:

--- Zitat von: tobias6789 schrieb am Mo, 01 April 2013 22:56 ---Hallo klaus.schauer

habe eben den PEHA 482 FU-BM DE Funk-Solar-Bewegungsmelder via Teach-In getestet.
Das schrieb Fhem in die CFG:


define EnO_sensor_0001FA99 EnOcean 0001FA99
attr EnO_sensor_0001FA99 room EnOcean
attr EnO_sensor_0001FA99 subType sensor
define FileLog_EnO_sensor_0001FA99 FileLog ./log/EnO_sensor_0001FA99-%Y.log EnO_sensor_0001FA99
attr FileLog_EnO_sensor_0001FA99 logtype text
attr FileLog_EnO_sensor_0001FA99 room EnOcean


Das Waren die States:

DEF    
0001FA99
IODev
   
TCM310_0
LASTInputDev
   
TCM310_0
MSGCNT
   
2
NAME
   
EnO_sensor_0001FA99
NR
   
568
STATE
   
144
TCM310_0_DestinationID
   
FFFFFFFF
TCM310_0_MSGCNT
   
2
TCM310_0_RSSI
   
67
TCM310_0_SecurityLevel
   
0
TCM310_0_SubTelNum
   
1
TCM310_0_TIME
   
2013-04-01 22:42:21
TYPE
   
EnOcean

Das Waren die Readings:

D0
   
1
   
2013-04-01 22:44:13
D1
   
0
   
2013-04-01 22:44:13
D2
   
1
   
2013-04-01 22:44:13
D3
   
1
   
2013-04-01 22:44:13
brightness
   
24
   
2013-04-01 22:38:29
motion
   
on
   
2013-04-01 22:38:29
presence
   
present
   
2013-04-01 22:38:29
sensor1
   
144
   
2013-04-01 22:44:13
sensor2
   
19
   
2013-04-01 22:44:13
sensor3
   
0
   
2013-04-01 22:44:13
state
   
144
   
2013-04-01 22:42:21
teach-in
   
EEP A5-08-01 Manufacturer: Peha
   
2013-04-01 22:38:28
temperature
   
0.0
   
2013-04-01 22:38:29
voltage
   
2.9
   
2013-04-01 22:38:29


Meine Rückmeldung:

Temperatur Sendet dieseer Sensor nicht. Das könnte man herausnehmen. Desweiteren stimmen die Lux-Werte nicht mit den tatsächlichen überein. (kann in der Firma genauere Tests machen mit Lux-Meter.) Das State Präsenz funktioniert auch nicht, da dies kein Präsenzmelder ist. Bewgung reagiert dieser Sensor sehr gut. Allerdingss gibts da ein Harken, hat der Sensor einmal Bewegung erkannt, reagiert er erst ca. 1,5 Min später wieder auf erneute Bewegung. Da sollte man vielleicht über eine Möglichkeit nachdenken die on-for-timer Zeit zurück stellen zu können beim Raspberry Pi. Aktuelle Situation ist so, Bewegung erkannt... notify meldet dies und schaltet das Licht an für 80 Sekunden... Licht geht aus... Erneute reaktion erst nach ca 100-120 Sekunden sprich man steht im Dunkeln.

Ich hoffe dass der Test ausführlich genug ist.  

Bei fragen ... einfach Fragen kann hier vieles nachstellen.

Gruß Tobias



--- Ende Zitat ---

Danke für den Test.
Es scheint, dass das per Teach-In gelernte Profil nicht vollständig abgespeichert wurde. Eigentlich müsste in fhem.cfg insbesondere stehen:

attr EnO_sensor_0001FA99 manufID 001
attr EnO_sensor_0001FA99 subType lightTempOccupSensor.01

Das Problem hatten andere auch schon. Ich hatte die Hoffnung, dass der Fehler inzwischen behoben ist. Bitte mal nach dem Teach-In die fhem.cfg manuell sichern.

Das Profil lightTempOccupSensor.01 bildet das Original EEP Profil ab. Leider gibt es firmenspezifische Besonderheiten. Ich habe bisher Eltako berücksichtigt. Kann durchaus sein, dass Peha z. B. einen anderen Wertebereich für die Helligkeit hat und keinen Anwesenheitsbutton. Ggf. kann ich ein zusätzliches firmenspezifisches Unterprofil vorsehen. Vielleicht hat jemand eine Beschreibung des speziellen Peha EEP Profils des Sensors.

Navigation

[0] Themen-Index

[*] Vorherige Sete

Zur normalen Ansicht wechseln