Autor Thema: MAX ECO Taster funktioniert nicht richtig  (Gelesen 765 mal)

Offline popperchris

  • Jr. Member
  • **
  • Beiträge: 98
MAX ECO Taster funktioniert nicht richtig
« am: 14 April 2021, 14:01:45 »
Hallo liebes Forum
Ich habe auf einem Raspberry FHEM installiert und mir mit einem Arduino Nano und einem CC1101, dazwischen eine Level shifter einen cul gebaut:
Das sind die Einträge in der fhem.cfg für den CUL:
define initialUsbCheck notify global:INITIALIZED usb create
setuuid initialUsbCheck 60744add-f33f-f198-05e2-290974561531a77b
define CUL0 CUL /dev/ttyUSB0@38400 1234
setuuid CUL0 60756f1d-f33f-f198-6831-51886f2fcce321fe
attr CUL0 model nanoCUL
attr CUL0 rfmode MAX


Dann den CM dafür aufgesetzt:
define cm CUL_MAX 123456
setuuid cm 6075904c-f33f-f198-3540-ba4c9d6f5461f9e7
attr cm IODev CUL0
attr cm fakeSCaddr 222222
attr cm fakeWTaddr 111111


Dann den ECO Taster angelernt:
define FlurObenSchlafzimmer MAX PushButton 13c12f
setuuid FlurObenSchlafzimmer 607597a8-f33f-f198-98ba-7a8c5d079686be26
attr FlurObenSchlafzimmer IODev cm
attr FlurObenSchlafzimmer debug 1
attr FlurObenSchlafzimmer event-on-change-reading .*
attr FlurObenSchlafzimmer model PushButton
attr FlurObenSchlafzimmer room MAX
define FileLog_FlurObenSchlafzimmer FileLog ./log/FlurObenSchlafzimmer-%Y.log FlurObenSchlafzimmer
setuuid FileLog_FlurObenSchlafzimmer 607597a8-f33f-f198-d0fe-9dfa75a46e1cc79b
attr FileLog_FlurObenSchlafzimmer logtype text
attr FileLog_FlurObenSchlafzimmer room MAX

Der CUL scheint zu funktionieren:
Er geht auf: CUL0 Initialized
und wenn ich die "get" Befehle ausführe bekommen ich zurück:
ccconf
freq:868.300MHz bWidth:101KHz rAmpl:33dB sens:8dB
cmds A B C E e F f G h i K k l M m R T t U V W X x Y Z z
credit10ms 548
fhtbuf AE
state Initialized
uptime 0 00:00:03
version V 1.67 nanoCUL868

auch bei dem "cm" sieht alles gut aus

Drücke ich bei dem Taster den "AUTO" oder "ECO" Taster blinkt in der Mitte die LED "3 mal".

Dann kommen in den "readings" von dem Taster ab und zu gar nicht, manchmal verzögert und wenn ich glück habe geht es sofort.

Wenn es geht kommt als reading
CUL0_RSSI                    -44
PairedTo                       000000
RSSI                            -44
SerialNr                     MKF0065343
battery                       ok
batteryState               ok
firmware                   1.0
gateway                     1
msgcnt                       1
onoff                          0
rferror                      1
state                    closed (rf error)
testresult                    0

Wenn es nicht funktioniert sehe ich auch "Event Monitor" nichts.

Jemand eine Idee was falsch ist oder fehlt ein "attr" ?
Oder kann ich mehr tracen um zu sehen wo vielleicht eine Meldung hängen bleibt ?

Vielen Dank für eure Hilfe

Grüße
Christoph





Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4501
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #1 am: 15 April 2021, 07:23:09 »
PairedTo                       000000
rferror                      1
Dein Taster ist nicht mit dem cm Device gepaired, schickt aber seine Nachrichten an irgend eine Zentrale die nicht antwortet. -> rf error
1. das cm Device auf verbose 5 stellen und schauen an wenn der ECO Tatster wirklich sendet und diese ID dann am cm statt der 123456 verwenden.
oder
2. ECO Taster Werksreset und dann mit dem cm pairen.
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline popperchris

  • Jr. Member
  • **
  • Beiträge: 98
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #2 am: 15 April 2021, 08:42:52 »
Morgen. Ich habe folgendes gemacht.

Alles auf Verbose 5 gesetzt und den Taster im FHEM nochmal gelöscht. Dann bei dem CUL0 und auch bei dem cm den Verbose auf 5 gesetzt.

Dann im cm den "setpair" gesetzt.
Am Taster den Eco Button länger als 3 Sekunden zum Pairen gedrückt.
Der Taster wurde auch im FHEM angelegt. Dann noch für den Taster das "event_on_change_reading" auf ".*" gesetzt.

Das sehe ich dann im LogFile von fhem:
2021.04.15 08:21:48 5: CUL0 sending Za123456
2021.04.15 08:21:48 5: SW: Za123456
2021.04.15 08:21:48 5: CUL0 sending Zw111111
2021.04.15 08:21:48 5: SW: Zw111111
2021.04.15 08:22:18 5: cm, BroadcastTime payload : 150f085612
2021.04.15 08:29:05 5: CUL/RAW: /Z1701040013C12F000000001005004D4
2021.04.15 08:29:05 5: CUL/RAW: Z1701040013C12F000000001005004D4/B463030363533343336^M

2021.04.15 08:29:05 4: CUL_Parse: CUL0 Z1701040013C12F000000001005004D4B463030363533343336 -47
2021.04.15 08:29:05 5: CUL0: dispatch Z1701040013C12F000000001005004D4B4630303635333433
2021.04.15 08:29:06 5: cm, IODev CUL0, len 23, msgcnt 01, msgflag 04, msgType PairPing, src 13c12f, dst 000000, group 0, payload 1005004D4B4630303635333433, rssi -47
2021.04.15 08:29:06 4: cm, PairPing (dst 000000, pairmode 1), firmware 16, type PushButton, testresult 0, serial MKF0065343
2021.04.15 08:29:06 3: cm, Pairing device MAX_13c12f of type PushButton with serial MKF0065343
2021.04.15 08:29:06 5: cm: dispatch MAX,0,define,13c12f,PushButton,MKF0065343,0
2021.04.15 08:29:06 5: MAX_Parse, MAX,0,define,13c12f,PushButton,MKF0065343,0
2021.04.15 08:29:06 3: MAX_PARSE, got message define for undefined device 13c12f type PushButton , autocreate is enabled
2021.04.15 08:29:06 2: autocreate: define MAX_13c12f MAX PushButton 13c12f
2021.04.15 08:29:06 2: autocreate: define FileLog_MAX_13c12f FileLog ./log/MAX_13c12f-%Y.log MAX_13c12f
2021.04.15 08:29:06 4: cm, send -> cmd:PairPong, msgcnt:01, flags:00, Cmd2id:01, src:MAX_123456 , dst:MAX_13c12f , gid:00 , payload:00 , cul:none
2021.04.15 08:29:06 5: cm, send packet: 0b01000112345613c12f0000
2021.04.15 08:29:06 5: cm, Send Queue 1 packet in queue
2021.04.15 08:29:06 5: SW: X
2021.04.15 08:29:06 5: CUL/RAW (ReadAnswer): 21  898^M

2021.04.15 08:29:06 5: cm, Send Queue CUL0 -> needPreamble: 1, necessaryCredit: 110, credit10ms: 898, CUL0 CMD_LAST_H: 2
2021.04.15 08:29:06 5: CUL0 sending Zs0b01000112345613c12f0000
2021.04.15 08:29:06 5: SW: Zs0b01000112345613c12f0000
2021.04.15 08:29:06 4: cm, Send Queue packet send : Zs0b01000112345613c12f0000 to MAX_13c12f with CUL0
2021.04.15 08:29:07 5: cm, Send Queue 1 packet in queue
2021.04.15 08:29:07 5: CUL/RAW: /Z0C01020213C12F12345600010039^M

2021.04.15 08:29:07 4: CUL_Parse: CUL0 Z0C01020213C12F12345600010039 -45.5
2021.04.15 08:29:07 5: CUL0: dispatch Z0C01020213C12F123456000100
2021.04.15 08:29:07 5: cm, IODev CUL0, len 12, msgcnt 01, msgflag 02, msgType Ack, src 13c12f, dst 123456, group 0, payload 0100, rssi -45.5
2021.04.15 08:29:07 5: cm, ACK from MAX_13c12f for cmd PairPong , packet will be removed soon
2021.04.15 08:29:07 5: cm, delete packet Index 0 in SendQueue direct !
2021.04.15 08:29:07 5: cm: dispatch MAX,1,Ack,13c12f,0100
2021.04.15 08:29:07 5: MAX_Parse, MAX,1,Ack,13c12f,0100
2021.04.15 08:29:07 5: MAX_Parse, MAX2,1,PushButtonState,13c12f,00
2021.04.15 08:29:07 5: MAX_13c12f, bat 0, rferror 0, onoff ?, langateway 0
2021.04.15 08:29:07 5: cm, Send Queue 0 packets in queue
2021.04.15 08:29:49 2: AttrTemplates: got 226 entries
2021.04.15 08:30:41 5: CUL/RAW: /Z0B01000212345613C12F000000^M
Z0C
2021.04.15 08:30:41 4: CUL_Parse: CUL0 Z0B01000212345613C12F000000 -74
2021.04.15 08:30:41 5: CUL0: dispatch Z0B01000212345613C12F0000
2021.04.15 08:30:41 5: cm, IODev CUL0, len 11, msgcnt 01, msgflag 00, msgType Ack, src 123456, dst 13c12f, group 0, payload 00, rssi -74
2021.04.15 08:30:41 4: cm, packet from ourselves or a other CUL [123456 / 0], - ignoring !
2021.04.15 08:30:41 5: CUL/RAW: Z0C/01025013C12F12345600100028^M

2021.04.15 08:30:41 4: CUL_Parse: CUL0 Z0C01025013C12F12345600100028 -54
2021.04.15 08:30:41 5: CUL0: dispatch Z0C01025013C12F123456001000
2021.04.15 08:30:41 5: cm, IODev CUL0, len 12, msgcnt 01, msgflag 02, msgType PushButtonState, src 13c12f, dst 123456, group 0, payload 1000, rssi -54
2021.04.15 08:30:41 5: cm: dispatch MAX,1,PushButtonState,13c12f,1000
2021.04.15 08:30:41 5: MAX_Parse, MAX,1,PushButtonState,13c12f,1000
2021.04.15 08:30:41 5: MAX_13c12f, bat 0, rferror 0, onoff 0, langateway 1
2021.04.15 08:31:11 5: CUL/RAW: /Z0B03000212345613C12F000000^M
2021.04.15 08:31:11 4: CUL_Parse: CUL0 Z0B03000212345613C12F000000 -74
2021.04.15 08:31:11 5: CUL0: dispatch Z0B03000212345613C12F0000
2021.04.15 08:31:11 5: cm, IODev CUL0, len 11, msgcnt 03, msgflag 00, msgType Ack, src 123456, dst 13c12f, group 0, payload 00, rssi -74
2021.04.15 08:31:11 4: cm, packet from ourselves or a other CUL [123456 / 0], - ignoring !
2021.04.15 08:31:11 5: CUL/RAW: Z0C/03025013C12F12345600100142^M

2021.04.15 08:31:11 4: CUL_Parse: CUL0 Z0C03025013C12F12345600100142 -41
2021.04.15 08:31:11 5: CUL0: dispatch Z0C03025013C12F123456001001
2021.04.15 08:31:11 5: cm, IODev CUL0, len 12, msgcnt 03, msgflag 02, msgType PushButtonState, src 13c12f, dst 123456, group 0, payload 1001, rssi -41
2021.04.15 08:31:11 5: cm: dispatch MAX,1,PushButtonState,13c12f,1001
2021.04.15 08:31:11 5: MAX_Parse, MAX,1,PushButtonState,13c12f,1001
2021.04.15 08:31:11 5: MAX_13c12f, bat 0, rferror 0, onoff 1, langateway 1
2021.04.15 08:32:01 5: CUL/RAW: /Z0B05000212345613C12F000000^M


Wenn ich den Taster drücke und es funktioniert nicht sehe ich auch nicht im LogFile.

Vielen Dank für eure Hilfe
Gruß
Christoph Langer


Offline popperchris

  • Jr. Member
  • **
  • Beiträge: 98
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #3 am: 15 April 2021, 11:57:58 »
Das sind immer Messages die ich sehe beim drücken eines Knopfes:
2021.04.15 11:44:18 5: CUL/RAW: /Z0B23000227089113C12F000000
Z0C
2021.04.15 11:44:18 4: CUL_Parse: CUL0 Z0B23000227089113C12F000000 -74
2021.04.15 11:44:18 5: CUL0: dispatch Z0B23000227089113C12F0000
2021.04.15 11:44:18 5: cm, IODev CUL0, len 11, msgcnt 23, msgflag 00, msgType Ack, src 270891, dst 13c12f, group 0, payload 00, rssi -74
2021.04.15 11:44:18 4: cm, packet from ourselves or a other CUL [270891 / 0], - ignoring !
2021.04.15 11:44:18 5: CUL/RAW: Z0C/23025013C12F27089100100042

2021.04.15 11:44:18 4: CUL_Parse: CUL0 Z0C23025013C12F27089100100042 -41
2021.04.15 11:44:18 5: CUL0: dispatch Z0C23025013C12F270891001000
2021.04.15 11:44:18 5: cm, IODev CUL0, len 12, msgcnt 23, msgflag 02, msgType PushButtonState, src 13c12f, dst 270891, group 0, payload 1000, rssi -41
2021.04.15 11:44:18 5: cm: dispatch MAX,1,PushButtonState,13c12f,1000
2021.04.15 11:44:18 5: MAX_Parse, MAX,1,PushButtonState,13c12f,1000
2021.04.15 11:44:18 5: MAX_13c12f, bat 0, rferror 0, onoff 0, langateway 1

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4501
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #4 am: 15 April 2021, 16:37:34 »
Alles auf Verbose 5 gesetzt und den Taster im FHEM nochmal gelöscht. Dann bei dem CUL0 und auch bei dem cm den Verbose auf 5 gesetzt.
a. Das ist kein Windows, also immer langsam mit dieser Löscherei ....
b. CUL0 hoch auf verbose 2 reicht völlig, der macht nur das log unötig voll.
c. Logs bitte immer in Code Tags posten, liest sich einfacher

d.  wer ist  270891 ? und warum meint  13c12f dahin etwas schicken zu müssen ?
Dann scheint da noch ein weiterer CUL oder Cube aktiv zu sein :
2021.04.15 08:30:41 4: cm, packet from ourselves or a other CUL [123456 / 0], - ignoring ! D.h. deine MAX Welt ist größer als du bisher hier verraten hast,
rück doch bitte mal mit vollständigen Infos raus. U.a auch woher stammt der ECO Taster ? Gebraucht gekauft ?

Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline popperchris

  • Jr. Member
  • **
  • Beiträge: 98
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #5 am: 16 April 2021, 08:20:36 »
Das ist mein erstes Device mit MAX.
Ich habe im Moment alles mit Homematic laufen und suche nach einem günstigen Taster um Lichtschalter im Flur zu ersetzen. Da ist mir der Max Eco Taster empfohlen worden.

Ehrlich gesagt denke ich das der Taster ein Problem hat. Ich habe ihn neu bei Amazon gekauft. Als er hier angekommen ist hatte ich das Gefühl das die Batterien die dabei waren schon ausgelaufen sind.

Danke für eure Hilfe

Hier meine fhem.cfg Datei:
attr global userattr cmdIcon devStateIcon:textField-long devStateStyle icon sortby webCmd webCmdLabel:textField-long widgetOverride
attr global autoload_undefined_devices 1
attr global autosave 0
attr global logfile ./log/fhem-%Y-%m.log
attr global modpath .
attr global motd SecurityCheck:\
  WEB is not password protected\
\
Protect this FHEM installation by defining an allowed device with define allowed allowed\
Running with root privileges is discouraged.\
You can disable this message with attr global motd none
attr global statefile ./log/fhem.save
attr global verbose 3

define WEB FHEMWEB 8083 global
setuuid WEB 60744adc-f33f-f198-3a02-793254fd91179910

# Fake FileLog entry, to access the fhem log from FHEMWEB
define Logfile FileLog ./log/fhem-%Y-%m.log fakelog
setuuid Logfile 60744add-f33f-f198-f871-81954c05edea67ab

define autocreate autocreate
setuuid autocreate 60744add-f33f-f198-0800-bc00b08c102cb04f
attr autocreate filelog ./log/%NAME-%Y.log

define eventTypes eventTypes ./log/eventTypes.txt
setuuid eventTypes 60744add-f33f-f198-d724-b28396d205c1a73d

# Disable this to avoid looking for new USB devices on startup
define initialUsbCheck notify global:INITIALIZED usb create
setuuid initialUsbCheck 60744add-f33f-f198-05e2-290974561531a77b
define CUL_MAX CUL /dev/ttyUSB0@38400 3011
setuuid CUL_MAX 60756f1d-f33f-f198-6831-51886f2fcce321fe
attr CUL_MAX model nanoCUL
attr CUL_MAX rfmode MAX
attr CUL_MAX verbose 5
define cm CUL_MAX 113096
setuuid cm 60782090-f33f-f198-bb5e-5e059800212434bb
attr cm IODev CUL_MAX
attr cm debug 1
attr cm fakeSCaddr 222222
attr cm fakeWTaddr 111111
attr cm verbose 5
define MAX_13c12f MAX PushButton 13c12f
setuuid MAX_13c12f 607821fe-f33f-f198-d183-eb093fc3157c1fde
attr MAX_13c12f IODev cm
attr MAX_13c12f event-on-change-reading .*
attr MAX_13c12f model PushButton
attr MAX_13c12f room MAX
attr MAX_13c12f verbose 1
define FileLog_MAX_13c12f FileLog ./log/MAX_13c12f-%Y.log MAX_13c12f
setuuid FileLog_MAX_13c12f 607821fe-f33f-f198-a2fa-12df1d5d60d530ac
attr FileLog_MAX_13c12f logtype text
attr FileLog_MAX_13c12f room MAX

« Letzte Änderung: 17 April 2021, 07:32:15 von Wzut »

Offline Wzut

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 4501
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #6 am: 17 April 2021, 07:42:12 »
Da hat dir aber IMHO jemand einen ganz schlechten Rat gegeben. Wenn du schon HM hast würde ich dabei bleiben und nicht mit etwas anfangen das eh vom Hersteller abgekündigt ist und noch dazu immer ein laufendes FHEM als Brücke benötigt.

Aber du musst bei dir entweder mal Ordung machen oder dich entscheiden woher du die Infos beziehst die du hier postet, das wird immer verworrener.
Bsp aus deiner config :
define cm CUL_MAX 113096
im ertsen Post und in den Logs :
define cm CUL_MAX 123456

entscheide dich bitte welche ID du wirklich verwenden möchtest und verpasse dem Taster einen Weksreset. 
Maintainer der Module: MAX, MPD, UbiquitiMP, UbiquitiOut, SIP, BEOK, readingsWatcher

Offline popperchris

  • Jr. Member
  • **
  • Beiträge: 98
Antw:MAX ECO Taster funktioniert nicht richtig
« Antwort #7 am: 05 Mai 2021, 18:34:39 »
Funktioniert übrigens jetzt
War wohl mein selbstgebastelter CUL. Ein original von BusWare geht

 

decade-submarginal