Autor Thema: FHEMWEB komplett abschalten und durch apache2 ersetzen?  (Gelesen 2044 mal)

Offline JoWiemann

  • Tester
  • Hero Member
  • ****
  • Beiträge: 3185
Antw:FHEMWEB komplett abschalten und durch apache2 ersetzen?
« Antwort #15 am: 16 April 2021, 20:18:02 »

Nachdem ich jetzt nochmal mitbekommen habe, dass das Thema FHEM@Fritzbox nicht mehr gerne gelesen wird, werde ich hoffentlich nichts mehr dazu schreiben.


Hm, das ist nur gefühlt so. Ist so ähnlich, wie Fhem unter Windows. Bei einem entsprechenden Post schauen alle erst einmal verdutzt und reagieren dann mit: Ach du schei... Mach doch so etwas nicht. Aber ich glaube, am ende wird immer irgendwie eine Lösung gefunden.

Grüße Jörg
Jörg Wiemann

Slave: RPi B+ mit 512 MB, COC (868 MHz), CUL V3 (433.92MHz SlowRF); FHEMduino, Aktuelles FHEM

Master: CubieTruck; Debian; Aktuelles FHEM

Offline sven.luebke

  • New Member
  • *
  • Beiträge: 14
Antw:FHEMWEB komplett abschalten und durch apache2 ersetzen?
« Antwort #16 am: 16 April 2021, 22:30:57 »
Hm, das ist nur gefühlt so. Ist so ähnlich, wie Fhem unter Windows. Bei einem entsprechenden Post schauen alle erst einmal verdutzt und reagieren dann mit: Ach du schei...
Dann ist ja gut :D. Ich hatte schon ein schlechtes Gewissen...gerade nach dem Kommentar von Rudolf  :)

Ich habe bei der Abfrage der TCP-Socket Buffersize noch etwas Interessantes gefunden. Der Text "The default..." gibt immer an, welche Socket-Buffersize als Default konfiguriert war. Im ersten Fall also 23720 für Send. Ich vergrößere den Wert dann auf 262KB . Später scheint der Wert sogar auf 664070 geändert worden zu sein. Dann wieder zurück auf den ersten Wert. Erklären kann ich mir das nicht...es sei denn perl oder FHEM macht das noch irgendwo anders. Vielleicht ist das der Grund, warum der Aufruf der FHEM-Seite manchmal funktionierte und ganz oft nicht. Jetzt ist die Geschwindigkeit MEHR als perfekt für mich: Das Anzeigen des Logfiles hat vorher manchmal so ca. 5s gedauert. Jetzt dauert es keine Sekunde mehr.

The default sndsize = 23720
The default rcvsize = 87380
The modified sndsize = 262144
The modified recvsize = 262144
TcpServer_WriteBlocking
TcpServer_Wait
Socket geöffnet!
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Accept
The default sndsize = 664070
The default rcvsize = 262094
The modified sndsize = 262144
The modified recvsize = 262144
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Close
TcpServer_Accept
The default sndsize = 664070
The default rcvsize = 262094
The modified sndsize = 262144
The modified recvsize = 262144
TcpServer_Close
TcpServer_Accept
The default sndsize = 23720
The default rcvsize = 87380
The modified sndsize = 262144
The modified recvsize = 262144
TcpServer_Accept
The default sndsize = 23720
The default rcvsize = 87380
The modified sndsize = 262144

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 4428
Antw:FHEMWEB komplett abschalten und durch apache2 ersetzen?
« Antwort #17 am: 22 April 2021, 13:53:15 »
Nein, es ist alles aktuell, also Fritz!OS 7.21 .
Es war aktuell. Heute kam die 7.26 raus. https://avm.de/service/downloads/?product=fritzbox-7490

Offline sven.luebke

  • New Member
  • *
  • Beiträge: 14
Antw:FHEMWEB komplett abschalten und durch apache2 ersetzen?
« Antwort #18 am: 13 Juli 2021, 18:05:08 »
Hallo, ich mal wieder!

Ich hab mir nun extra etwas Zeit gelassen, um die Fritzbox und FHEM intensiv zu testen. Ich kann nach einer 3-monatigen Testphase nun sagen, dass ich mit der gesamten Geschwindigkeit zu 95% SEHR zufrieden bin und ich bin hinsichtlich des Themas "Webseiten anschauen" schnell sehr ungeduldig. Es gibt allerdings wirklich ein paar Aktionen, die man in FHEM auf der Fritzbox nicht unbedingt so oft machen sollte
  • updates und dann erwarten, dass man in 30s weiter "arbeiten" kann:
    2021.07.13 17:30:53 1 : Calling /var/media/ftp/usr/bin/perl /var/media/ftp/opt/fhem/contrib/commandref_join.pl -noWarnings, this may take a while
    2021.07.13 17:36:47 1 :
    Wie man sieht, dauert die Aktion 6min.
  • Select icon oder Extend devStateIcon sollte man auch nicht anwählen. Danach ist das System lange beschäftigt. SVG Plots klappen wunderbar und dauern 4-10s (je nach Grafikumfang)

Weil ich gerade viel beschäftigt war (und bin), hatte ich für 1035,4h gerade keine Zeit für FHEM. Ein Klick und die Seite öffnet sich, keine Verzögerungen und der VmHWM-Wert liegt bei 52MB.
Man muss dazu sagen, dass ich kein Haus habe, sondern nur eine Wohnung. Die vernetzten Geräte halten sich also im Rahmen. Tasmota (inkl. MQTT), direkt angeschlossenem MapleCUL (mit einem 433 und 868MHZ-Modul) sowie haufenweise angemeldeten Rauchmeldern, Heizkostenverteilern und Temperatur-Modulen.

Mit der Standard-Einstellung der Fritzbox hat man allerdings wirklich wenig Spaß, weil sich FHEM scheinbar dauernd aufhängen kann (das war der eigentliche Grund für diesen Thread). Abhilfe hat die Erstellung der Datei sysctl.conf mit folgendem Inhalt gebracht
net.ipv4.tcp_rmem=32768 262144 1934144
net.ipv4.tcp_wmem=32768 262144 1934144
net.core.optmem_max=20480
net.ipv4.tcp_rmem=32768
net.ipv4.udp_rmem_min=16384
Diese muss man beim Start mittels
/sbin/sysctl -p $PFAD_ZU_DEN_EINSTELLUNGEN/conf/sysctl/sysctl.confladen. Danach ist das System zu 100% stabil und bleibt nicht mehr hängen. Falls jemand FHEM ohne diese Settings testet, dann ist klar, dass man keinen Spaß daran haben kann. Allein das Anzeigen des Logfiles hat vorher ewig gedauert. Jetzt ist es "einfach" da. ICh bin überzeugt davon, dass man mit einer 7590 noch mehr Spaß haben kann...ich war allerdings zu geizig mir deswegen eine zu kaufen. Sehen würde ich es aber schon gerne mal...

Fazit
Fritzbox und FHEM? Immer noch eine klare Empfehlung von mir, wenn man ein bisschen Energie sparen möchte und mit ein paar kleinen Einschränkungen leben kann. Ich muss allerdings auch sagen, dass ich von meinem Pi4 4GB beeindruckt war, der im hochgefahrenen Zustand gerade mal 3,5W gezogen hat.
« Letzte Änderung: 13 Juli 2021, 18:06:59 von sven.luebke »

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 24474
Antw:FHEMWEB komplett abschalten und durch apache2 ersetzen?
« Antwort #19 am: 13 Juli 2021, 18:15:46 »
Zitat
Wie man sieht, dauert die Aktion 6min.
attr global commandref modular

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17435
  • s/fhem\.cfg/configDB/g
Antw:FHEMWEB komplett abschalten und durch apache2 ersetzen?
« Antwort #20 am: 28 Juli 2021, 21:50:00 »
attr global commandref modular

Alternativ:

Das globale Attribut exclude_from_update um den Eintrag "commandref" erweitern, dann wird überhaupt keine lokale commandref mehr erzeugt.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!