FHEM > English Corner

CUL: No answer

(1/4) > >>

kennybl:
Hello,

Last week i connected my CUL again to start using my new program. It works good except that the cul loses connection multiple times a day.

I get:
CUL: No answer


I see a strange thing after restarting fhem:


--- Code: ---2021.04.02 07:58:31 1: usb create starting
2021.04.02 07:58:31 3: Probing ZWDongle device /dev/serial1
2021.04.02 07:58:31 3: Probing CUL device /dev/ttyAMA0
2021.04.02 07:58:32 3: Probing TCM_ESP3 device /dev/ttyAMA0
2021.04.02 07:58:32 3: Probing ZWDongle device /dev/ttyAMA0
2021.04.02 07:58:32 3: Probing SIGNALDuino device /dev/ttyAMA0
2021.04.02 07:58:32 3: Probing MYSENSORS device /dev/ttyAMA0
2021.04.02 07:58:32 3: Probing ArduCounter device /dev/ttyAMA0
2021.04.02 07:58:32 3: Probing ElsnerWS device /dev/ttyAMA0
2021.04.02 07:58:33 3: Probing FRM device /dev/ttyAMA0
2021.04.02 07:58:39 3: Probing TCM_ESP3 device /dev/ttyUSB0
2021.04.02 07:58:39 3: Probing TCM_ESP2 device /dev/ttyUSB0
2021.04.02 07:58:39 3: Probing FHZ device /dev/ttyUSB0
2021.04.02 07:58:39 3: Probing TRX device /dev/ttyUSB0
2021.04.02 07:58:40 3: Probing ZWDongle device /dev/ttyUSB0
2021.04.02 07:58:40 3: Probing SIGNALDuino device /dev/ttyUSB0
2021.04.02 07:58:40 3: Probing MYSENSORS device /dev/ttyUSB0
2021.04.02 07:58:40 3: Probing ArduCounter device /dev/ttyUSB0
2021.04.02 07:58:40 3: Probing ElsnerWS device /dev/ttyUSB0
2021.04.02 07:58:41 3: Probing FRM device /dev/ttyUSB0
2021.04.02 07:58:59 3: Probing TCM_ESP3 device /dev/ttyUSB_RELAY
2021.04.02 07:58:59 3: Probing TCM_ESP2 device /dev/ttyUSB_RELAY
2021.04.02 07:58:59 3: Probing FHZ device /dev/ttyUSB_RELAY
2021.04.02 07:58:59 3: Probing TRX device /dev/ttyUSB_RELAY
2021.04.02 07:59:00 3: Probing ZWDongle device /dev/ttyUSB_RELAY
2021.04.02 07:59:00 3: Probing SIGNALDuino device /dev/ttyUSB_RELAY
2021.04.02 07:59:00 3: Probing MYSENSORS device /dev/ttyUSB_RELAY
2021.04.02 07:59:00 3: Probing ArduCounter device /dev/ttyUSB_RELAY
2021.04.02 07:59:01 3: Probing ElsnerWS device /dev/ttyUSB_RELAY
2021.04.02 07:59:02 3: Probing FRM device /dev/ttyUSB_RELAY
2021.04.02 07:59:07 1: usb create end
--- Ende Code ---


I see ttyUSB0 and ttyUSB_RELAY (a name i gave to a relayboard connected via USB).
I am not sure if it always happens but after i turn on or off a relay, i think the cul "crashes".

The connection to the cul is this:

--- Code: ---/dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0@38400 0000

--- Ende Code ---

Did i do something wrong, is above just normal or is my USB cable wrong for example?

Thanks a lot!

KölnSolar:

--- Zitat ---is above just norma
--- Ende Zitat ---
No. You should remove usb commands in Your FHEM-config.

kennybl:
i should comment this part?


--- Code: ---# Disable this to avoid looking for new USB devices on startup
define initialUsbCheck notify global:INITIALIZED usb create
setuuid initialUsbCheck 5f847b85-f33f-c04f-3b46-18d1c7338ccc398c
--- Ende Code ---


I commented both lines, but as soon as i set a relay, fhem reports this line in the log:


--- Code: ---2021.04.18 10:36:57 1: /dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0 disconnected, waiting to reappear (CUL)

--- Ende Code ---

It won't reappear until i restart fhem

KölnSolar:

--- Zitat ---i should comment this part?
--- Ende Zitat ---
yes.

--- Zitat ---It won't reappear until i restart fhem
--- Ende Zitat ---
Seems to be a problem with your relay board. Is it defined in FHEM too ? Otherwise its an OS-issue. What shows
--- Code: ---ls -l /dev/serial/by-id
--- Ende Code ---
?

kennybl:

--- Code: ---$ ls -l /dev/serial/by-id
total 0
lrwxrwxrwx 1 root root 13 Apr 18 11:07 usb-1a86_USB2.0-Serial-if00-port0 -> ../../ttyUSB1
lrwxrwxrwx 1 root root 13 Apr 18 10:53 usb-Prolific_Technology_Inc._USB-Serial_Controller_D-if00-port0 -> ../../ttyUSB0
--- Ende Code ---

The relayboard is a 8-chanel Conrad relayboard (https://www.conrad.nl/p/conrad-components-197730-relaiskaart-module-12-vdc-197730), sometimes it works great but sometimes it crashes too after setting some relays.

This doesn't happen all the time but all the them FHEM loses connection to the usb CUL

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln