Autor Thema: [gelöst] Kein Event zigbee2mqtt Geräten mittels MQTT2_DEVICE  (Gelesen 304 mal)

Offline Thomas X

  • Jr. Member
  • **
  • Beiträge: 79
Hallo zusammen,

ich habe jetzt meine Zigee2MQTT Devices von MQTT auf MQTT2 (mit MQTT_CLIENT und MQTT_DEVICE) migriert. Das funktioniert auch soweit, dass alle Devices da sind und auch alle Readings aktuallisiert werden. Allerdings lösen Updates bzw. Changes an Readings keine Events aus. Somit kann ich auf die Buttons oder Bewegungsmelder nicht mehr reagieren.

Was muss hier noch beachtet werden? Ich habe nichts dazu finden können.  :-\
« Letzte Änderung: 17 Juni 2021, 18:35:33 von Thomas X »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16884
Antw:Kein Event zigbee2mqtt Geräten mittels MQTT2_DEVICE
« Antwort #1 am: 17 Juni 2021, 17:58:45 »
Gehe mal davon aus, dass MQTT2_CLIENT und MQTT2_DEVICE gemeint sind?

Vielleicht zeigst du mal ein list oder eine RAW-Definition von einem der (MQTT2_DEVICE-) Devices? Das klingt mir nach ungünstig gesetzten "event-on..."-Attributen.
Server: HP-T620@Debian 11, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline Thomas X

  • Jr. Member
  • **
  • Beiträge: 79
Antw:Kein Event zigbee2mqtt Geräten mittels MQTT2_DEVICE
« Antwort #2 am: 17 Juni 2021, 18:34:56 »
Ja, Es sind MQTT2_CLIENT und MQTT2_DEVICE gemeint. Da liegt genau das Problem!

Ich habe es jetzt doch gefunden: Beim Umbenennen wird dann der "friendly Name" nicht im zigbee2mqtt geändert. Ist also hier gelöst. Sorry!

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16884
Antw:[gelöst] Kein Event zigbee2mqtt Geräten mittels MQTT2_DEVICE
« Antwort #3 am: 17 Juni 2021, 19:46:15 »
Kein Problem.

Hinweis bei der Gelegenheit: friendly names sind mAn. nicht zu empfehlen, würde auf der z2m-Ebene auf den "Technames" bleiben.
Server: HP-T620@Debian 11, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline Thomas X

  • Jr. Member
  • **
  • Beiträge: 79
Antw:[gelöst] Kein Event zigbee2mqtt Geräten mittels MQTT2_DEVICE
« Antwort #4 am: 18 Juni 2021, 07:11:52 »
Ja, das sehe ich jetzt genauso. An der Stelle hilft die Bequemlichkeit nichts, sonder ist eher kontraproduktiv.