Autor Thema: WT-Ausführung nur bis zu einer bestimmten Uhrzeit  (Gelesen 880 mal)

Offline juemuc

  • Hero Member
  • *****
  • Beiträge: 1000
WT-Ausführung nur bis zu einer bestimmten Uhrzeit
« am: 14 Juli 2021, 19:33:31 »
Hallo,

ich habe einen WT, definiert, der bei Sonnenuntergang eine Lampe einschaltet. Nun möchte ich, dass dies aber nur bis 20:30 Uhr erfolgt. Danach soll einfach nichts passieren. Was muss ich ändern?
Hier die Definition:
defmod Esszimmerlampe_WT WeekdayTimer Esszimmerlampe_WT_dummy de 1234560|{sunset_abs("REAL",0,"00:00","23:59")}|on
attr Esszimmerlampe_WT commandTemplate set $NAME  $EVENT
attr Esszimmerlampe_WT devStateStyle style="text-align:right"
attr Esszimmerlampe_WT disable 1
attr Esszimmerlampe_WT group Schaltzeitpunkte
attr Esszimmerlampe_WT room Schaltzentrale,Wohnzimmer
attr Esszimmerlampe_WT stateFormat {my $val;;\
 if (ReadingsVal($name, "disabled","") eq "1") {$val = "AUS"}\
 else {$val = ReadingsVal($name, "currValue","")};;\
 $val}
Viele Grüße
Jürgen
3x Sonos Play 1, 1x Sonos Arc + Sub, 1 Sonos-One, 1x Sonos Playbar
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate,  raspberry3, HM Funkmodul HM-MOD-RPI-PCB, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und  Amazon Echo Dot, raspberry3B+ mit RPI-RF-MOD und piVCCU, Raspbian Buster Lite

Offline juemuc

  • Hero Member
  • *****
  • Beiträge: 1000
Antw:WT-Ausführung nur bis zu einer bestimmten Uhrzeit
« Antwort #1 am: 14 Juli 2021, 22:23:24 »
Ich hoffe, ich konnte das Problem mit folgender "condition" lösen.
(ReadingsVal("Uhrzeit","state","") le "20:30")

Erste Tests waren zumindest erfolgreich.

Viele Grüße
Jürgen
3x Sonos Play 1, 1x Sonos Arc + Sub, 1 Sonos-One, 1x Sonos Playbar
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate,  raspberry3, HM Funkmodul HM-MOD-RPI-PCB, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und  Amazon Echo Dot, raspberry3B+ mit RPI-RF-MOD und piVCCU, Raspbian Buster Lite

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15568
Antw:WT-Ausführung nur bis zu einer bestimmten Uhrzeit
« Antwort #2 am: 15 Juli 2021, 11:39:35 »
...weiß nicht...

CONDITION ist eigentlich dazu gedacht, einen WDT für den ganzen Tag zu deaktivieren, was für den gestrigen Tag wohl auch gepaßt hat. Würde eher annehmen, dass man das mit einer Perl-Anweisung lösen muss, die wird immer zum Auslösezeitpunkt evaluiert:
{fhem("set @ $EVENT") if ReadingsVal('Uhrzeit','state','') le '20:30'}
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline juemuc

  • Hero Member
  • *****
  • Beiträge: 1000
Antw:WT-Ausführung nur bis zu einer bestimmten Uhrzeit
« Antwort #3 am: 15 Juli 2021, 22:22:54 »
Hallo Beta-User,

da das Ereignis (Sonnenuntergang) ja nur einmal am Tag eintritt, musste es ja passen. Aktuell habe ich das ganze Device noch auf disabled, da ich ja weiß, dass der Sonnenuntergang (bei uns) nach 20:30 Uhr ist.
Ich werde aber weiter testen (auch Dein Tipp) und berichten.

Viele Grüße
Jürgen
3x Sonos Play 1, 1x Sonos Arc + Sub, 1 Sonos-One, 1x Sonos Playbar
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate,  raspberry3, HM Funkmodul HM-MOD-RPI-PCB, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und  Amazon Echo Dot, raspberry3B+ mit RPI-RF-MOD und piVCCU, Raspbian Buster Lite

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15568
Antw:WT-Ausführung nur bis zu einer bestimmten Uhrzeit
« Antwort #4 am: 16 Juli 2021, 07:05:15 »
Hmm, ja, du hast natürlich recht, dass das bei einem Schaltzeitpunkt auch so hinhaut :) .
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}