Autor Thema: 76_SMAInverter.pm - Abfrage von SMA Wechselrichter  (Gelesen 162470 mal)

Offline ClausL

  • Jr. Member
  • **
  • Beiträge: 65
Antw:76_SMAInverter.pm - Abfrage von SMA Wechselrichter
« Antwort #1020 am: 03 Mai 2022, 15:33:19 »
Hallo,

anscheinend hat niemand eine Idee. Darum antworte ich mir mal selber. ;-) Und siehe da, seit heute morgen läuft es wieder. Dabei habe ich überhaupt nichts verändert. Eigentlich glaube ich das nie, wenn das jemand zu mir sagt. Aber nun erlebe ich es selber. Merkwürdig.

Viele Grüße, Claus

Offline thobo

  • New Member
  • *
  • Beiträge: 19
Antw:76_SMAInverter.pm - Abfrage von SMA Wechselrichter
« Antwort #1021 am: 16 Mai 2022, 21:53:18 »
Hallo zusammen,

ich bin mir fast Sicher, dass mein Problem keines vom SMAInverter Modul ist, aber ich weiß nicht, wo ich sonst anfragen kann. Seit ca. einer Woche habe ich das Problem, dass ich unten angehängte Fehlermeldung erhalte. Diese habe ich zwischendurch immer mal wieder bekommen, nun bekomme ich sie aber ausschließlich und somit auch keine Daten mehr von meinem Tripower 20000. Selbst der Login über den Sunny Explorer klappt nur "teilweise", ich bekomme keine aktuellen Daten, sondern nur Infos über Satus und Firmeware Version. Auch im Sunny Portal kommen keine Daten mehr an.
Vielleicht hat ja jmd. eine Idee, was passiert sein könnte oder noch besser, wie ich es wieder flott bekomme?

2022.05.16 21:30:05.193 3: SMAInverter SmaInverter - WARNING - old process 6908 will be killed now to start a new BlockingCall
2022.05.16 21:30:05.194 1: SMAInverter SmaInverter -> BlockingCall SMAInverter_getstatusDoParse Timeout: process terminated
2022.05.16 21:30:05.198 4: SmaInverter - ###############################################################
2022.05.16 21:30:05.199 4: SmaInverter - ##########  Begin of new SMAInverter get data cycle  ##########
2022.05.16 21:30:05.199 4: SmaInverter - ###############################################################
2022.05.16 21:30:05.199 4: SmaInverter - timeout cycles since module start: 3
2022.05.16 21:30:05.247 4: SmaInverter -> Start BlockingCall SMAInverter_getstatusDoParse
2022.05.16 21:30:05.376 4: SmaInverter - current time: 16.05.2022 21:30:05
2022.05.16 21:30:05.377 4: SmaInverter - operation time begin: 16.05.2022 05:00:46
2022.05.16 21:30:05.377 4: SmaInverter - operation time end: 16.05.2022 22:03:49
2022.05.16 21:30:05.379 5: SmaInverter - STP 20000TL-30
2022.05.16 21:30:05.394 4: SmaInverter - Send login to SMA-Wechselrichter.fritz.box on Port 9522 with password xxxxxxxx
2022.05.16 21:30:05.394 5: SmaInverter - Send: 534D4100000402A000000001003A001060650EA0......E9BABDBCBF8888888800000000

Offline DS_Starter

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7828
Antw:76_SMAInverter.pm - Abfrage von SMA Wechselrichter
« Antwort #1022 am: 16 Mai 2022, 22:24:23 »
Dein WR antwortet nicht mehr. Dadurch kommt es zu den timeouts:

2022.05.16 21:30:05.193 3: SMAInverter SmaInverter - WARNING - old process 6908 will be killed now to start a new BlockingCall
2022.05.16 21:30:05.194 1: SMAInverter SmaInverter -> BlockingCall SMAInverter_getstatusDoParse Timeout: process terminated

Da auch keine Daten an SMA geliefert werden bzw. es mt dem Sunny Explorer auch nicht richtig funktioniert gehe ich davon aus dass in der Kommunikationseinheit im WR etwas defekt/abgestürzt ist.
Möglicherweise reicht es mal den WR neu zu starten. Also komplett vom Netz trennen + Neustart.
ESXi 6.5 @NUC6i5SYH mit FHEM auf Debian 10, DbLog/DbRep mit MariaDB auf VM
Maintainer: SSCam, SSChatBot, SSCal, SSFile, DbLog/DbRep, Log2Syslog, SolarForecast,Watches, Dashboard
Kaffeekasse: https://www.paypal.me/HMaaz
Contrib: https://svn.fhem.de/trac/browser/trunk/fhem/contrib/DS_Starter

Offline thobo

  • New Member
  • *
  • Beiträge: 19
Antw:76_SMAInverter.pm - Abfrage von SMA Wechselrichter
« Antwort #1023 am: 16 Mai 2022, 23:25:30 »
Ich habe es mir fast gedacht, mich aber nicht getraut. Nun habe ich den Wechselrichter einfach restartet und siehe da, es funktioniert wieder alles!!

DANKE!!!

Offline MadMax

  • Full Member
  • ***
  • Beiträge: 343
Antw:76_SMAInverter.pm - Abfrage von SMA Wechselrichter
« Antwort #1024 am: Gestern um 11:50:41 »
Hallo,

ich habe seit kurzem ein Problem in meiner Energiebilanz. Der Wert PVErzeugung Heute steht dauerhaft auf 0. Dabei sind die Werte für den Monat und das Jahr aber plausibel. Auch der aktuelle Wert passt. Ich habe im relevanten Wechselrichter (SMA Tripower 8.0) noch ein Userreading im Verdacht gehabt (eingefügt für Solarforcast). Aber löschen hat nichts verändert. Wenn ich den Code richtig verstehe, dann kommen die Werte aus dem Reading etoday des Inverters. Dieses Reading (und auch das Reading etoday_fc) scheinen sich aber nicht zu verändern. Der dort angezeigte Wert hat auch nichts mit den realen Daten zu tun (4294967.295).

Ich habe mal das Device auf Verbose 5 gesetzt und das Resultat hier angehängt. Vieleicht kann mir ja jemand beim Suchen helfen.

Viele Grüße, Claus

Hallo,

Ich dachte ich hätte das Problem behoben da es schon lange nicht mehr aufgetreten war und bei selber auch nicht.
Ich werde mir dein LOG mal in Ruhe ansehen.

Gruß
Max
Raspberry Pi 4B 4GB mit FHEM 6.0, Siemens Logo 0BA7, Homematic CCU3, Philips HUE

Contrib: https://svn.fhem.de/trac/browser/trunk/fhem/contrib/MadMax

 

decade-submarginal