Autor Thema: weewx-fhem - Erfahrungen?  (Gelesen 4964 mal)

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 365
Antw:weewx-fhem - Erfahrungen?
« Antwort #15 am: 05 März 2020, 09:30:07 »
Wenn ich die Zeile mit filter:TYPE=MQTT2_DEVICE weglösche, dann taucht der Eintrag weewx_weather_station auf. Wenn ich dann set WetterstationTest attrTemplate weewx_weather_station ausführen will kommt die Fehlermeldung
Unknown template_entry_name weewx_weather_station
Viele Grüße

Martin

Raspi 4 mit Raspian, FHEM, Signalduino 433MHz & 868MHz, MAX!, WeeWX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16860
Antw:weewx-fhem - Erfahrungen?
« Antwort #16 am: 05 März 2020, 09:36:57 »
Hmm, schräg...

Kann im Moment nicht sagen, woran es hängt. Vorschlag: Ich packe das beim nächsten update allgemein mit rein, und wir schauen dann, ob es erwartungsgemäß läuft oder was zu verbessern gibt?
 Dazu bitte die file einfach wieder löschen, sonst kommen Warnungen wegen doppelter Einträge.
Server: HP-T620@Debian 11, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16860
Antw:weewx-fhem - Erfahrungen?
« Antwort #17 am: 05 März 2020, 19:19:23 »
...ist jetzt im svn, ab morgen via update...
Server: HP-T620@Debian 11, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 365
Antw:weewx-fhem - Erfahrungen?
« Antwort #18 am: 05 März 2020, 21:22:28 »
Alles klar, ich werde es mal checken, so schwer kann das ja nicht sein.
Ich weiß auch nicht was da los war, das mit den Rechten war OK, lesen konnte er es auch...

Grüße Martin
Viele Grüße

Martin

Raspi 4 mit Raspian, FHEM, Signalduino 433MHz & 868MHz, MAX!, WeeWX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 365
Antw:weewx-fhem - Erfahrungen?
« Antwort #19 am: 06 März 2020, 10:48:15 »
Hallo Beta-User,

sieht gut aus! Alles so wie gewünscht. Ich werde es auf mein Produktivdevice auch anwenden.

Nur ein zwei Details:

- im Status zwischen der Temperatur bzw. rel. Feucht und der jeweiligen Einheit noch ein Leerzeichen so wie beim Luftdruck
- Für Hilfe werde ich noch etwas zusammenstellen und hier posten.

Vielen Dank und viele Grüße

Martin
Viele Grüße

Martin

Raspi 4 mit Raspian, FHEM, Signalduino 433MHz & 868MHz, MAX!, WeeWX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline Jens_B

  • Full Member
  • ***
  • Beiträge: 400
Antw:weewx-fhem - Erfahrungen?
« Antwort #20 am: 17 Juni 2020, 13:16:38 »
Falls es jemand interessiert, ich nutze seit jahren folgendes weewxskin
https://github.com/matthewwall/weewx-fhem


das erzeugt ein Textfile, was man einfach per httpmod aus fhem auslesen kann.
defmod WEATHERSTATION HTTPMOD http://192.168.178.14/weewx/fhem/fhem.txt 300
attr WEATHERSTATION userattr enableControlSet reading01Name reading01OExpr reading01Regex reading02Name reading02OExpr reading02Regex reading03Name reading03OExpr reading03Regex reading04Name reading04OExpr reading04Regex reading05Name reading05OExpr reading05Regex reading06Name reading06OExpr reading06Regex reading07Name reading07OExpr reading07Regex reading08Name reading08OExpr reading08Regex reading09Name reading09OExpr reading09Regex reading10Name reading10OExpr reading10Regex reading11Name reading11OExpr reading11Regex reading12Name reading12OExpr reading12Regex reading13Name reading13OExpr reading13Regex
attr WEATHERSTATION enableControlSet 1
attr WEATHERSTATION homebridgeMapping CurrentTemperature=Aussentemperatur
attr WEATHERSTATION reading01Name Innentemperatur
attr WEATHERSTATION reading01OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading01Regex inTemp: ([\d\.-]+)
attr WEATHERSTATION reading02Name Aussentemperatur
attr WEATHERSTATION reading02OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading02Regex outTemp: ([\d\.-]+)
attr WEATHERSTATION reading03Name Luftfeuchtigkeit_Innen
attr WEATHERSTATION reading03OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading03Regex inHumidity: ([\d\.-]+)
attr WEATHERSTATION reading04Name Luftfeuchtigkeit_Aussen
attr WEATHERSTATION reading04OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading04Regex outHumidity: ([\d\.-]+)
attr WEATHERSTATION reading05Name Taupunkt
attr WEATHERSTATION reading05OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading05Regex dewpoint: ([\d\.-]+)
attr WEATHERSTATION reading06Name Windgeschwindigkeit
attr WEATHERSTATION reading06OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading06Regex windspeed: ([\d\.-]+)
attr WEATHERSTATION reading07Name Windrichtung
attr WEATHERSTATION reading07OExpr {sprintf("%s", $val)}
attr WEATHERSTATION reading07Regex winddirection: ([A-Z/\-]+)
attr WEATHERSTATION reading08Name Luftdruck_Trend
attr WEATHERSTATION reading08OExpr {sprintf("%.0f", $val)}
attr WEATHERSTATION reading08Regex pressureTrend: ([\d\.-]+)
attr WEATHERSTATION reading09Name Luftdruck
attr WEATHERSTATION reading09OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading09Regex pressure: ([\d\.-]+)
attr WEATHERSTATION reading10Name Regen
attr WEATHERSTATION reading10OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading10Regex rain: ([\d\.-]+)
attr WEATHERSTATION reading11Name WindDurchschnitt
attr WEATHERSTATION reading11OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading11Regex windaverage: ([\d\.-]+)
attr WEATHERSTATION reading12Name Regen_heute
attr WEATHERSTATION reading12OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading12Regex rainDay: ([\d\.-]+)
attr WEATHERSTATION reading13Name Windboen
attr WEATHERSTATION reading13OExpr {sprintf("%.1f", $val)}
attr WEATHERSTATION reading13Regex windgust: ([\d\.-]+)
attr WEATHERSTATION room Homekit,System
attr WEATHERSTATION timeout 8
attr WEATHERSTATION userReadings humidity { ReadingsVal("WEATHERSTATION","Luftfeuchtigkeit_Aussen",0);; }, rain { ReadingsVal("WEATHERSTATION","Regen",0);; }

so sieht das dann bei mir aus.


Vielleicht kann mir jemand dafür helfen, wo ich für meine WS1080 von Conrad den Sender als Ersatzteil bekomme...
RaspberryPi 3 (Raspian Buster)FHEM+Homebridge
HMLAN für Homematic
Z-Wave USB Stick
Pilight
Fritz!Box 7590

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 365
Antw:weewx-fhem - Erfahrungen?
« Antwort #21 am: 17 Juni 2020, 13:55:53 »
Früher gab es mal was auf https://www.froggit.de vielleicht haben die noch was.
Viele Grüße

Martin

Raspi 4 mit Raspian, FHEM, Signalduino 433MHz & 868MHz, MAX!, WeeWX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline Jens_B

  • Full Member
  • ***
  • Beiträge: 400
Antw:weewx-fhem - Erfahrungen?
« Antwort #22 am: 03 Juli 2020, 13:17:37 »
Früher gab es mal was auf https://www.froggit.de vielleicht haben die noch was.

Die haben eine komplette "Kombiaussenstation" (WH1080SE) als Ersatzteil (https://www.froggit.de/product_info.php?info=p337_wh1080-se-ersatz--all-in-one--ausseneinheit.html) , leider aber nicht den einzelnen Sender der Alten Aussenstation.
Die Kombistation taugt so wie abgebildet IMHO nix, da die Windrose unten ziemlich dicht am Masten hängt. Heißt der Mast beeinflusst die Windrichtungsanzeige.
Aber vielleicht reicht es ja, ich werde es für 80 Euro auf einen Versuch ankommen lassen.
RaspberryPi 3 (Raspian Buster)FHEM+Homebridge
HMLAN für Homematic
Z-Wave USB Stick
Pilight
Fritz!Box 7590

Offline gent

  • Full Member
  • ***
  • Beiträge: 323
Antw:weewx-fhem - Erfahrungen?
« Antwort #23 am: 08 Juni 2021, 21:09:22 »
Ich hänge mich mal an den Eintrag hier mit dran, obwohl schon älter.

Ich habe seit kurzem einen froggit Wetterserver ( https://www.froggit.de/product_info.php?language=de&info=p410_dp1500-wi-fi-wetterserver-usb-dongle.html ) der wohl ein GW1000 ist, mit ein paar zusätzlichen Sensoren. Alles soweit funktionsfähig und soweit auch in weewx eingebunden hiermit ( https://github.com/gjr80/weewx-gw1000/wiki/Quick-Start-Guide )

Ich habe auch bereits die weewx mqtt extension installiert ( https://github.com/matthewwall/weewx-mqtt ) und würde damti auch Werte in fhem bekommen.

Was ich aber nicht checke ist: An welcher Stelle konfiguriert man nun die Werte mit den Einheiten, die man in fhem dann in den Readings haben will?

Wenn ich den gw1000 Treiber starte, bekomme ich diese Ausgabe:

2021-06-08 20:20:12 CEST (1623176412): UV: 0, dateTime: 1623176412, dayRain: 7.4, daymaxwind: 7.1, extraHumid1: 84, extraHumid2: 91, extraTemp1: 18.3, extraTemp2: 18.9, inHumidity: 56, inTemp: 23.4, luminosity: 108.0, monthRain: 31.8, outHumidity: 92, outTemp: 16.8, pressure: 975.3, rain: None, rainRate: 1.8, relbarometer: 1020.1, soilMoist1: 34, stormRain: 7.4, usUnits: 17, uvradiation: 0.5, weekRain: 11.2, wh31_ch1_batt: 0, wh31_ch1_sig: 4, wh31_ch2_batt: 0, wh31_ch2_sig: 4, wh51_ch1_batt: 1, wh51_ch1_sig: 4, wh65_batt: 0, wh65_sig: 4, windDir: 5, windGust: 0.0, windSpeed: 0.0, yearRain: 65.3

Wenn ich dann weewxd starte, dann bekomme ich diese Werte:

LOOP:   2021-06-08 20:47:53 CEST (1623178073) altimeter: 30.165662812819864, appTemp: 64.45375863158243, barometer: 30.152243521027685, cloudbase: 1666.6115152216012, dateTime: 1623178073, daymaxwind: 7.1, dayRain: 0.2992125984251969, dewpoint: 59.953537391732254, extraHumid1: 85, extraHumid2: 92, extraTemp1: 64.58000000000001, extraTemp2: 65.30000000000001, heatindex: 61.988, humidex: 69.44601148800837, inDewpoint: 57.404138028970664, inHumidity: 56, inTemp: 74.12, luminosity: 155.0, maxSolarRad: 7.79358717496755, monthRain: 1.2598425196850394, outHumidity: 94, outTemp: 61.7, pressure: 28.806502806250002, rain: None, rainRate: 0.0, relbarometer: 1020.3, soilMoist1: 34, stormRain: 0.2992125984251969, usUnits: 1, UV: 0, uvradiation: 0.5, weekRain: 11.4, wh31_ch1_batt: 0, wh31_ch1_sig: 4, wh31_ch2_batt: 0, wh31_ch2_sig: 4, wh51_ch1_batt: 1, wh51_ch1_sig: 4, wh65_batt: 0, wh65_sig: 4, windchill: 61.7, windDir: 163, windGust: 1.1184709259696521, windSpeed: 0.8947767407757218, yearRain: 2.5787401574803153

In fhem (per mqtt) sehe ich dann so etwas im Reading "loop":

{"dateTime": "1622569471.0", "inTemp_C": "23.00", "outTemp_C": "25.10", "inHumidity": "40.00", "outHumidity": "29.00", "pressure_mbar": "969.40", "relbarometer": "1014.2", "luminosity": "15159.0", "uvradiation": "18.7", "UV": "1.0", "extraTemp1_C": "22.70", "extraTemp2_C": "27.30", "extraHumid1": "29.00", "extraHumid2": "23.00", "soilMoist1_centibar": "37.0", "rain_mm": "0.00", "stormRain_mm": "0.0", "rainRate_mm_per_hour": "0.00", "dayRain_mm": "0.0", "weekRain": "0.0", "monthRain_mm": "0.00", "yearRain_mm": "33.5", "windDir": "164.0", "windSpeed_mps": "0.8000019883927573", "windGust_mps": "1.0000024854909466", "daymaxwind": "2.0", "wh65_batt": "0.0", "wh31_ch1_batt": "0.0", "wh31_ch2_batt": "0.0", "wh51_ch1_batt": "1.0", "wh65_sig": "4.0", "wh31_ch1_sig": "4.0", "wh31_ch2_sig": "4.0", "wh51_ch1_sig": "4.0", "altimeter_mbar": "1015.19", "appTemp_C": "23.58", "barometer_mbar": "1013.35", "cloudbase_meter": "2793.13", "dewpoint_C": "5.80", "heatindex_C": "24.42", "humidex_C": "25.10", "inDewpoint_C": "8.66", "windchill_C": "25.100000000000005", "hourRain_mm": "0.0", "rain24_mm": "0.00", "usUnits": "17.0"}
(natürlich stimmen jetzt die Werte nicht überein, weil ich das zu unterschiedlichen Zeiten protokolliert habe, aber man sieht z.B. schon, dass in der weewxd-LOOP z.B. Werte vorhanden sind, die vom GW1000 wohl gar nicht kommen (z.B. altimeter: 30.165662812819864) und das auch die Einheiten bei den Temperaturen eher in °F sind als in °C obwohl in der weex.conf die Einheiten auf METRIC stehen und auch der Treiber seine Werte wohl in der korrekten Einheit liefert...

Wenn man sich die mqtt-Ausgabe in fhem ansieht, dann fehlen hier Werte (z.B die altimeter) und es gibt Werte, die der Treiber gar nicht liefert (z.B. cloudbase)

Ist vielleicht etwas "off-topic", aber ich wüsste schon gerne, wieso das so ist?

Wäre irgendwer bereit, mir hier zu helfen?

LG, Holger

fhem auf rPi3 mit USB boot und M2, 1 x cul886, 1 x cul866 (hm), homebridge, YeeLight, FlowerSens, Shelly RGBW2, Shelly 2.5, Harmony, WemosD1, Sonoff Basics, SonoffPow

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 365
Antw:weewx-fhem - Erfahrungen?
« Antwort #24 am: 08 Juni 2021, 22:20:43 »
Hallo,

Ich meine, dass musst du schon in der WeeWX.conf definieren. Ich dort ist glaube ich sogar kommentiert. Und auf www.weewx.com ist ne gute Doku für sowas. Ich muss mal in Ruhe kramen, dann kann ich dir mal meine weewx.conf posten. Ich übertrage die Werte von weewx nach fhem per mqtt. Und das geht sehr zuverlässig. Im Forum hatte ich dazu glaube ich auch schon was gepostet. Ich finde nur gerade das nicht.

Viele Grüße

Martin
Viele Grüße

Martin

Raspi 4 mit Raspian, FHEM, Signalduino 433MHz & 868MHz, MAX!, WeeWX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline gent

  • Full Member
  • ***
  • Beiträge: 323
Antw:weewx-fhem - Erfahrungen?
« Antwort #25 am: 08 Juni 2021, 23:28:21 »
Hallo Martin,

klar, die Doku kenne ich natürlich, aber der Zusammenhang fehlt mir. Da weewx ja bei mir nur eine Art Gateway zu mqtt (und damit fhem) ist, sind hier einige Konfigurationen im Spiel, die Werte beeinflussen können:

- der GW1000 Treiber
- die weewx.conf
- die Readings in fhem

Alternativ, wäre natürlich irgendwas in fhem ohne weewx auch eine Alternative für mich (aber nicht die wunderground Module o.ä, weil ich dann keine Daten der zusätzlichen Sensoren habe)

Was würde denn notwendig sein, damit die Daten des dp1500 / gw1000 irgendwie direkt in fhem als reading landen?

Viele Grüße
fhem auf rPi3 mit USB boot und M2, 1 x cul886, 1 x cul866 (hm), homebridge, YeeLight, FlowerSens, Shelly RGBW2, Shelly 2.5, Harmony, WemosD1, Sonoff Basics, SonoffPow

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 365
Antw:weewx-fhem - Erfahrungen?
« Antwort #26 am: 10 Juni 2021, 13:45:35 »
Hallo,

soweit ich mich entsinnen kann, war es so, dass ich noch in weewx.conf für MQTT definiert habe, welche Einheiten benutzt werden. Somit werden direkt die Werte in der richtigen Einheit gesendet. Das sind ja nur Zahlenwerte ohne Einheit.

Weiterhin hatte ich noch das hier eingerichtet. https://github.com/weewx/weewx/wiki/mqtt. Da das mit weewx-fhem nicht gescheit funktioniert hatte. Es ist schon so lange her, dass ich mich nicht mehr im Detail erinnere, erst wieder so nach und nach.

Bei weewx-mqtt musst du auch die Einheiten angeben. Standard ist glaube ich nämlich die Imperial Einheiten und nicht die metric.

Das war kein Hexenwerk. Etwas optimieren muss man ggf. falls, weil durch die Umrechnung doch sehr viele Nachkommastellen mit übertragen werden. ist aber alles unter dem Link beschrieben.

Viele GRüße

Martin
« Letzte Änderung: 10 Juni 2021, 13:47:31 von maddinthebrain »
Viele Grüße

Martin

Raspi 4 mit Raspian, FHEM, Signalduino 433MHz & 868MHz, MAX!, WeeWX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline kjmEjfu

  • Sr. Member
  • ****
  • Beiträge: 773
Antw:weewx-fhem - Erfahrungen?
« Antwort #27 am: 01 Juli 2021, 10:26:22 »
Hallo Martin,

klar, die Doku kenne ich natürlich, aber der Zusammenhang fehlt mir. Da weewx ja bei mir nur eine Art Gateway zu mqtt (und damit fhem) ist, sind hier einige Konfigurationen im Spiel, die Werte beeinflussen können:

- der GW1000 Treiber
- die weewx.conf
- die Readings in fhem

Alternativ, wäre natürlich irgendwas in fhem ohne weewx auch eine Alternative für mich (aber nicht die wunderground Module o.ä, weil ich dann keine Daten der zusätzlichen Sensoren habe)

Dann schau dir https://www.loxwiki.eu/display/LOXBERRY/FOSHKplugin+-+generic+version an. Wichtig: läuft ohne Loxone

Offline gent

  • Full Member
  • ***
  • Beiträge: 323
Antw:weewx-fhem - Erfahrungen?
« Antwort #28 am: 29 Juli 2021, 20:51:22 »
Dann schau dir https://www.loxwiki.eu/display/LOXBERRY/FOSHKplugin+-+generic+version an. Wichtig: läuft ohne Loxone

Habe ich mal ausprobiert, aber ich bekomme da leider keine Werte. Sollte eigentlich ein raw-log geben, aber das füllt sich nicht. Und auch auf dem mqtt broker kommt nix an. Schade. Das klang echt vielversprechend.
fhem auf rPi3 mit USB boot und M2, 1 x cul886, 1 x cul866 (hm), homebridge, YeeLight, FlowerSens, Shelly RGBW2, Shelly 2.5, Harmony, WemosD1, Sonoff Basics, SonoffPow

 

decade-submarginal