Autor Thema: [gelöst] Unknown argument seit HM-Update von heute  (Gelesen 3512 mal)

Offline blackbite

  • Full Member
  • ***
  • Beiträge: 142
Antw:[gelöst] Unknown argument seit HM-Update von heute
« Antwort #15 am: 02 August 2020, 21:36:44 »
Hallo Martin,

mit dem heutigen Update ist der Fehler

userCfg return value: Unknown argument displayWM, choose one of clear:readings,trigger,register,oldRegs,rssi,msgEvents,msgErrors,attack,all displayWM getConfig:noArg getRegRaw peerBulk peerChan regBulk regSet sign:on,off text tplSet_0-tplChan- tplSet_vccu_Btn1-tplPeer-
Unknown argument displayWM, choose one of clear:readings,trigger,register,oldRegs,rssi,msgEvents,msgErrors,attack,all displayWM getConfig:noArg getRegRaw peerBulk peerChan regBulk regSet sign:on,off text tplSet_0-tplChan- tplSet_vccu_Btn1-tplPeer-

wieder zurück. Kannst Du das mal anschauen? Danke

Problem mit 10_CUL_HM.pm 22516 von martin876 seit heute gelöst. Siehe:

https://forum.fhem.de/index.php/topic,113277.msg1075920.html#msg1075920
Blackbite

Offline huntsman

  • New Member
  • *
  • Beiträge: 13
Antw:[gelöst] Unknown argument seit HM-Update von heute
« Antwort #16 am: 24 September 2021, 19:22:49 »
Hallo Martin,
kann es sein, daß mit den aktuellen nightly builds der Fehler 'Unknown argument displayWM' wieder da ist?
Jedenfalls kommt er bei mir, seit ich auf die neuste 6er Version aktualisiert habe,
danke für Deine Hilfe

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16324
Antw:[gelöst] Unknown argument seit HM-Update von heute
« Antwort #17 am: 27 September 2021, 15:17:00 »
Hallo Martin,
kann es sein, daß mit den aktuellen nightly builds der Fehler 'Unknown argument displayWM' wieder da ist?
Jedenfalls kommt er bei mir, seit ich auf die neuste 6er Version aktualisiert habe,
danke für Deine Hilfe
Bin zwar nicht Martin, aber vielleicht testest du mal, ob es mit der gepatchten Fassung aus https://forum.fhem.de/index.php/topic,122422.msg1176632.html#msg1176632 weiter auftritt?

Ansonsten wäre ich an einem list oder einer RAW-Def des Hauptdevices interessiert, dann kann ich uU. vorab was testen und versuchen, Martin einen passenden Patch vorzuschlagen...

PS: Das "Aufwärmen" von "gelösten" Threads ist uU. nicht zielführend, weil manche Maintainer dann nicht mehr so intensiv in diese Threads reinschauen (ich weiß aber nicht, wie Martin das handhabt).
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline huntsman

  • New Member
  • *
  • Beiträge: 13
Antw:[gelöst] Unknown argument seit HM-Update von heute
« Antwort #18 am: 03 Oktober 2021, 20:56:01 »
Moin Beta-User,
vielen Dank für Deine Hilfe und auch Deinen Tipp (ich dachte ich versuche es erstmal in diesem Thread :-o ).
Ich habe die beiden Dateien ausgetauscht (Version vom 2.10.) und FHEM neu gestartet, leider immer noch der gleiche Fehler :-(
Mit meinem Hauptdevice meinst Du meine Steuereinheit (CUL V 1.58 CUL868) ? Was für ein list bzw. Raw-Def meinst Du, bzw. wie erzuge ich die?
Danke und viele Grüße

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16324
Antw:[gelöst] Unknown argument seit HM-Update von heute
« Antwort #19 am: 03 Oktober 2021, 21:22:32 »
Bitte mache dazu einen neuen Thread auf (du kannst dann gerne von hier weg verlinken), denn wie gesagt: "gelöst"-Threads liest man als Maintainer uU. nicht mehr...

Es tut mir auch leid, dass "meine" Fassungen dein Problem nicht lösen konnten, ich vermute ein ähnliches Problem wie das mit den virtuellen TC (https://forum.fhem.de/index.php/topic,123136.0.html), aber jedenfalls was spezielleres als das "generische" "diverse Befehle nicht mehr da", das hier mal diskutiert wurde.

Mit "Hauptdevice" war das Display gemeint (als CUL_HM-Instanz mit 6 Stellen), wobei dazu mind. zwei Kanal-Devices gehören sollten (die da als Channel_0n) in der Detailseite zu sehen sein müßten).
Aber jetzt würde ich mal behaupten, dass es hilfreich wäre, wenn du (in dem neuen Thread, in dessen Titel gerne das problematische Modell auftauchen darf) sowohl je ein "list <devicename>" liefern würdest wie auch ein "list -r <devicename>" (das letztere hilft mir ggf., das im Testsystem zu simulieren).
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16324
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline huntsman

  • New Member
  • *
  • Beiträge: 13
Antw:[gelöst] Unknown argument seit HM-Update von heute
« Antwort #21 am: 05 Oktober 2021, 20:19:28 »
Vielen Dank, leider war Patchversuch nicht erfolgreich  :(
habe jetzt ein neues Thema mit den detail Infos gestartet: https://forum.fhem.de/index.php/topic,123257.msg1178098.html#msg1178098
Danke fürs Anschauen