Autor Thema: [gelöst] Raspi fährt nicht mehr hoch! Brauche Hilfe!  (Gelesen 846 mal)

Offline Nixblicker

  • New Member
  • *
  • Beiträge: 20
[gelöst] Raspi fährt nicht mehr hoch! Brauche Hilfe!
« am: 26 August 2021, 08:39:28 »
Moin zusammen

Ich betreibe mein FHEM-System seit 5 Jahren auf einem Raspi 3b mit RASPIAN weitestgehend problemlos. Doch gestern Abend war er auf einmal nicht mehr erreichbar. Er ist wohl abgestürzt und hat dann versucht neu zu starten, blieb jedoch in der Zeile "random: nonblocking pool is initialized" hängen (siehe Bild). Habe es noch ein paar mal versucht, immer das gleiche. Über Nacht habe ich ihn dann vom Strom abgenommen und heute morgen noch einmal versucht hoch zu fahren. Da bleib er dann bei der Zeile "---[ end Kernel panic ..." (siehe Bild) hängen. Habe ihne dann noch einmal versuch hoch zu fahren, dann bliebt er allerdings wieder bei der Zeile hängen, bei der er sonst auch immer hängen blieb.
Ich habe leider von LINUX so gut wie keine Ahnung  :-[

Hat einer eine Idee was der Fehler sein kann?

Ich danke euch schon einmal im Voraus!!

Gruß,

Frank
« Letzte Änderung: 27 August 2021, 20:08:44 von Nixblicker »

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4996
  • Are we just self-replicating DNA?
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #1 am: 26 August 2021, 08:45:48 »
Hallo,

ich vermute, dass Du das Betriebssystem und die Logs auf einer SD-Karte hast. Dann ist es wahrscheinlich, dass die SD-Karte hinüber ist. Du kannst mal versuchen, die Karte auf einem anderen Linux-Rechner zu mounten. GGf. gibt es auch Tools zur Prüfung der Karte unter Windows.

Grüße
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Nixblicker

  • New Member
  • *
  • Beiträge: 20
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #2 am: 26 August 2021, 08:52:27 »
Hi

Ja, das stimmt. Das System läuft auf einer SD-Karte. D.h. ich könnte versuchen, das System mit einer neuen SD-Karte neu aufzusetzen und FHEM per Backup wieder einspielen?

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4996
  • Are we just self-replicating DNA?
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #3 am: 26 August 2021, 08:53:37 »
Genau, das ist die Methode der Wahl.
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Nixblicker

  • New Member
  • *
  • Beiträge: 20
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #4 am: 26 August 2021, 08:57:55 »
... ok, danke, dann versuche ich das heute Abend. Hast Du zufällig irgendwo einen Link zu einer Anleitung für Dummies? Meine ist aus 2015...  :D

DANKE!

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4996
  • Are we just self-replicating DNA?
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #5 am: 26 August 2021, 09:31:53 »
Englische Doku hier: https://www.raspberrypi.org/software/

Ansonsten bitte googlen, Anleitungen an jeder Ecke. Die neuesten beziehen sich auf Raspberry Pi OS, wie Raspbian nun heißt.

Viele Erfolg!
Boris
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19685
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #6 am: 26 August 2021, 10:09:41 »
Meine Notiz zum Crash (dort gibt es auch einen Link zum Setup) https://heinz-otto.blogspot.com/2020/08/crash-recovery.html

Viel Erfolg
Otto
« Letzte Änderung: 26 August 2021, 10:16:05 von Otto123 »
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline Nixblicker

  • New Member
  • *
  • Beiträge: 20
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #7 am: 26 August 2021, 10:42:48 »
Danke für die Antorten. Ein aktuelles Backup habe ich Gott sei Dank auf meiner Synology liegen. Werden das System heute Abend erst eimal mit einer neuen SD-Karte neu aufsetzen und dann versuchen, FHEM mittels Backup wiederherzustellen.

Ich lese öfters, das SD-Karten gar nicht so gut für den Dauerbetrieb geeignet sind - macht es vielleicht Sinn eine externe SD-Festplatte zu benutzen?

Danke und Gruß!

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19685
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #8 am: 26 August 2021, 10:51:08 »
Naja wie Dein Beispiel zeigt, ist es auch eine simple Strategie alle drei/vier Jahre eine neue SD Card zu kaufen. Häufige Ausfälle kann ich nicht bestätigen, hatte bisher keinen einzigen.
SSD an der USB Schnittstelle ist auch nicht gerade optimal ...
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline Nixblicker

  • New Member
  • *
  • Beiträge: 20
Antw:Raspi fährt nicht mehr hoch! Brauche Hilfe!
« Antwort #9 am: 27 August 2021, 20:07:23 »
Moin zusammen

Es hat funktioniert!
@Otto: Deine Anleitung ist super. Konnte das ganze System wieder herstellen. Problemlos. Wirklich toll, dass Du so etwas zur Verfügung stellst!

Gruß,

Frank

 

decade-submarginal