Autor Thema: 'HTTP::Request::Common' installiert, trotzdem Meldung 'Missing perl module ..'  (Gelesen 3561 mal)

Offline Marcel_R

  • Full Member
  • ***
  • Beiträge: 122
Grüezi alle!

Nach 'update' erhalte ich die Meldung:
'Missing perl module 'HTTP::Request::Common'. Please install this module first.'

Dies auch nachdem ich das entsprechende Modul eingepflegt habe

pi@raspberrypi /tmp/HTTP-Message-6.06 $ perl Makefile.PL
Warning: prerequisite Encode::Locale 1 not found. We have 0.04.
Writing Makefile for HTTP::Message
Writing MYMETA.yml
pi@raspberrypi /tmp/HTTP-Message-6.06 $ make
cp lib/HTTP/Status.pm blib/lib/HTTP/Status.pm
cp lib/HTTP/Headers/Auth.pm blib/lib/HTTP/Headers/Auth.pm
cp lib/HTTP/Request.pm blib/lib/HTTP/Request.pm
cp lib/HTTP/Headers/ETag.pm blib/lib/HTTP/Headers/ETag.pm
cp lib/HTTP/Config.pm blib/lib/HTTP/Config.pm
cp lib/HTTP/Request/Common.pm blib/lib/HTTP/Request/Common.pm
cp lib/HTTP/Headers/Util.pm blib/lib/HTTP/Headers/Util.pm
cp lib/HTTP/Message.pm blib/lib/HTTP/Message.pm
cp lib/HTTP/Response.pm blib/lib/HTTP/Response.pm
cp lib/HTTP/Headers.pm blib/lib/HTTP/Headers.pm
Manifying blib/man3/HTTP::Status.3pm
Manifying blib/man3/HTTP::Request.3pm
Manifying blib/man3/HTTP::Headers::Util.3pm
Manifying blib/man3/HTTP::Request::Common.3pm
Manifying blib/man3/HTTP::Config.3pm
Manifying blib/man3/HTTP::Message.3pm
Manifying blib/man3/HTTP::Response.3pm
Manifying blib/man3/HTTP::Headers.3pm
pi@raspberrypi /tmp/HTTP-Message-6.06 $ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/common-req.t .......... ok
t/headers-auth.t ........ ok
t/headers-etag.t ........ ok
t/headers-util.t ........ ok
t/headers.t ............. ok
t/http-config.t ......... ok
t/message-charset.t ..... ok
t/message-decode-xml.t .. ok
t/message-old.t ......... ok
t/message-parts.t ....... ok
t/message.t ............. ok
t/request.t ............. ok
t/response.t ............ ok
t/status-old.t .......... ok
t/status.t .............. ok
All tests successful.
Files=15, Tests=554, 25 wallclock secs ( 3.09 usr  0.15 sys + 19.87 cusr  0.93 csys = 24.04 CPU)
Result: PASS
pi@raspberrypi /tmp/HTTP-Message-6.06 $ sudo make install
Installing /usr/local/share/perl/5.14.2/HTTP/Request.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Headers.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Config.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Response.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Status.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Message.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Request/Common.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Headers/ETag.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Headers/Auth.pm
Installing /usr/local/share/perl/5.14.2/HTTP/Headers/Util.pm
Installing /usr/local/man/man3/HTTP::Config.3pm
Installing /usr/local/man/man3/HTTP::Headers::Util.3pm
Installing /usr/local/man/man3/HTTP::Response.3pm
Installing /usr/local/man/man3/HTTP::Message.3pm
Installing /usr/local/man/man3/HTTP::Headers.3pm
Installing /usr/local/man/man3/HTTP::Request.3pm
Installing /usr/local/man/man3/HTTP::Status.3pm
Installing /usr/local/man/man3/HTTP::Request::Common.3pm
Appending installation info to /usr/local/lib/perl/5.14.2/perllocal.pod


Dies auch nach einem 'shutdown' von FHEM und einem Neustart des Raspi.

Welche Infos fehlen?

Was kann (muss) ich noch unternehmen?

Danke
Marcel

P.S. Encode::Locale ist installiert (es wurden dabei 2 mögliche Typos gemeldet line 181)
FHEM / Fritz!Box 7490 / CULv3 / Raspi / COC / MAX! / HomeMatic /

Offline Cruiser79

  • Full Member
  • ***
  • Beiträge: 306
Hallo,

hast du zu deinem Problem schon eine Lösung rausgefunden? Bin nämlich gerade bei dem gleichen Problem.
Bei mir meldet "fheminfo" folgendes
Missing perl module 'HTTP::Request::Common'. Please install this module first. d
Dabei liegt das Modul unter /usr/share/perl5/HTTP/Request/Common.pm auf meinem raspberry rum.
Und nach einer Fehlermeldung der SerialPort.pm, die mich aber nicht weiter stört, da ich es nicht benutze, ist der Pfad /usr/share/perl5 mit im Includepfad mit drin
Can't locate Device/SerialPort.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl . ./FHEM) at ./FHEM/DevIo.pm line 192.

Gruß,
Cruiser
FHEM auf Raspberry Pi
HM-CFG-LAN mit HM-TC-IT-WM-W-EU, HM-CC-RT-DN, HM-WDS10-TH-O, HM-LC-SW1-FM, HM-LC-Bl1-FM
Signalduino mit Elro AB440, LOGILINK WS0002, IT CMR-1000

Offline wkarl

  • Sr. Member
  • ****
  • Beiträge: 851
Hallo ihr beiden,

hatte ein ähnliches Problem unter ArchLinux. Modul über CPAN installiert und CPAN meldete auch, dass es installiert ist.
Aber erst nachdem ich da Perl-Packet über pacman (Installer unter ArchLinux) wurde das Modul von perl erkannt.

Vielleicht hilft Euch diese Erfahrung weiter.

ciao walter
FHEM 5.7 & TabletUI 2.2 auf Fedora22 Server auf NUC5i5RYK
CUL 868 > FAST EnergyCam
HMLAN > HomeMatic TCs & VDs, Bewegungsmelder, Schalter, Taster, Steckdosen

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16096
  • s/fhem\.cfg/configDB/g
hast du zu deinem Problem schon eine Lösung rausgefunden? Bin nämlich gerade bei dem gleichen Problem.

apt-get install libwww-perl libdevice-serialport-perl
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.

Offline Cruiser79

  • Full Member
  • ***
  • Beiträge: 306
apt-get install libwww-perl libdevice-serialport-perl
Super, danke, das funktioniert so  :)
FHEM auf Raspberry Pi
HM-CFG-LAN mit HM-TC-IT-WM-W-EU, HM-CC-RT-DN, HM-WDS10-TH-O, HM-LC-SW1-FM, HM-LC-Bl1-FM
Signalduino mit Elro AB440, LOGILINK WS0002, IT CMR-1000