FHEM - Hardware > Server - Linux

[gelöst] SmartVisu über zwei NGINX

(1/3) > >>

Saphora:
Hallo,
hat von euch jemand SmartVisu über zwei NGINX aktiv?
Möchte gern SmartVisu von extern über NGINX darstellen.
SmartVisu selbst wird über einen eigenen NGINX betrieben.
Mein NGINX für das Internet läuft aber auf einem anderen Server.
Daher würde ich gern vom Internet NGINX zum SmartVisu NGINX weiterleiten.
Das klappt auch soweit, dass SmartVisu angezeigt wird.
Aber es sind keine Werte sichtbar (Values, Button On/off...).
Im Fronthem ist die IP des Internet NGINX hinterlegt, aber das Fronthem Device m FHEM bleibt auf disconnected.
Am SmartVisu NGINX kommen die Anfragen mit der IP des Internet NGINX an, die auch als Fronthem Device angelegt ist.

Kennt jemand das Problem?

Martin

Wernieman:
Du verwendest also NGINX als Reverse-Proxy für den Internen Webserver (NGINX)

- Kannst Du uns bitte die Config des Reverse-Proxys geben?
- Der Interen Webserver funktioniert wie gewünscht?

Kenne jetzt SmartVisu nicht genau, aber bei FHEM selber würde ich Dir raten, Testweise mal LongPoll zu aktivieren

Saphora:
ja NGINX als interner Webserver für Smartvisu.
Das funktioniert auch einwandfrei, wenn es direkt aufgerufen wird.
Kommt nun der zweite NGINX ins Spiel, wird nur die Smartvisu Seite angezeigt, aber FHEM liefert keine Werte usw.

Hier die Konfigurationen für den NGINX intern

--- Code: ---server {
        listen 192.168.178.2:80;
        server_name 192.168.178.2;

        root /var/www/html;
        index index.php index.html index.htm index.nginx-debian.html;

        location / {
                try_files $uri $uri/ =404;
        }

        location ~ \.php$ {
                 try_files $uri =404;
                 fastcgi_split_path_info ^(.+\.php)(/.+)$;
                 fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                 fastcgi_index index.php;
                 include fastcgi.conf;
                 fastcgi_read_timeout 600;
         }
}

--- Ende Code ---



Hier die Konfigurationen für den NGINX extern

--- Code: ---upstream backend-smartvisu {
        server 192.168.178.2;
}

server {
        listen                meinedomain.de:443 ssl;
        server_name     meinedomain.de;

...
SSL
...

       location /smartvisu
                {
                proxy_pass http://backend-smartvisu;
                }
}

--- Ende Code ---

Wernieman:
Habe jetzt meinen eigenen Nginx-Reverseproxy nicht im Zugriff, aber es fehlen so einige Parameter bei der location des Reverse-Proxys. Gibt dazu auch Threads im Forum. Suche mal nach nginx ....

Saphora:
Die folgenden Header sind gesetzt, bringen aber keinen Erfolg...

        proxy_http_version        1.1;
        proxy_set_header          Upgrade $http_upgrade;
        proxy_set_header          Host $host;
        proxy_set_header          X-Real-IP 192.168.178.3;                    #Setzt Client IP, wenn aus dem Internet kommt, da diese im Frothem zugelassen ist
        proxy_set_header          X-Forwarded-For 192.168.178.3;          #Setzt Client IP, wenn aus dem Internet kommt, da diese im Frothem zugelassen ist
        proxy_set_header          X-Forwarded-Proto $scheme;

Die SmartVisu Seite wird ohne Probleme angezeigt, aber im FHEM wird das Fronthem Device nicht als aktiv angezeigt.

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln