Autor Thema: [gelöst] Status MySensors Gateway  (Gelesen 536 mal)

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5404
    • PeMue's github
[gelöst] Status MySensors Gateway
« am: 15 September 2021, 15:34:38 »
Hallo zusammen,

ich habe an meiner Testumgebung ein MySensors Gatway, das bisher tadellos funktioniert hat. Beim Probieren von 1-wire Sensoren (über USB) habe ich festgestellt, dass mein Gateway auch per ID eingebunden werden kann. Kurz und gut, vorher war der Status
startup completeNach der Änderung ist das Gateway auf
openedund es werden keine Daten mehr empfangen.
Ich habe in diesem Zug auch ein Update gemacht, die Modulversionen sind
00_MYSENSORS.pm        24683 2021-06-26 04:52:49Z Beta-User
10_MYSENSORS_DEVICE.pm 24446 2021-05-15 14:04:30Z Beta-User
Ich habe alle USB Geräte abgesteckt und nur mal das Gateway dringelassen, aber keine Änderung.
Da ich nicht viel mit MySensors mache, meine Frage, wo kann ich noch suchen?

Danke für einen Schubs in die richtige Richtung.

Gruß Peter
« Letzte Änderung: 15 September 2021, 18:15:36 von PeMue »
RPi3Bv1.2 rpiaddon 1.66 6.0 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 2xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU  1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F) 1xRFXtrx 90 1xWT440H 3xTFA30.3150 5xFA21
RPi1Bv2 LCDCSM 1.63 5.8 2xMAX HKT 1xMAX RT V200KW1 Heizung Wasser

Offline Beta-User

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 15731
Antw:Status MySensors Gateway
« Antwort #1 am: 15 September 2021, 15:42:30 »
Konflikte der "by-id"-Definitionen sind ausgeschlossen und alle USB-Geräte sind by-id definiert, oder?
Sonst irgendwas dran an USB-Geräten, auf das von anderen Diensten zugegriffen wird? (z.B. deconz)
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5404
    • PeMue's github
Antw:Status MySensors Gateway
« Antwort #2 am: 15 September 2021, 16:48:05 »
es gibt zwei Definitionen:
nanoCUL
define nanoCUL CUL /dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0@38400 0000und das MySensors Gateway
define PMMySGW02 MYSENSORS /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9KJJ11D-if00-port0@115200sonst nichts. Der nanoCUL empfängt sauber ...

Gruß Peter
RPi3Bv1.2 rpiaddon 1.66 6.0 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 2xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU  1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F) 1xRFXtrx 90 1xWT440H 3xTFA30.3150 5xFA21
RPi1Bv2 LCDCSM 1.63 5.8 2xMAX HKT 1xMAX RT V200KW1 Heizung Wasser

Offline Beta-User

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 15731
Antw:Status MySensors Gateway
« Antwort #3 am: 15 September 2021, 17:22:10 »
Test-PIN ist es auch nicht? (Nach DEF-Änderung wird der FTDI neu initialisiert)
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5404
    • PeMue's github
Antw:Status MySensors Gateway
« Antwort #4 am: 15 September 2021, 18:13:55 »
Test-PIN ist es auch nicht? (Nach DEF-Änderung wird der FTDI neu initialisiert)
War gefixt, aber bei meinen Umbauaktionen habe ich den Arduino nano falsch rum auf den nanoCUL v2.3 draufgesteckt (der kann ja diverse Arduino Boards).
In diesem Fall saß das Problem vor dem Bildschirm. Trotzdem danke für die Tipps.

Gruß Peter
« Letzte Änderung: 15 September 2021, 18:16:16 von PeMue »
RPi3Bv1.2 rpiaddon 1.66 6.0 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 2xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU  1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F) 1xRFXtrx 90 1xWT440H 3xTFA30.3150 5xFA21
RPi1Bv2 LCDCSM 1.63 5.8 2xMAX HKT 1xMAX RT V200KW1 Heizung Wasser

Offline Beta-User

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 15731
Antw:(gelöst) Status MySensors Gateway
« Antwort #5 am: 15 September 2021, 18:15:42 »
 ;D ... kann vorkommen, willkommen im Club, have a nice day!
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}

 

decade-submarginal