Autor Thema: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK  (Gelesen 6302 mal)

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19733
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #15 am: 30 August 2019, 16:18:44 »
Oh ich hatte es vermutet: der VCCU fehlt das attr IOgrp auf sich selbst!
Ohne das attr ist die VCCU bei Ausfall eines IO nicht in der Lage den richtigen Sender zu setzen.
https://forum.fhem.de/index.php/topic,88621.msg811397.html#msg811397

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 788
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #16 am: 30 August 2019, 16:46:49 »
... okay ... das muss ich mir ansehen.
Ich habe das VCCU ursprünglich mal angelegt, ohne wirklich zu wissen, wie das im Detail funktioniert. Dieser Aspekt war mir komplett unbewusst. Seltsam ist aber dann doch, dass es ansonsten immer funktioniert hat, oder etwa nicht? Ich habe öfters probehalber wechselweise HMLANGW und HMUSB ausgesteckt und an einzelnen Aktoren (nicht am aktuell hier besprochenen) die Funktion geprüft, und es hat immer funktioniert. Nun gut, ich glaube Dir natürlich schon, dass Du an sich Recht hast. Werde das mit definieren.

EDIT: Etwas irritiert mich die Beschreibung:
attr VCCU IOgrp <Name der vccu>"Name der vccu" ist doch exemplarisch im vorderen Teil schon mit "VCCU" gesetzt, warum dann nicht auch hinten? Es kann dann doch nichts anderes da stehen, oder übersehe ich wieder etwas?

BTW: Im zweiten identischen Aktor hatte ich die Definition auch mit dem preferedID, muss das also schon mal gewusst haben - ist das einsetzende Demenz :o
« Letzte Änderung: 30 August 2019, 16:58:43 von duke-f »
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19733
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #17 am: 30 August 2019, 17:00:22 »
Ich sage nicht das es die Lösung Deines Problemes ist  ;) aber es ist auf alle Fälle nicht richtig und ich habe das erst vor ca. 1 Jahr so im Wiki nachgetragen.

Ich habe damals entdeckt "Das ist sicher nur ein Problem wenn man pairen will. " Aber wer weiß :)


Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 788
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #18 am: 30 August 2019, 18:11:08 »
Auf jeden Fall wird mir das dann helfen, wenn ich demnächst den Austausch des Wandschalters pairen muss. Jetzt ist es drin. Und ob das Problem weiter besteht wird sich zeigen.

Beste Grüße
duke-f
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19733
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #19 am: 30 August 2019, 18:21:42 »
EDIT: Etwas irritiert mich die Beschreibung:
attr VCCU IOgrp <Name der vccu>"Name der vccu" ist doch exemplarisch im vorderen Teil schon mit "VCCU" gesetzt, warum dann nicht auch hinten? Es kann dann doch nichts anderes da stehen, oder übersehe ich wieder etwas?
Ja hast Du sicher Recht, ich sehe es mir an und gehe noch mal in mich.   ;D
Irgendwas verwirrt irgendwen immer :)
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline frank

  • Hero Member
  • *****
  • Beiträge: 10572
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #20 am: 30 August 2019, 18:34:57 »
Zitat
Das RSSI-Loggen werde ich mal aufgreifen. Ist das dann nicht das Attribut rssiLog? ligIDs gibt's wohl nicht.
richtig,
demenz ist wohl überall.  ;)
FHEM: 6.0(SVN) => Pi3(buster)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [HMdeviceTools.js (hm.js)]: https://forum.fhem.de/index.php/topic,106959.0.html
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 788
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #21 am: 30 August 2019, 19:10:33 »
Irgendwas verwirrt irgendwen immer :)
Da ist was dran - irgenwie verwirrend ... :o
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19733
  • schon mal restore trainiert?
    • Otto's Technik Blog
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline duke-f

  • Sr. Member
  • ****
  • Beiträge: 788
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #23 am: 09 Oktober 2019, 14:47:22 »
Ist ja jetzt wieder einige Zeit her. Und gewässert wird auch nicht mehr. Gerade muss ich aber bei einem Probelauf feststellen, dass mein Problem nach wie vor besteht. Vielleicht liegt es am Aktor selber oder es gibt Komponenten in der Nachbarschaft, die stören. Einen zweiten, identischen Aktor, den ich in ähnlicher Position mit praktisch identischer Konfiguration betreibe, zeigt das Phänomen nicht.

Mal sehen, wie sich der "Trockenlauf" im Winter im Keller zeigt.
Cubietruck, 3 Raspberry Pis,
CUL868, RFXtrx433, CUL433, SCC868, HM-USB,
IRTrans, EZcontrol XS1, IguanaWorks USB IR Transceiver
ESPEasy, Fritz!Box, Samsung TV+BD, LMS, Squeezelite

Offline Frood42

  • Full Member
  • ***
  • Beiträge: 151
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #24 am: 17 September 2021, 21:34:30 »
Hi, gabe es hier etwas neues im Keller?

Ich hatte meine HM-LC-SW1-BA-PCB nur wenige Tage in Betrieb und bekam dann immer wieder MISSING ACK. Irgendwie ist das Ding schräg oder etwas angeschlagen.
In den Logs / Event Monitor habe ich nichts verdächtiges finden können. Ein aus und einstecken der Stromversorgung hat das Problem immer wieder für wenige Stunden gelöst.
 
Da es an einer kritischen Stelle der Infrastruktur eingesetzt wurde, habe ich es dann gleich wieder durch eine Steckdose ersetzt.

Grüße, Frood

Offline frank

  • Hero Member
  • *****
  • Beiträge: 10572
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #25 am: 18 September 2021, 11:54:40 »
zeig doch mal ein list vom aktor.
FHEM: 6.0(SVN) => Pi3(buster)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [HMdeviceTools.js (hm.js)]: https://forum.fhem.de/index.php/topic,106959.0.html

Offline Frood42

  • Full Member
  • ***
  • Beiträge: 151
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #26 am: 18 September 2021, 21:12:16 »
   DEF        750D25
   FUUID      614269c6-f33f-9562-9395-af77196b2bfd3c1c
   HMGW1_MSGCNT 10
   HMGW1_RAWMSG 050000332A8400750D2500000017006C5345513132303633343010410100
   HMGW1_RSSI -51
   HMGW1_TIME 2021-09-18 21:10:34
   IODev      HMGW1
   LASTInputDev HMGW1
   MSGCNT     10
   NAME       HM_750D25
   NR         418
   NTFY_ORDER 50-HM_750D25
   STATE      on
   TYPE       CUL_HM
   chanNo     01
   disableNotifyFn 1
   lastMsg    No:2A - t:00 s:750D25 d:000000 17006C5345513132303633343010410100
   protCmdDel 6
   protLastRcv 2021-09-18 21:10:34
   protRcv    10 last_at:2021-09-18 21:10:34
   protResnd  6 last_at:2021-09-18 20:38:10
   protResndFail 6 last_at:2021-09-18 20:38:15
   protSnd    18 last_at:2021-09-18 21:10:30
   protSndB   13 last_at:2021-09-18 21:07:52
   protState  CMDs_done
   rssi_at_HMGW1 cnt:10 min:-54 max:-48 avg:-51.3 lst:-51
   .attraggr:
   .attrminint:
   Helper:
     DBLOG:
       powerOn:
         myDbLog:
           TIME       1631992071.7323
           VALUE      2021-09-18 21:07:51
   READINGS:
     2021-09-18 21:10:34   .D-devInfo      410100
     2021-09-18 21:10:34   .D-stc          10
     2021-09-15 23:46:57   .R-intKeyVisib  invisib
     2021-09-15 23:46:57   .R-ledMode      off
     2021-09-15 23:46:57   .R-lowBatLimitBA 10.5 V
     2021-09-15 23:46:57   .R-pairCentral  0xAFFECC
     2021-09-15 23:46:57   .R-sign         off
     2021-09-18 21:07:54   .associatedWith HM_750D25,HM_750D25
     2021-09-18 21:07:54   .peerListRDate  2021-09-18 21:07:54
     2021-09-18 21:10:34   .protLastRcv    20210918211034
     2021-09-17 17:15:20   CommandAccepted yes
     2021-09-18 21:10:34   D-firmware      1.7
     2021-09-18 21:10:34   D-serialNr      SEQ1206340
     2021-09-18 21:10:30   IODev           HMGW1
     2021-09-18 21:07:53   PairedTo        0xAFFECC
     2021-09-18 21:07:53   RegL_00.         00:00 02:01 05:00 0A:AF 0B:FE 0C:CC 12:69
     2021-09-18 21:07:54   RegL_01.         00:00 08:00
     2021-09-18 21:10:30   battery         ok
     2021-09-18 21:08:54   cfgState        ok
     2021-09-18 21:10:30   commState       CMDs_done
     2021-09-18 21:10:30   deviceMsg       on (to VCCU)
     2021-09-18 21:10:30   level           100
     2021-09-18 21:10:30   pct             100
     2021-09-18 21:07:51   powerOn         2021-09-18 21:07:51
     2021-09-18 21:10:30   recentStateType info
     2021-09-18 21:10:30   state           on
     2021-09-18 21:10:30   timedOn         off
     2021-09-17 20:46:53   trigLast        fhem:02
   helper:
     HM_CMDNR   81
     PONtest    0
     cSnd       01AFFECC750D2501040000000001,01AFFECC750D250103
     cfgStateUpdt 0
     lastMsgTm  1631992234.77726
     mId        006C
     peerFriend peerSens,peerVirt
     peerIDsRaw ,00000000
     peerIDsState complete
     peerOpt    3:switch
     regLst     0,1,3p
     rxType     2
     supp_Pair_Rep 1
     cmds:
       TmplKey    :no:1631981053.70949
       TmplTs     1631981053.70949
       cmdKey     1:1:0::HM_750D25:006C:01:
       cmdLst:
         assignHmKey noArg
         clear      [(readings|trigger|register|oldRegs|rssi|msgEvents|{msgErrors}|attack|all)]
         deviceRename -newName-
         fwUpdate   -filename- [-bootTime-]
         getConfig  noArg
         getDevInfo noArg
         getRegRaw  (List0|List1|List2|List3|List4|List5|List6|List7) [-peerChn-]
         getVersion noArg
         inhibit    [(on|{off})]
         off        noArg
         on         noArg
         on-for-timer -ontime-
         on-till    -time-
         pair       noArg
         peerBulk   -peer1,peer2,...- [({set}|unset)]
         peerIODev  [IO] -btn- [({set}|unset)] 'not for future use'
         peerSmart  -peerOpt-
         press      [(long|{short})] [(-peer-|{self01})] [(-repCount-|{0})] [(-repDelay-|{0.25})]
         raw        -data- [...]
         regBulk    -list-.-peerChn- -addr1:data1- [-addr2:data2-]...
         regSet     [(prep|{exec})] -regName- -value- [-peerChn-]
         reset      noArg
         sign       [(on|{off})]
         statusRequest noArg
         toggle     noArg
         tplDel     -tplDel-
         tplSet_0   -tplChan-
         unpair     noArg
       lst:
         condition  slider,0,1,255
         peer       
         peerOpt    HM_5FE8DE_MOTION_BATH,HM_653B50_SenF,HM_653B50_SenI,HM_653B50_SenPwr,HM_653B50_SenU,HM_67B628_Btn_01,HM_67B628_Btn_02,HM_67B628_Btn_03,HM_67B628_Btn_04,HM_67B628_Btn_05,HM_67B628_Btn_06,HM_6AA531_Btn_01,HM_6AA531_Btn_02,HM_6CA9C4_Btn_01,HM_6CA9C4_Btn_02,HM_72C5C2_KLINGEL,VCCU_Btn1,VCCU_Btn2,Vact_2Taster,Vact_Taster
         tplChan   
         tplDel     
         tplPeer   
       rtrvLst:
         cmdList    [({short}|long)]
         deviceInfo [({short}|long)]
         list       [({normal}|full)]
         param      -param-
         reg        -addr- -list- [-peerChn-]
         regList    noArg
         regTable   noArg
         regVal     -addr- -list- [-peerChn-]
         saveConfig [-filename-]
         tplInfo    noArg
     expert:
       def        0
       det        0
       raw        1
       tpl        0
     io:
       flgs       0
       newChn     +750D25,00,00,00
       nextSend   1631992234.86607
       rxt        0
       vccu       VCCU
       p:
         750D25
         00
         00
         00
       prefIO:
         HMGW1
     mRssi:
       mNo        2A
       io:
         HMGW1:
           -45
           -45
     peerIDsH:
       00000000   broadcast
     prt:
       bErr       0
       sProc      0
       rspWait:
       tryMsg:
     q:
       qReqConf   
       qReqStat   
     regCollect:
     role:
       chn        1
       dev        1
       prs        1
     rssi:
       at_HMGW1:
         avg        -51.3
         cnt        10
         lst        -51
         max        -48
         min        -54
     shadowReg:
     tmpl:
Attributes:
   .mId       006C
   IOgrp      VCCU:HMGW1
   autoReadReg 4_reqStatus
   expert     rawReg
   firmware   1.7
   model      HM-LC-SW1-BA-PCB
   msgRepeat  1
   peerIDs    00000000
   room       01a_FLOOR,CUL_HM
   serialNr   SEQ1206340
   subType    switch
   webCmd     statusRequest:toggle:on:off


Offline frank

  • Hero Member
  • *****
  • Beiträge: 10572
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #27 am: 19 September 2021, 13:55:32 »
zur beurteilung des funk fehlen die rssi, die das device ermittelt. mit einigen erfolgreichen statusrequest sollten die auftauchen.

zeig noch ein list vom io.
sind die antennen von io und device noch original, oder getuned?

um zu "sehen", wo es genau zwickt, müsstest du mal die rawmessages sniffen, wie im wiki beschrieben.

gibt es freezes?
schon mal apptime und/oder freezemon angeworfen?

eine korrelation mit poweron wäre seltsam.
vermutlich eine täuschung, da "missing_ack" nur länger sichtbar bleibt? das ist ja kein zustand, sondern nur ein kurzes ereignis.
ansonnsten vielleicht ein netzteil problem.
FHEM: 6.0(SVN) => Pi3(buster)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [HMdeviceTools.js (hm.js)]: https://forum.fhem.de/index.php/topic,106959.0.html

Offline Frood42

  • Full Member
  • ***
  • Beiträge: 151
Antw: HM-LC-SW1-BA-PCB zeigt gehäuft plötzlich MISSING ACK
« Antwort #28 am: 21 September 2021, 22:39:12 »
Ich habe das Ding jetzt rausgeworfen, daher kann ich erst mal keine weiteren Details liefern.

 

decade-submarginal