Autor Thema: never touch a running system!!!  (Gelesen 1248 mal)

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
never touch a running system!!!
« am: 03 Oktober 2021, 14:06:01 »
Hallo,
ich habe da ein kleines Problem.
Dachte mir heute morgen mal ein Update von meinem Heizungsfhem zu machen. Auf diesem war das letzte Update von 2016!
Lief all die jahre komplett durch und hat wunderbar funktioniert. Dort ist noch ein ganz alter B Raspi im Einsatz.
Soweit so gut,
Update gemacht, update ohne Fehler durchgeführt, fhem neu gestartet.
Fhem startet kurz aber nach einigen Sekunden wird es wieder beendet.

Log Datei zeigt folgendes:
Protect this FHEM installation by defining an allowed device with define allowed allowed
You can disable this message with attr global motd none
Autosave deactivated
2021.10.03 13:45:17 3: Opening FIRMATA device /dev/ttyUSB0
2021.10.03 13:45:17 3: Setting FIRMATA serial parameters to 57600,8,N,1
2021.10.03 13:45:17 3: FIRMATA device opened
2021.10.03 13:45:21 1: usb create starting
2021.10.03 13:45:24 3: Probing CUL device /dev/ttyAMA0
2021.10.03 13:45:24 3: Probing TCM_ESP3 device /dev/ttyAMA0
2021.10.03 13:45:24 3: Probing ZWDongle device /dev/ttyAMA0
2021.10.03 13:45:24 3: Probing SIGNALDuino device /dev/ttyAMA0
2021.10.03 13:45:24 3: Probing MYSENSORS device /dev/ttyAMA0
2021.10.03 13:45:25 3: Probing ArduCounter device /dev/ttyAMA0
2021.10.03 13:45:25 3: Probing ElsnerWS device /dev/ttyAMA0
2021.10.03 13:45:26 3: Probing FRM device /dev/ttyAMA0
2021.10.03 13:45:31 1: usb create end
2021.10.03 13:45:33 0: Featurelevel: 6
2021.10.03 13:45:33 0: Server started with 36 defined entities (fhem.pl:25039/2021-10-01 perl:5.014002 os:linux user:fhem pid:2714)
2021.10.03 13:45:33 3: FIRMATA: querying Firmata versions
@./FHEM/10_FRM.pm:main:816 : Unhandled attribute 'protocol_version_query' called

Auch beim Versuch mit sudo service fhem start , startet fehm kurz, und wird dann beendet.
Hat jemand ne Idee?
Danke als im voraus
betateilchen  <--- my personal hero

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #1 am: 03 Oktober 2021, 14:18:58 »
edit:
es scheint an der Firmata zu liegen.
Habe in der fhem.cfg den Eintrag define FIRMATA FRM /dev/ttyUSB0@57600 auskommentiert und fhem startet jetzt wieder und ist auch per browser erreichbar.
betateilchen  <--- my personal hero

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #2 am: 03 Oktober 2021, 14:32:31 »
edit2:
anscheinend gibts da ne neue version davon oder so in der Art.
in der commandref steht:
(1) Install version 0.69 or higher of the Perl module Device::Firmata, e.g. via OS command line:

cpan install Device::Firmata

das läuft gerade. (dauert etwas)
betateilchen  <--- my personal hero

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #3 am: 03 Oktober 2021, 14:35:03 »
edit:3
hmm, da liegt ein problem vor.
pi@raspberrypi ~ $ cpan install Device::Firmata

CPAN.pm requires configuration, but most of it can be done automatically.
If you answer 'no' below, you will enter an interactive dialog for each
configuration option instead.

Would you like to configure as much as possible automatically? [yes] y

 <install_help>

Warning: You do not have write permission for Perl library directories.

To install modules, you need to configure a local Perl library directory or
escalate your privileges.  CPAN can help you by bootstrapping the local::lib
module or by configuring itself to use 'sudo' (if available).  You may also
resolve this problem manually if you need to customize your setup.

What approach do you want?  (Choose 'local::lib', 'sudo' or 'manual')
 [local::lib] sudo

Autoconfigured everything but 'urllist'.

Now you need to choose your CPAN mirror sites.  You can let me
pick mirrors for you, you can select them from a list or you
can enter them by hand.

Would you like me to automatically choose some CPAN mirror
sites for you? (This means connecting to the Internet) [yes] y
Trying to fetch a mirror list from the Internet
Fetching with LWP:
http://www.perl.org/CPAN/MIRRORED.BY

Looking for CPAN mirrors near you (please be patient)
. done!

New urllist
  http://www.cpan.org/

Autoconfiguration complete.

commit: wrote '/home/pi/.cpan/CPAN/MyConfig.pm'

You can re-run configuration any time with 'o conf init' in the CPAN shell
Fetching with LWP:
http://www.cpan.org/authors/01mailrc.txt.gz
Going to read '/home/pi/.cpan/sources/authors/01mailrc.txt.gz'
............................................................................DONE
Fetching with LWP:
http://www.cpan.org/modules/02packages.details.txt.gz
Going to read '/home/pi/.cpan/sources/modules/02packages.details.txt.gz'
  Database was generated on Sun, 03 Oct 2021 11:41:02 GMT
.............
  New CPAN.pm version (v2.28) available.
  [Currently running version is v1.960001]
  You might want to try
    install CPAN
    reload cpan
  to both upgrade CPAN.pm and run the new version without leaving
  the current session.


...............................................................DONE
Fetching with LWP:
http://www.cpan.org/modules/03modlist.data.gz
Going to read '/home/pi/.cpan/sources/modules/03modlist.data.gz'
DONE
Going to write /home/pi/.cpan/Metadata
Running install for module 'Device::Firmata'
Running make for J/JN/JNSBYR/Device-Firmata-0.69.tar.gz
Fetching with LWP:
http://www.cpan.org/authors/id/J/JN/JNSBYR/Device-Firmata-0.69.tar.gz
Fetching with LWP:
http://www.cpan.org/authors/id/J/JN/JNSBYR/CHECKSUMS
Checksum for /home/pi/.cpan/sources/authors/id/J/JN/JNSBYR/Device-Firmata-0.69.tar.gz ok
Uncompressed /home/pi/.cpan/sources/authors/id/J/JN/JNSBYR/Device-Firmata-0.69.tar.gz successfully
Using Tar:/bin/tar xf "Device-Firmata-0.69.tar":
Couldn't untar Device-Firmata-0.69.tar
Package seems to come without Makefile.PL.
  (The test -f "/home/pi/.cpan/build/JNSBYR-FzBRD3/Makefile.PL" returned false.)
  Writing one on our own (setting NAME to DeviceFirmata)
  Had problems unarchiving. Please build manually
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install
pi@raspberrypi ~ $
« Letzte Änderung: 03 Oktober 2021, 14:41:08 von hankyzoolander »
betateilchen  <--- my personal hero

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #4 am: 03 Oktober 2021, 14:43:19 »
edit4:
sobald ich das FRM Modul mit define FIRMATA FRM /dev/ttyUSB0@57600 anlege, wird fhem sofort beendet.
Das device wird angelegt und es steht folgende Meldung,

DRIVER_STATUS             Perl module Device::Firmata version 0.69 or higher required, see Commandref for details how to fix

betateilchen  <--- my personal hero

Offline rischbiter123

  • Full Member
  • ***
  • Beiträge: 413
Antw:never touch a running system!!!
« Antwort #5 am: 03 Oktober 2021, 15:30:20 »
Moin,
Antwort #3, versuch mal sudo.
LG
Andreas
4*Raspi, Max Thermostate und Fensterkontakte, FB7590, Mysensors und NanoCUL, IT und Sonoff, zigbee2mqtt2

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #6 am: 03 Oktober 2021, 15:56:18 »
das bringt leider auch nix
CPAN.pm: Going to build J/JN/JNSBYR/Device-Firmata-0.69.tar.gz

Argument "6.57_05" isn't numeric in numeric ge (>=) at Makefile.PL line 6.
Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site]
'YAML' not installed, will not store persistent state
  JNSBYR/Device-Firmata-0.69.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine prerequisites
betateilchen  <--- my personal hero

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #7 am: 03 Oktober 2021, 16:39:36 »
so, ich gebe es auf.

Liegt wohl daran das alles zu alt ist. apt-get update funktioniert auch nicht mehr. Werfe den alten raspi raus, und ersetze ihn durch einen neuen, und setze fhem neu auf. Freue mich jetzt schon total darauf alles neu zu verkabeln  ::) :o >:( >:(

Deshalb:   !!!  never touch a running system  !!!
betateilchen  <--- my personal hero

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17556
  • s/fhem\.cfg/configDB/g
Antw:never touch a running system!!!
« Antwort #8 am: 03 Oktober 2021, 16:40:11 »
Fang am Besten nochmal von vorne an.

Lösche den Ordner .cpan im Homeverzeichnis des Benutzers, mit dem Du die ganze Zeit versuchst, zu einem Erfolg zu kommen. Danach die Installation nochmal neu starten mit:

sudo cpan install Device::Firmata
Bitte beachte auch die Hinweise in diesem Thread, insbesondere den ersten Beitrag:

https://forum.fhem.de/index.php?topic=114552.0
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17556
  • s/fhem\.cfg/configDB/g
Antw:never touch a running system!!!
« Antwort #9 am: 03 Oktober 2021, 16:40:37 »
so, ich gebe es auf.

Was für ein Weichei...
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #10 am: 03 Oktober 2021, 16:47:28 »
Was für ein Weichei...

ist das alles was du beizutragen hast?
cool

betateilchen  <--- my personal hero
betateilchen  <--- my personal hero

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17556
  • s/fhem\.cfg/configDB/g
Antw:never touch a running system!!!
« Antwort #11 am: 03 Oktober 2021, 16:50:08 »
Wieso maulst Du mich an?

ist das alles was du beizutragen hast?

Nö. Oben hatte ich Dir konkrete Tipps geschrieben, was Du tun kannst.

-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!

Offline hankyzoolander

  • Full Member
  • ***
  • Beiträge: 193
Antw:never touch a running system!!!
« Antwort #12 am: 03 Oktober 2021, 16:55:19 »
es kommt weiterhin
pi@raspberrypi ~ $ sudo cpan install Device::Firmata
Going to read '/root/.cpan/Metadata'
  Database was generated on Sun, 03 Oct 2021 11:41:02 GMT
Running install for module 'Device::Firmata'
Running make for J/JN/JNSBYR/Device-Firmata-0.69.tar.gz
Checksum for /root/.cpan/sources/authors/id/J/JN/JNSBYR/Device-Firmata-0.69.tar.gz ok

  CPAN.pm: Going to build J/JN/JNSBYR/Device-Firmata-0.69.tar.gz

Argument "6.57_05" isn't numeric in numeric ge (>=) at Makefile.PL line 6.
Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site]
'YAML' not installed, will not store persistent state
  JNSBYR/Device-Firmata-0.69.tar.gz
  /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine prerequisites
pi@raspberrypi ~ $
betateilchen  <--- my personal hero

Offline andies

  • Tester
  • Hero Member
  • ****
  • Beiträge: 3196
Antw:never touch a running system!!!
« Antwort #13 am: 03 Oktober 2021, 21:43:43 »
Erst mal durchatmen, das haben wir alle durch (Du auch betateilchen?). Ich habe den Kram, glaube ich, zehn Mal aufgesetzt. Einmal saß ich den ganzen Tag dran und meine Frau stand mit der Pfanne daneben, weil nix mehr ging ;D

Nimm das als Schicksalsschlag, hätte ja auch Stromausfall sein können. Den soll es ja demnächst öfter geben.
FHEM 6.0 auf RaspPi3 (Raspbian:  4.19.97-v7+ ); Perl: v5.28.1
SIGNALduino (433 MHz) und HM-UART (868 MHz)
wenige Brennenstuhl-IT, Sonoff, Blitzwolf, Somfy RTS, CAME-Gartentor, Volkszähler, Keyence-Sensor, Homematic-Sensoren und -thermostat, Ferraris-Zähler für Wasseruhr, Openlink-Nachbau Viessmann