FHEM - Hausautomations-Systeme > KNX/EIB

KNXD nach Neuinstallation

(1/1)

Bronze:
Hallo zusammen,
nach einer Neuinstallation bekomme ich zwar KNXD auf einem QNAP-NAS ans Laufen (sudo systemctl -l status bringt grünes Licht und die korrekten Adressen), aber in FHEM kommen noch keine Daten an:


--- Code: ---2021.10.20 00:46:00 0: Server shutdown
2021.10.20 00:46:01 1: Including fhem.cfg
2021.10.20 00:46:02 3: WEB: port 8083 opened
2021.10.20 00:46:02 2: eventTypes: loaded 1282 lines from ./log/eventTypes.txt
2021.10.20 00:46:06 3: TUL opening KNX device eibd:localhost
2021.10.20 00:46:11 3: TUL device opened
2021.10.20 00:46:11 1: Including ./log/fhem.save
2021.10.20 00:46:16 1: usb create starting
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS0
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS1
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS2
2021.10.20 00:46:16 1: PERL WARNING: can't getattr: Input/output error at FHEM/DevIo.pm line 598.
2021.10.20 00:46:16 1: CUL: Can't open /dev/ttyS2: Input/output error
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS3
2021.10.20 00:46:16 1: CUL: Can't open /dev/ttyS3: Input/output error
2021.10.20 00:46:16 1: usb create end
2021.10.20 00:46:16 0: Featurelevel: 6
2021.10.20 00:46:16 0: Server started with 28 defined entities (fhem.pl:25039/2021-10-01 perl:5.030000 os:linux user:fhem pid:141155)
2021.10.20 00:46:16 3: telnetForBlockingFn_1634683576: port 36583 opened
2021.10.20 00:46:21 2: getRequest: communication to knxd failed

2021.10.20 00:46:21 2: GetGroup: seems like knxd not connected

2021.10.20 00:46:21 1: eibd:localhost disconnected, waiting to reappear
2021.10.20 00:46:31 3: OpenDev: OBD response from eibd:localhost
2021.10.20 00:46:31 1: TUL eibd:localhost reappeared (KNX)
--- Ende Code ---

Neustart habe ich schon gemacht. Hat jemand eine Idee?
Gruß, Bronze

Bronze:
Nun werde per autocreate doch die einzelnen KNX-Adressen als Geräte in FHEM angelegt und unter KNX gruppiert.

Allerdings erscheint im Log immer noch minütlich diese Meldung:


--- Code: ---2021.10.20 09:27:23 2: GetGroup: seems like knxd not connected

2021.10.20 09:27:23 1: eibd:localhost disconnected, waiting to reappear
2021.10.20 09:27:33 3: OpenDev: OBD response from eibd:localhost
2021.10.20 09:27:33 1: TUL eibd:localhost reappeared (KNX)
2021.10.20 09:27:43 2: getRequest: communication to knxd failed
--- Ende Code ---

Über FHEM lässt sich entsprechend nicht schalten bzw. kommt keine Info vom KNX-Bus an.

Im Event-Monitor erscheint mindestens jede Minute:

--- Code: ---2021-10-20 10:09:40 TUL KNX DISCONNECTED
2021-10-20 10:09:45 TUL KNX CONNECTED
--- Ende Code ---

erwin:
Hi,

--- Zitat ---Im Event-Monitor erscheint mindestens jede Minute:
--- Ende Zitat ---
ich vermute dass knxd jede minute einmal abstürzt und von systemd neu gestartet wird...
Warum? keine Ahnung, poste doch mal die config vom knxd

PS: disable doch das initialUsbCheck device in fhem, evtl. stört das den seriellen port vom knxd!

--- Zitat ---2021.10.20 00:46:16 1: usb create starting
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS0
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS1
2021.10.20 00:46:16 3: Probing CUL device /dev/ttyS2
--- Ende Zitat ---
l.g. erwin

Bronze:

--- Code: ---DeviceOverview
KNX Initialized
Internals
AckLineDef
Clients :KNX:EIB:
DEF
eibd:localhost 15.15.167
DevType EIBD
DeviceAddress 0ffa7
DeviceName eibd:localhost
FD 7
FUUID 616f4685-f33f-30b9-9d03-e1a3f39ff143eae4
FVERSION 00_TUL.pm:0.156130/2017-12-15
KNX_MSGCNT 106
KNX_TIME 2021-10-21 11:43:42
NAME KNX
NR 35
PARTIAL
RAWMSG C01122p0212100
REFUSED
STATE Initialized
TYPE TUL
--- Ende Code ---

Nach dem Deaktivieren von initialusbcheck zeigt der Log keine Fehler mehr.

Muss man den initialusbcheck komplett deaktivieren oder kann man das nur für KNX machen? Vielleicht gibt es Nebenwirkungen mit anderen Geräten.
Danke.

erwin:
Hi,
es scheint ja zu funktionieren, mit dem initialusbcheck disabled, zumindest sehe ich in deinem list 106 messages...

Ich hab nie verstanden, wozu das   initialusbcheck  gut sein soll, das scanned jeden seriellen port im system und schaut ob ein CUL dahinter steckt...und stört damit jede andere serialle Komm.  Wozu?
das ist das erste was ich nach einer neuinst. disable!
l.g.erwin

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln