Autor Thema: Undefined value fduino, wie finde ich den Schuldigen?  (Gelesen 384 mal)

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 744
Undefined value fduino, wie finde ich den Schuldigen?
« am: 22 Oktober 2021, 18:22:23 »
Hi,

ich habe beim starten von FHEM leider die folgende Meldung:
init_errors
Messages collected while initializing FHEM:./log/fhem.save: Undefined value fduino
Undefined value fduino

Autosave deactivated

Mir ist auch klar das da im save File ein falscher Eintrag stehen muss.
Mein Problem ich habe 455 * fduino im save File.

Normal als IODEV an Devicen.
Einmal mein fduino Device selbst.
Wahrscheinlich ist ein Device drin das kein fduino mehr unterstützt?

Gibt es eine Möglichkeit hier eine etwas spezifischere Fehlermeldung zu erhalten. Z.b. mit Zeile?

Gruß und Danke,
Stefan

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17547
  • s/fhem\.cfg/configDB/g
Antw:Undefined value fduino, wie finde ich den Schuldigen?
« Antwort #1 am: 22 Oktober 2021, 19:43:07 »
Dein FHEM sollte aber doch trotzdem laufen?

Tritt der Fehler auch dann noch auf, wenn Du dann ein erneutes "save" ausführst und FHEM neu startest?
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 744
Antw:Undefined value fduino, wie finde ich den Schuldigen?
« Antwort #2 am: 22 Oktober 2021, 21:36:59 »
Hi,

ja klar FEHM läuft nur Autostart wird deaktiviert.
Ja leider nach Save und Neustart keine Besserung :-(

Gruß,
Stefan

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17547
  • s/fhem\.cfg/configDB/g
Antw:Undefined value fduino, wie finde ich den Schuldigen?
« Antwort #3 am: 23 Oktober 2021, 11:11:55 »
setz mal

attr global verbose 5
mache ein save und dann einen Neustart. Dann sollte eigentlich die fehlerhafte Zeile im Log auftauchen.

Aber vergiß nicht, den verbose level danach wieder zurückzusetzen, sonst explodiert Dein Logfile  :)
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 744
Antw:Undefined value fduino, wie finde ich den Schuldigen?
« Antwort #4 am: 25 Oktober 2021, 15:07:57 »
Hi Betateilchen,

das war mir nicht bewusst dass ich dann so eine gute Ausgabe bekomme.
Habe mit Verbose 5 auf Global folgendes bekommen:
2021.10.25 15:00:29 5: Cmd: >setstate FA20RF_b04767 2021-10-22 21:42:43 IODev fduino<
2021.10.25 15:00:29 5: ./log/fhem.save line 1248 returned >Undefined value fduino<
2021.10.25 15:00:29 5: Cmd: >setstate FA20RF_f146a9 2021-10-22 21:42:44 IODev fduino<
2021.10.25 15:00:29 5: ./log/fhem.save line 1249 returned >Undefined value fduino<

Mit dieser Info konnte ich die fehlerhaften Zeilen endlich löschen.
Und der Initialisierung Fehler ist endlich weg.
Sau gut :-)

Ich danke dir vielmals.

Gruß,
Stefan

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17547
  • s/fhem\.cfg/configDB/g
Antw:Undefined value fduino, wie finde ich den Schuldigen?
« Antwort #5 am: 26 Oktober 2021, 10:15:42 »
das war mir nicht bewusst dass ich dann so eine gute Ausgabe bekomme.

hast Du überhaupt schonmal die Doku zu FHEM gelesen?
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Lesen gefährdet die Unwissenheit!

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 744
Antw:Undefined value fduino, wie finde ich den Schuldigen?
« Antwort #6 am: 26 Oktober 2021, 12:55:35 »
Hi Betateilchen,

doch schon, irgendwie dachte ich ich hätte das schon probiert und es käme nichts.
Mein Fehler...

Leider ist jetzt nach etwas laufen und Neustart der Fehler wieder da.
Irgendein Modul scheint den fduino als iodev reinzuschreiben aber dann nicht benutzen zu wollen?
Sehr seltsam.
Ich schaue mal welche devices es betrifft und ob es die selben sind wie zuvor.

Ja es sind wieder die beiden:
setstate FA20RF_b04767 2021-10-26 09:51:13 IODev fduino
setstate FA20RF_f146a9 2021-10-26 09:51:13 IODev fduino

Der Type der Devices ist:
TYPE FHEMduino_FA20RF

Fehlermeldung nach wie vor: Undefined value fduino

Fduino ist mein fduino device.

Irgendeine Idee warum das passiert? Reihefolge Problem beim starten?

Gruß und Danke,
Stefan


 

decade-submarginal