FHEM - Hausautomations-Systeme > InterTechno

Arduino emuliert CUL und steuert Elro 440S Funksteckdosen

(1/1)

culemu:
In einem Satz: Ein Arduino tut so, als sei er ein CUL, und stellt lediglich den Befehl is zum Senden an Intertechno Switches bereit.

Vorhanden war ein Arduino und ein 433MHz Sender für 3,50 von Wattenrott.
Mit dem Modul rc-switch (google code) lassen sich damit die Elro "Baumarktdosen", die letztlich 10 Bit Adressierung (=1024 Dosen :-) bieten, hervorragend steuern. Von Hand. Oder mit cron.

Fehlte: der Anschluß als FHEM Modul. Meine Wahl fiel auf CUL, weil dort die Ansteuerung bitweise entsprechend den "Mäuseklavieren" in den Steckdosen möglich ist.
Und weil das "echte" CUL OpenSource ist - vielleicht komme ich ja doch mal an eines ran..

Der Arduinosketch war schnell um die paar Kommandos erweitert, die dem CUL Modul als Identifizierung genügen. Das Ergebnis ist vor allem eines: ausbaufähig. Den Sketch hänge ich mal an. Er ist noch nicht von dem manuellen Kommandos "entrümpelt", die als CULemu nicht mehr benutzt werden.

Im Wiki gibts eine umfängliche Abhandlung zur "Intertechno Code Berechnung".

Famme:
Hallo ich bin neu hier im Forum und auch ein Blutiger Anfänger was Fhem angeht aber eigentlich möchte ich glaub ich genau das was du mit den Elro Steckdosen machst. Nur sind meine von brennenstuhl hab mir mal n einfaches Arduino Prog geschrieben das einfach nur Steckdose an und aus schaltet geht super.
Nun zu meiner eigentlichen Frage Hab ne Fritzbox daher Fhem installiert soweit Alles Super nur wie muss ich mir das jetzt weiter vorstellen. Den Arduino per USB an Fritzbox und dann hört es bei mir auf. Wird der irgend wie auf dem WebUI erkannt oder was muss ich konkret ändern um den auf die Fritzbox bzw auf meine Funksteckdosen anzupassen. Entschuldige die doofen fragen aber es ist nicht sehr intuitiv.

Olly:
Hallo,

ich bin auch auf der Suche nach einer Möglichkeit meine Elro Funksteckdosen per Automatisierung zu steuern. Da ist dies eigentlich genau das was ich suche. Einen Arduino (Uno R3) hab ich sowieso immer für Tests parat...
Also fix den Sketch eingespielt und den Arduino per USB an den Raspberry mit FHEM 5.4 angesteckt und per

--- Code: ---
define CUL1 CUL /dev/ttyACM0@115200

--- Ende Code ---

versucht zu initialisieren. Klappt aber nicht so ganz...

Das Log sagt:

--- Code: ---
2013.05.21 22:38:31 3: Opening CUL1 device /dev/ttyACM0
2013.05.21 22:38:31 3: Setting CUL1 baudrate to 115200
2013.05.21 22:38:31 3: CUL1 device opened
2013.05.21 22:38:33 1: Not an CUL device, got for V:  

V 0.70 CULemu

2013.05.21 22:38:33 1: Cannot init /dev/ttyACM0, ignoring it

--- Ende Code ---

Die Versions-Meldung kommt ja, aber ist hier die Leerzeile das Problem, oder wird die für den CUL wohl ungewöhnliche Version nicht erkannt?? Oder ist noch was ganz anderes faul?
Über einen Stups in die richtige Richtung würde ich mich freuen, bin da noch Neuling.

Danke und Gruß

     Olly

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln