Autor Thema: Timeout bei Kommunikation mit ZWave Dongle  (Gelesen 570 mal)

Offline ickster80

  • Newbie
  • Beiträge: 2
Timeout bei Kommunikation mit ZWave Dongle
« am: 01 November 2021, 17:27:50 »
Hi ich benutze Fhem auf einem Raspberry.

Leider hat es vor kurzem die SD-Karte zerstört, und ich musste den Raspberry neu aufsetzen.

Anschließend habe ich FHEM neu installiert, und den Ordner /opt/fhem mit einer alten Sicherung überschrieben.
Dieser blauäugige Plan hat auch halbwegs funktioniert. Es funktioniert alles außer Z-Wave.

Es scheint so, als könnte sich Fhem nicht mit dem Razberry unterhalten.

Kann mit bitte jemand einen Stubs oder Denkanstoß geben?
Ich bekomme auf jeden get-Befehl ein Tiemou:
Timeout reading answer for get nodeList


2021.11.01 17:25:43 4: ZWDongle *** get ZWAVE1 nodeList
2021.11.01 17:25:43 5: ZWDongle_Write 0002 ()
2021.11.01 17:25:43 5: DevIo_SimpleWrite ZWAVE1: 01030002fe
2021.11.01 17:25:43 4: ZWDongle_ReadAnswer arg:nodeList regexp:^0102
2021.11.01 17:25:44 5: ZWDongle_ReadAnswer: select timeout
2021.11.01 17:25:44 2: ZWDongle_ProcessSendStack: no ACK, resending message 01030002fe
2021.11.01 17:25:44 5: DevIo_SimpleWrite ZWAVE1: 01030002fe
2021.11.01 17:25:45 2: ZWDongle_ProcessSendStack: no ACK, resending message 01030002fe
2021.11.01 17:25:45 5: DevIo_SimpleWrite ZWAVE1: 01030002fe
2021.11.01 17:25:46 2: ZWDongle_ProcessSendStack: no ACK, resending message 01030002fe
2021.11.01 17:25:46 5: DevIo_SimpleWrite ZWAVE1: 01030002fe
2021.11.01 17:25:47 2: ZWDongle_ProcessSendStack: no ACK, resending message 01030002fe
2021.11.01 17:25:47 1: ERROR: max send retries reached, removing 01030002fe from dongle sendstack


Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18382
Antw:Timeout bei Kommunikation mit ZWave Dongle
« Antwort #1 am: 01 November 2021, 17:36:18 »
Der Pi hat BT? Dann muss vermutlich  die serielle Schnittstelle vorbereitet werden. Siehe Wiki zu HM-Mod-RPi-PCB.
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline ickster80

  • Newbie
  • Beiträge: 2
Antw:Timeout bei Kommunikation mit ZWave Dongle
« Antwort #2 am: 01 November 2021, 19:22:48 »
Yeah. Vielen vielen Dank.
Genau das war es.

Anhand dieses Artikels: https://wiki.fhem.de/wiki/Raspberry_Pi#Verwendung_UART_f.C3.BCr_Zusatzmodule
habe ich die Schnittstelle nun konfiguriert. Und siehe da: es funktioniert.

Danke