Autor Thema: Kein Zugriff über Putty + Alexa Connector Problem  (Gelesen 725 mal)

Offline RitterSport

  • Full Member
  • ***
  • Beiträge: 283
Kein Zugriff über Putty + Alexa Connector Problem
« am: 03 November 2021, 10:44:25 »
Hallo Zusammen,

ich hatte zugrundeliegend folgende Fehlermeldung im Alexa "Could not resolve hostname fhem-va.fhem.de: Temporary failure in name resolution"
Daraufhin ein RPI update gemacht, neu gestartet und piHole ausgeschaltet welches auch auf dem gleichen Raspi läuft.
Bei weiteren Eingaben und Neustarts kam aber auch jetzt: "Cannot resolve Main01..."
Also piHole deinstalliert.

Ein Zugriff über Putty und der IP 192.168.0.9 ist nicht möglich: "Closed Network Connection.."
auch nicht über Main01
-> Fhem läuft und ist erreichbar über seine IP 192.168.0.9 und Main01
-> In der Fritzbox ist der Name allerdings "RaspberryPiMain" ein ändern auf Main01 hat die gleichen Fehler gebracht
-> Ein Portscan zeigt Main01.fritz.box und Port 22 (TCP) ssh protocol 2.0, sowie Port 80 (TCP) lighttpd 1.4.45 Forbidden
-> Windows Powershell :PS C:\Users\MeinPC> ssh -v 192.168.0.9 22
OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2
debug1: Connecting to 192.168.0.9 [192.168.0.9] port 22.
debug1: Connection established.
debug1: identity file C:\\Users\\MeinPC/.ssh/id_rsa type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_rsa-cert type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_dsa type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_dsa-cert type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_ecdsa type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_ecdsa-cert type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_ed25519 type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_ed25519-cert type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_xmss type -1
debug1: identity file C:\\Users\\MeinPC/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_for_Windows_8.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4p1 Raspbian-10+deb9u7
debug1: match: OpenSSH_7.4p1 Raspbian-10+deb9u7 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
debug1: Authenticating to 192.168.0.9:22 as 'MeinPC'
debug1: SSH2_MSG_KEXINIT sent
Connection closed by 192.168.0.9 port 22

Hat jemand eine Idee wie ich den Schlamassel anpacken kann?

Offline frober

  • Hero Member
  • *****
  • Beiträge: 1137
  • Was man nicht kann, kann man lernen...
Antw: Kein Zugriff über Putty + Alexa Connector Problem
« Antwort #1 am: 03 November 2021, 12:48:38 »
Dein Zugriff scheitert schon einmal, da du den User mit angeben musst.
MeinPC wird nicht der User auf dem Rasi sein!?

ssh user@ip
Raspi 3b mit Raspbian Stretch und relativ aktuellem Fhem,  FS20, LGW, PCA301, MySensors mit RS485(CAN-Receiver), etc.,
einiges umgesetzt, vieles in Planung :-)

********************************************
...man wächst mit der Herausforderung...

Offline RitterSport

  • Full Member
  • ***
  • Beiträge: 283
Antw: Kein Zugriff über Putty + Alexa Connector Problem
« Antwort #2 am: 03 November 2021, 13:01:22 »
Danke schonmal für den Hinweis.

MeinPC habe ich hier in den Ausführungen gesetzt, da dort sonst mein Klarname des Laptops stand. Somit ist richtig, ich komme mit dem User Namen nicht auf den Raspi.
Das war auch nur zum Test, um zu sehen ob Ports offen sind und SSH vorhanden ist.

Ich habe jetzt Bildschirm und Tastatur am Raspi und mich als User pi eingelogt.
->Open SSH ist installiert

Über Windows Powershell:

PS C:\Users\MeinPC> ssh pi@192.168.0.9
debug1: Local version string SSH-2.0-OpenSSH_for_Windows_8.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4p1 Raspbian-10+deb9u7
debug1: match: OpenSSH_7.4p1 Raspbian-10+deb9u7 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
debug1: Authenticating to 192.168.0.9:22 as 'pi'
debug1: SSH2_MSG_KEXINIT sent
Connection closed by 192.168.0.9 port 22


Da ich auch keine Pakete etc installieren kann mit der gleichen Rückmeldung, habe ich mir die /etc/dhcpcd.conf angesehen.
static ip_adress=192.168.0.9/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1 1.1.1.1 1.0.0.1
« Letzte Änderung: 03 November 2021, 13:43:04 von RitterSport »

Offline frober

  • Hero Member
  • *****
  • Beiträge: 1137
  • Was man nicht kann, kann man lernen...
Antw: Kein Zugriff über Putty + Alexa Connector Problem
« Antwort #3 am: 03 November 2021, 13:22:05 »
Bei aktuellen Raspbian Versionen ist ssh nicht aktiviert.

In der command line  ein
sudo raspi-config
dann kannst du es unter 5 aktivieren.
Raspi 3b mit Raspbian Stretch und relativ aktuellem Fhem,  FS20, LGW, PCA301, MySensors mit RS485(CAN-Receiver), etc.,
einiges umgesetzt, vieles in Planung :-)

********************************************
...man wächst mit der Herausforderung...

Offline RitterSport

  • Full Member
  • ***
  • Beiträge: 283
Antw: Kein Zugriff über Putty + Alexa Connector Problem
« Antwort #4 am: 03 November 2021, 13:45:44 »
Habe ich vorsichtshalber probiert. Kein Effekt.
Da ich aber eine bestehende und bisher laufende Konfiguration habe: Es ging ja vorher.

Offline Wernieman

  • Developer
  • Hero Member
  • ****
  • Beiträge: 8280
Antw: Kein Zugriff über Putty + Alexa Connector Problem
« Antwort #5 am: 03 November 2021, 16:18:37 »
Du bekommst ja auch Ausgaben des SSHD

Wenn DU Dich loal einloggst (Du schriebst so etwas?), funktioniert dann ssh?

Was steht in den üblichen Verdächtigen (/var/log/kern.log|auth.log ....)?
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 21079
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw: Kein Zugriff über Putty + Alexa Connector Problem
« Antwort #6 am: 03 November 2021, 17:37:46 »
@RitterSport Ich befürchte Du manipulierst Deine Ausgaben zu sehr und zeigst nicht alles. Das wird schwierig mit Hilfe.
Nimm Bitte Codetags - siehe https://forum.fhem.de/index.php/topic,71806.0.html

Wenn er wirklich an der Stelle abbrichst, klappt der Austausch der Keys nicht.
Mach mal bei lokaler Anmeldung mit User pi:
ls -lha ~/.ssh
Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7590,WRT3200ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266,MQTT,Zigbee,deconz