Autor Thema: Probleme nach Update  (Gelesen 2022 mal)

Offline FHEM_Newone

  • Jr. Member
  • **
  • Beiträge: 73
Probleme nach Update
« am: 07 November 2021, 13:16:09 »
Hallo!

Nach dem Update habe ich festgestellt, dass meine 6-fach Wandtaster Probleme machte. Und zwar schaltete er bei festgelegten Routinen nicht ein oder 2 Actoren, sondern sende eine Vielzahl von Befehlen ab. Meine Rolladen-Aktoren klickten ständig und die Rolladen führen rauf und runter etc.

Ich habe die beiden Taster auf Werkseinstellungen zurückgesetzt, in FHEM gelöscht und wieder neu angelernt. Beim Anlernen fiel mir schon auf, dass die Taster-Eintragungen in der fhem.cfg weg waren, das Device aber in Everything angezeigt wurde. Allerdings nur die 6 Kanäle, nicht der Autor selbst.

Dann habe ich folgendes festgestellt, dass unter Everything/FHEM FHEM auf der gleichen IP-Adresse läuft, aber komische Bezeichnungen (evtl. Hosts) dahinterstehen. Kann mir jemand helfen. Ein shutdown restart brachte keine "Besserung".

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12289
  • NIVEAu ist keine Creme...
Antw:Probleme nach Update
« Antwort #1 am: 07 November 2021, 14:06:55 »
Warum im Unterforum für "Forum-SW"!!? -> verschieben! Kannst du selber...

Sind es Homematic Geräte, eingebunden per CUL_HM? -> "unsaubere" notify/DOIF, mal im Forum suchen... -> Verschieben ins Homematic Forum

Keine Homematic: evtl. selbes Problem aber anderes Unterforum -> passendes suchen

Die Einträge die du im Screenshot hast (bitte keine Screen Shots außer es hat mit Grafik zu tun / besser lists etc. und dann "Code-Tag", das '#' im "Menü"):
das sind nur Verbindungen die der Browser aufmacht, von dem aus du zugreifst (ein Browser macht duchaus mehr als eine Verbindung auf ;) )...

Was fehlt:

list der Devices (mindestens eines), list von beteiligten notify/DOIF, Auszüge aus dem Eventmonitor...
...alles in "Code-Tags"...

EDIT: löschen und neu anlegen etc. ist (fast) immer kontraproduktiv, außer man macht es aus einem bestimmten Grund/weiß, dass es damit zusammenhängt... (aber nicht "einfach so", weil "mal was nicht tut")...

Gruß, Joachim
« Letzte Änderung: 07 November 2021, 14:08:58 von MadMax-FHEM »
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25488
Antw:Probleme nach Update
« Antwort #2 am: 07 November 2021, 14:11:06 »
#1 Das ist der falsche Forumsbereich, das Problem hat mit grosser Wahrscheinlichkeit nichts mit dem Forumssoftware (SMF) zu tun. Das man hier falsch ist, kann man vor dem Posten sehen (gerade geprueft), wenn man das ignoriert, zeigt man, dass die Hausordnung einem egal ist.
#2 Das Betreff ist kontraproduktiv, da fuehlt sich keiner zustaendig.
#3 Selbst im Text steht nichts drin welche Module betroffen sind. FHEM hat ueber 600, keiner kennt sie alle. Um zu helfen braucht man detaillierte Angaben, mit list der einzelnen Geraete, usw. das ist an diversen Stellen beschrieben.
#4 Die im Screenshot dargestellte Eintraege zeigen die aktuell hergestellten Verbindungen zwischen Browser und FHEM und sind ganz normal.

Offline FHEM_Newone

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Probleme nach Update
« Antwort #3 am: 07 November 2021, 20:10:12 »
Danke für Eure Hinweise! Und auch danke dafür, dass Ihr so nachsichtig seid, mir die falsche Einordnung des Themas zu verzeihen. Bin halt kein Hero-Member.

Und, gegen die "Hausordnung" wollte ich auch nicht verstoßen.

Was ist es denn dann? Ein Thema für Hardware? Dachte, dass das in Zusammenhang steht...

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12289
  • NIVEAu ist keine Creme...
Antw:Probleme nach Update
« Antwort #4 am: 07 November 2021, 20:21:07 »
Wenn du schon mal wenigstens schreiben würdest um welche Geräte/Typ/genau Bezeichnung/Hersteller etc. oder Devices/Typ es geht?
Und: ein list davon.

Dann könnte man entweder direkt helfen oder zumindest das passende Unterforum mitteilen...

Gruß, Joachim
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline FHEM_Newone

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Probleme nach Update
« Antwort #5 am: 08 November 2021, 11:12:23 »
Zum einen bin ich verwundert, dass in FHEMWEB die vielen Einträge sind. Dabei konnte ich mir schon selbst erschließen, dass die unterschiedliche IP-Adresse von meinen unterschiedlichen Devices herrühren. In der Firtzbox konnte ich die Geräte durch den letzte Teil der IP-Adresse "wiederfinden". Ich verstehe aber nicht, dass gleiche IP-Adressen mit unterschiedlichen Hosts oder Ports aufgeführt werden.

Bie dem 6-fach Taster handelt es sich um einen Homematic-Taster vom Typ HM-PB-6-WM55. Beim Anlernen in FHEM wurde die einzelnen "Knöpfe" immer mit HM-12345_Btn_01 bis DH-12345_Btn_06 angelegt, aber es fehlte immer das "Haupt"-Device HM-12345. Die Notifys habe ich über FHEM angelegt. Zuerst mit define Name. Dann in der Weboberfläche die Paramter a und b definiert. Dabei habe ich als auszuführende Routine das Schalten von Schaltern und Rolladenaktoren hinterlegt. Bei der Anlage von Gruppen von Rollandenaktoren kam es dann zu den Problemen, dass anscheinend eine Welle von Befehlen gesendet wurde.

Offline marvin78

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5969
Antw:Probleme nach Update
« Antwort #6 am: 08 November 2021, 11:18:10 »
Wenn du den Thread nicht, wie vorgeschlagen verschiebst, wirst du sehr sicher keine brauchbaren Antworten erhalten.

Im Übrigen muss man dafür kein Hero Member sein. Ein wenig das Hirn anschmeißen reicht.
Zustimmung Zustimmung x 2 Liste anzeigen

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12289
  • NIVEAu ist keine Creme...
Antw:Probleme nach Update
« Antwort #7 am: 08 November 2021, 13:18:58 »
Ich verstehe aber nicht, dass gleiche IP-Adressen mit unterschiedlichen Hosts oder Ports aufgeführt werden.

Wurde zwar schon beantwortet (https://forum.fhem.de/index.php/topic,123962.msg1185207.html#msg1185207) aber dann halt noch mal: ein Browser macht durchaus mehr als eine Verbindung auf! Jede dann nat. mit einem neuen Port (weil pro Port nur EINE Verbindung geht) aber nat. mit derselben IP, weil der Browser ja nun mal auf diesem Rechner läuft...


Bie dem 6-fach Taster handelt es sich um einen Homematic-Taster vom Typ HM-PB-6-WM55. Beim Anlernen in FHEM wurde die einzelnen "Knöpfe" immer mit HM-12345_Btn_01 bis DH-12345_Btn_06 angelegt, aber es fehlte immer das "Haupt"-Device HM-12345. Die Notifys habe ich über FHEM angelegt. Zuerst mit define Name. Dann in der Weboberfläche die Paramter a und b definiert. Dabei habe ich als auszuführende Routine das Schalten von Schaltern und Rolladenaktoren hinterlegt. Bei der Anlage von Gruppen von Rollandenaktoren kam es dann zu den Problemen, dass anscheinend eine Welle von Befehlen gesendet wurde.

Notify angelegt: selber (vermute ich weil du was von define schreibst)?
Oder mittels Eventmonitor -> besser und einfacher...

Ich schätze (hatte ich ja auch schon geschrieben), dass eben die Trigger-Regex zu "ungenau" ist und ja es kamen mal Events dazu und wenn eben die Regex zu "groß" gefasst ist, dann triggert das notify halt JETZT öfter als FRÜHER...

ABER: es war schon immer "nicht gut" ;)
(ist halt nur nicht aufgefallen)

Und, steht angepinnt (https://forum.fhem.de/index.php/board,18.0.html bzw. https://forum.fhem.de/index.php/topic,71806.0.html) und wurde (von mir) auch schon angefragt: wo sind die lists der Devices um die es geht (also das/die Homematic Dinger und das/die notify) und Auszüge aus dem Eventmonitor?

Und ja verschieben, sonst wird das nix/mühsam!
(wurde auch schon mehrfach geschrieben)

Gruß, Joachim
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline FHEM_Newone

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Probleme nach Update
« Antwort #8 am: 08 November 2021, 14:02:19 »
@Marvin78: Früher war es hier auch schon einmal freundlicher... Da hat man die Leute, die sich WIRKLICH nur hobbymäßig damit beschäftigen, nicht beleidigt. Das kannst Du vielleicht Dir mal auf einen Zettel schreiben und ins Auto legen. Einfach rausholen, wenn Du das nächste Mal geblitzt wirst. Also nicht den Zettel, sondern das Hirn!

@MadMax-FHEM: Werde dann mal ein Notify anlegen, mit nur einem Aktor. Vielleicht kommen dann die Befehle besser durch. Wie gesagt, der 6-fach Taster war im Betrieb und lief störungsfrei bis zum Update. Vermutlich war er dann aber vorher schon nicht korrekt eingerichtet.

Das Anlernen in FHEM war aber auch schon fehlerhaft. Da kamen ja nicht alle Informationen durch. Kann das mit der Homebridge zusammenhängen, die ich betreibe? Die Überträgt an Homekit bzw. EVE und dort wird in kurzen Intervallen aktualisiert. Können dadurch die Anlernprozesse gestört werden? Wäre es besser beim Anlernen die Homebridge runter zu fahren, damit alle Infors durchkommen.

Und bevor ich wieder das Hirn einschalte... Wie verschiebe ich den Beitrag denn? Mache ich dann auch gerne.

Offline Benni

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2437
  • FHEMinist
Antw:Probleme nach Update
« Antwort #9 am: 08 November 2021, 14:07:58 »
Und bevor ich wieder das Hirn einschalte... Wie verschiebe ich den Beitrag denn? Mache ich dann auch gerne.

... und die Augen auf:

https://forum.fhem.de/index.php?topic=68904.0

Offline FHEM_Newone

  • Jr. Member
  • **
  • Beiträge: 73
Antw:Probleme nach Update
« Antwort #10 am: 08 November 2021, 14:11:39 »
Und übrigens, das ist hier doch ein Anfängerforum, wie ich den Beiträgen entnehmen konnte. Und ohne mich gekrängt zu fühlen, würde ich mich auch als Anfänger bezeichnen.

Offline marvin78

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5969
Antw:Probleme nach Update
« Antwort #11 am: 08 November 2021, 14:12:52 »
Wow...


@Marvin78: Früher war es hier auch schon einmal freundlicher... Da hat man die Leute, die sich WIRKLICH nur hobbymäßig damit beschäftigen, nicht beleidigt. Das kannst Du vielleicht Dir mal auf einen Zettel schreiben und ins Auto legen. Einfach rausholen, wenn Du das nächste Mal geblitzt wirst. Also nicht den Zettel, sondern das Hirn!


1. Schau nach, was eine Beleidigung ist. Hier gab es keine. Nicht einmal deine Auslassung, würde ich als Beleidigung bewerten auch wenn sie unabgebracht und unbedacht ist.
2. Keiner macht das hier beruflich
3. Um die Dinge hier zu verstehen, muss man nur lesen. Nicht mehr.
4. Mein Hinweis wäre tatsächlich hilfreich für dich, da man in dieses Forum nicht schaut um derlei Fragen zu beantworten. Wenn du sie im richtigen Forum stellst, geht das aber in der Regel sehr schnell!

Vielleicht hast du nun was gelernt.

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12289
  • NIVEAu ist keine Creme...
Antw:Probleme nach Update
« Antwort #12 am: 08 November 2021, 14:13:09 »
@MadMax-FHEM: Werde dann mal ein Notify anlegen, mit nur einem Aktor. Vielleicht kommen dann die Befehle besser durch. Wie gesagt, der 6-fach Taster war im Betrieb und lief störungsfrei bis zum Update. Vermutlich war er dann aber vorher schon nicht korrekt eingerichtet.

(Gerne) auch das noch mal: seit einem Update gibt es MEHR (andere/zusätzliche) Events von Homematic Devices! -> wenn die Trigger-RegEx eines notify nicht ausreichend "eng" gefasst war, dann löst das (nat.) öfter (ungewollt9 aus! Gibt einige Threads im Forum dazu (die schon eine Weile her sind, eben seit dem das mit zusätzlichen Events "eingebaut" wurde)...

Poste doch einfach mal (endlich!!) ein list eines betroffenen Homematic Devices und eines dazu gehörigen notify!

Vermutlich war er dann aber vorher schon nicht korrekt eingerichtet.

Davor gab es diese "neuen" Events nicht, da mag die Trigger-Regex (wenn auch "ungenau") halt "gepasst" haben...
...aber ja: war dann verm. schon immer "nicht gut"...

Kann man aber erst sagen, wenn Infos kommen...


Das Anlernen in FHEM war aber auch schon fehlerhaft. Da kamen ja nicht alle Informationen durch. Kann das mit der Homebridge zusammenhängen, die ich betreibe? Die Überträgt an Homekit bzw. EVE und dort wird in kurzen Intervallen aktualisiert. Können dadurch die Anlernprozesse gestört werden? Wäre es besser beim Anlernen die Homebridge runter zu fahren, damit alle Infors durchkommen.

Wenn die angefragten Infos andlich da wären, könnte man auch da weiterhelfen... 8)

Bevor du aber nun (unnötig) viel rumtust: poste doch einfach die angefragten Infos...
...weil sonst kann dir KEINER helfen (selbst wenn du verschiebst)...


Und bevor ich wieder das Hirn einschalte... Wie verschiebe ich den Beitrag denn? Mache ich dann auch gerne.

Habe es selbst auch noch nicht gemacht aber es sollte "irgendwo unten" einen "Knopf"/Link geben...

Vorher halt noch schauen wo du hin "solltest"!
Kommt u.a. auch drauf an wie eingebunden: CUL_HM oder HMCCU (wobei das für's Verschieben egal ist aber du solltest es im Titel nennen)

Zitat
Module: 10_CUL_HM.pm Maintainer: martinp876 Forum: HomeMatic

Zitat
Module: 88_HMCCU.pm Maintainer: zap Forum: HomeMatic

Gruß, Joachim
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline marvin78

  • Developer
  • Hero Member
  • ****
  • Beiträge: 5969
Antw:Probleme nach Update
« Antwort #13 am: 08 November 2021, 14:13:20 »
Und übrigens, das ist hier doch ein Anfängerforum, wie ich den Beiträgen entnehmen konnte. Und ohne mich gekrängt zu fühlen, würde ich mich auch als Anfänger bezeichnen.

Ja. Es hat wohl jemand für dich verschoben. Ob es richtig ist, lasse ich mal dahingestellt.

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12289
  • NIVEAu ist keine Creme...
Antw:Probleme nach Update
« Antwort #14 am: 08 November 2021, 14:14:25 »
Und übrigens, das ist hier doch ein Anfängerforum, wie ich den Beiträgen entnehmen konnte. Und ohne mich gekrängt zu fühlen, würde ich mich auch als Anfänger bezeichnen.

Da hast du ja eben NICHT! gepostet, sondern eben unter "ForumSW" ;)

Selbst Anfänger-Forum wäre besser gewesen ;)

Ja. Es hat wohl jemand für dich verschoben. Ob es richtig ist, lasse ich mal dahingestellt.
EDIT: hmm, jetzt ja ;)

EDIT: und besser als runzutun wäre es endlich mal ein paar (brauchbare) Infos zu liefern... Sonst: nix Hilfe möglich...

Gruß, Joachim
« Letzte Änderung: 08 November 2021, 14:16:07 von MadMax-FHEM »
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)
Zustimmung Zustimmung x 1 Liste anzeigen

 

decade-submarginal