Autor Thema: Probleme mit CUL und FHEM 5.3  (Gelesen 3227 mal)

Physikus

  • Gast
Probleme mit CUL und FHEM 5.3
« am: 19 April 2013, 08:23:38 »
Hallo Forum,

ich bin neu hier, gerade angemeldet, da ich mit der Inbetriebnahme von FHEM mit einem CUL USB stick nicht mehr weiter komme.

Zuerst einmal meine HW und SW-Versionen:

Synology NAS DS112 (Chipsatz Marvell 6282) mit DSM 4.1

darauf habe ich die Pakete von Martin Fischer installiert:

- fhem-5.3-mfr-1.1-syno-88f628x.spk
- usb-driver-kernel-2.6.32-mfr-1.0-syno-88f628x.spk
- perl-5.16.0-mfr-1.0-syno-88f628x.spk
- openssl-1.0.0j-mfr-1.0-syno-88f628x.spk

Die Installationen waren erfolgreich, FHEM selbst und die anderen Pakete laufen, inzwischen ein update durchgeführt, und nun habe ich Probleme den neu bestellten CULv3 ans Laufen zu bringen.

CULv3 Fimware mit FLIP aufgespielt, alles OK.
Wenn an USB der Synology angesteckt, blinkt langsam die Led am CUL (ist also betriebsbereit).
Nach einem Reboot von FHEM wurde ein TCM310 erkannt, aber kein CUL !?
Deshalb habe ich in die cfg ein define hinzugügt.

Die relevanten Zeilen in der fhem.cfg:
(habe sowohl ttyUSB0 wie auch ttyACM0 ausprobiert mit gleichem Ergebnis)

define initialUsbCheck notify global:INITIALIZED usb create

#define CUL CUL /dev/ttyUSB0@9600 1234
define CUL CUL /dev/ttyACM0@9600 1234
 

Damit bekomme ich aber folgende Fehlermeldung:

Can't locate Device/SerialPort.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/MARVELL_88F6281 /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/MARVELL_88F6281 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl . /usr/local/FHEM/share/fhem/FHEM) at /usr/local/FHEM/share/fhem/FHEM/DevIo.pm line 192, <$fh> line 46.

Im Log sieht das dann so aus:

2013.04.19 08:02:32 1: Including /usr/local/FHEM/etc/fhem.cfg
2013.04.19 08:02:32 3: telnetPort: port 7072 opened
2013.04.19 08:02:32 3: WEB: port 8083 opened
2013.04.19 08:02:32 3: WEBphone: port 8084 opened
2013.04.19 08:02:32 3: WEBtablet: port 8085 opened
2013.04.19 08:02:32 3: Opening CUL device /dev/ttyACM0
2013.04.19 08:02:32 1: Can't locate Device/SerialPort.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/MARVELL_88F6281 /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/MARVELL_88F6281 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl . /usr/local/FHEM/share/fhem/FHEM) at /usr/local/FHEM/share/fhem/FHEM/DevIo.pm line 192, <$fh> line 46.
2013.04.19 08:02:32 1: define: Can't locate Device/SerialPort.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/MARVELL_88F6281 /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/MARVELL_88F6281 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl . /usr/local/FHEM/share/fhem/FHEM) at /usr/local/FHEM/share/fhem/FHEM/DevIo.pm line 192, <$fh> line 46.
2013.04.19 08:02:32 1: Including /usr/local/FHEM/var/log/fhem.save

CUL lässt sich natürlich nicht ansprechen.
Kann mir bitte jemand erklären was hier schief läuft und wie ich den CUL ans Laufen bringe?

Danke im voraus

Gruß
Physikus

Physikus

  • Gast
Aw: Probleme mit CUL und FHEM 5.3
« Antwort #1 am: 19 April 2013, 08:53:12 »
Hallo,

bevor sich jemand Mühe macht zu antworten: evtl. hat sich das Problem erledigt.

Ich habe noch einmal ein bisschen rumgespielt und nun scheint es zu funktionieren.
Define muss ttyusb0 sein, es muss ein Reboot der DS mit angestecktem Stick erfolgen und natürlich muss in einem Kommando "CUL" großgeschrieben werden!
Hier haben sich wohl mehrere Fehler addiert :-(
Ich kann den CUL nun ansprechen, ob die Übertragung geht kann ich noch nicht sagen.

 

decade-submarginal