FHEM > Automatisierung

(gelöst) DBLog - Readings mit Umlauten

(1/2) > >>

PS915:
Moin zusammen,

ich habe Probleme mit DBLog. Readings, die Umlaute enthalten werden falsch in der MySQL Datenbank abgespeichert.


Hier zum Beispiel das Reading "weather" von Proplanta. Aus Sprühregen wird in der Datenbank Sprühregen. Das kann ja so nicht gewollt sein, oder?

DB ist mit UTF8   erstellt worden:

--- Code: ---CREATE DATABASE `fhem` DEFAULT CHARACTER SET utf8 COLLATE utf8_bin;

--- Ende Code ---

Wie kann ich das Problem fixen?  :(

CoolTux:
Kannst Du die Abfrage eventuell noch mal direkt auf dem Server in der Konsole machen? Vielleicht ist es ja die Anwendung welche Du verwendest die falsch darstellt.

DS_Starter:
Die Clientverbindung DbLog-> DB auch auf UTF8 einstellen.

Was zeigt denn ein DbLog "set ... configCheck" ?

PS915:
Wie im Screenshot zu sehen, habe ich phpMyAdmin verwendet.
In der Console als auch auf zwei anderen Clients (RemoDB auf Android sowie Grafana auf einer Synology NAS) werden die Umlaute nicht korrekt angezeigt.

Ist also ziemlich sicher, dass es kein Darstellungsfehler ist, sondern wirklich so in der Datenbank abgespeichert wurde.

PS915:
@DS_Starter

Wir kommen der Sache näher:


--- Zitat ---Result of encoding check

Encoding used by Client (connection): LATIN1
Encoding used by DB db10995356-fhem: UTF8
Recommendation: Both encodings should be identical. You can adjust the usage of UTF8 connection by setting the UTF8 parameter in file '/opt/fhem/db.conf' to the right value. Your DBD version fulfills UTF8 support, no need to update DBD.
--- Ende Zitat ---

Nun die Frage, wie stelle ich von LATIN1 auf UTF8 um?

Wie muss das Parameter in db.conf gesetzt werden?

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln