FHEM > Automatisierung

(gelöst) DBLog - Readings mit Umlauten

<< < (2/2)

DS_Starter:
Das steht gleich zu Begin bei "help dblog".

    #%dbconfig= (                                                   
    #    connection => "mysql:database=fhem;host=<database host>;port=3306",   
    #    user => "fhemuser",                                         
    #    password => "fhempassword",
    #    # optional enable(1) / disable(0) UTF-8 support
    #    # (full UTF-8 support exists from DBD::mysql version 4.032, but installing
    #    # 4.042 is highly suggested)   
    #    utf8 => 1   
    #);

D.h. also den Schlüssel "utf8 => 1" setzen. Im Internal steht dann UTF8 auf "1".

PS915:
Vielen Dank euch! Nach der Änderung der db.conf und einem set DBLogging rereadcfg steht der Internal UTF8 auf 1 und die Umlaute werden korrekt übertragen! :)

Wieder etwas gelernt!  ::) 

DS_Starter:
:)

Navigation

[0] Themen-Index

[*] Vorherige Sete

Zur normalen Ansicht wechseln