FHEM - Hausautomations-Systeme > Homematic

HmIP-SMO-A - Problem / sendet nicht immer

(1/1)

remo:
Hey ihr Profis ;)

ein frohes neues Jahr wünsche ich noch!

Ich habe mir einen HmIP-SMO-A zugelegt.
An meiner CCU2 angelernt und eingestellt.
So weit, so gut.

Bewegungen werden erkannt und FHEM bekommt diese auch mit.
Die Kommunikation funktioniert also grundsätzlich.


Nun habe ich aber ein Problem (Verständnis oder technisch):

Szenario 1

Lasse ich den Bewergungsmelder 1x auslösen, schaltet FHEM meine Test-Lampe ein.
Ohne weitere Bewegung schaltet die Lampe dann auch wieder aus.
Dieses Szenario kann ich beliebig oft wiederholen - mit zuverlässig, reproduzierbarem Ergebnis.


Szenario 2

Mache ich für z.B. für 5 Minuten einen "Hampelmann" im Erfassungsfeld des Bewegungsmelders,
schaltet FHEM die Lampe ein - und die Lampe bleibt auch ein, weil ja immer wieder Bewegung registriert wird.
Soweit in Ordnung.

Stoppt nun die Bewegung, passiert eines von zwei Dingen (sporadisch abwechselnd):
1) Der Melder sendet noMotion erst wieder nach der Zeit, die er Motion gesendet hat (also ca. 5 Minuten - solange bleibt die Lampe ein und schaltet dann aus).
2) Der Melder sendet gar kein noMotion mehr - erst nachdem ich die Batterien neu eingesetzt habe.



Firmware, CCU2, FHEM sind auf aktuellem Stand

Kennt dieses Phänomen jemand?
Oder verstehe ich grundsätzlich etwas falsch?
Vielleicht hat jemand einen Schubs in die richtige Richtung für mich?!

Liebe Grüße






--- Code: ---Internals:
   DEF        xxxxxxxxxx:1
   FUUID      61dfd705-f33f-f9d8-4eda-199fd9a2b7e395fc
   IODev      CCU
   NAME       sensor_Bewegung_Carport
   NR         772
   STATE      noMotion
   TYPE       HMCCUCHN
   ccuaddr    xxxxxxxxxx:1
   ccudevstate active
   ccuif      HmIP-RF
   ccuname    sensor-Bewegung_Carport:1
   ccurolectrl MOTIONDETECTOR_TRANSCEIVER
   ccurolestate MOTIONDETECTOR_TRANSCEIVER
   ccusubtype SMO
   ccutype    HmIP-SMO-A
   firmware   1.2.8
   readonly   no
   READINGS:
     2022-01-13 08:39:35   CURRENT_ILLUMINATION 1.7
     2022-01-13 08:39:35   CURRENT_ILLUMINATION_STATUS NORMAL
     2022-01-13 11:59:34   ILLUMINATION_STATUS NORMAL
     2022-01-13 08:38:45   IODev           CCU
     2022-01-13 11:59:34   activity        alive
     2022-01-13 11:59:34   battery         ok
     2022-01-13 11:59:34   brightness      16.1
     2022-01-13 11:59:34   control         active
     2022-01-13 11:59:34   detection       active
     2022-01-13 11:59:34   devstate        ok
     2022-01-13 11:59:34   hmstate         noMotion
     2022-01-13 11:59:34   motion          noMotion
     2022-01-13 11:59:34   rssidevice      -78
     2022-01-13 08:39:34   rssipeer        -64
     2022-01-13 11:59:34   state           noMotion
     2022-01-13 11:59:34   voltage         2.9
   hmccu:
     channels   1
     detect     1
     devspec    xxxxxxxxxx:1
     nodefaults 1
     role       1:MOTIONDETECTOR_TRANSCEIVER
     setDefaults 0
     cmdlist:
       get       
       set        detection:inactive,active reset:noArg toggle:noArg
     control:
       chn        1
       dpt        MOTION_DETECTION_ACTIVE
     dp:
       0.CONFIG_PENDING:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      false
           OVAL       0
           SVAL       false
           VAL        0
       0.DUTY_CYCLE:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      false
           OVAL       0
           SVAL       false
           VAL        0
       0.ERROR_CODE:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      0
           OVAL       0
           SVAL       0
           VAL        0
       0.LOW_BAT:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      ok
           OVAL       0
           SVAL       ok
           VAL        0
       0.OPERATING_VOLTAGE:
         VALUES:
           NVAL       2.9
           ONVAL      2.9
           OSVAL      2.9
           OVAL       2.9
           SVAL       2.9
           VAL        2.9
       0.OPERATING_VOLTAGE_STATUS:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      NORMAL
           OVAL       0
           SVAL       NORMAL
           VAL        0
       0.RSSI_DEVICE:
         VALUES:
           NVAL       -78
           ONVAL      -78
           OSVAL      -78
           OVAL       -78
           SVAL       -78
           VAL        -78
       0.RSSI_PEER:
         VALUES:
           NVAL       -64
           ONVAL      -64
           OSVAL      -64
           OVAL       -64
           SVAL       -64
           VAL        -64
       0.UNREACH:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      alive
           OVAL       0
           SVAL       alive
           VAL        0
       1.CURRENT_ILLUMINATION:
         VALUES:
           NVAL       1.7
           ONVAL      1.7
           OSVAL      1.7
           OVAL       1.7
           SVAL       1.7
           VAL        1.7
       1.CURRENT_ILLUMINATION_STATUS:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      NORMAL
           OVAL       0
           SVAL       NORMAL
           VAL        0
       1.ILLUMINATION:
         VALUES:
           NVAL       16.1
           ONVAL      13.1
           OSVAL      13.1
           OVAL       13.1
           SVAL       16.1
           VAL        16.1
       1.ILLUMINATION_STATUS:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      NORMAL
           OVAL       0
           SVAL       NORMAL
           VAL        0
       1.MOTION:
         VALUES:
           NVAL       0
           ONVAL      0
           OSVAL      noMotion
           OVAL       0
           SVAL       noMotion
           VAL        0
       1.MOTION_DETECTION_ACTIVE:
         VALUES:
           NVAL       1
           ONVAL      1
           OSVAL      active
           OVAL       1
           SVAL       active
           VAL        1
     roleCmds:
       get:
       set:
         detection:
           channel    1
           role       MOTIONDETECTOR_TRANSCEIVER
           subcount   1
           syntax     V:MOTION_DETECTION_ACTIVE:#detection=inactive,active
           usage      detection {inactive,active}
           subcmd:
             000:
               args       inactive,active
               dpt        MOTION_DETECTION_ACTIVE
               fnc       
               max        1
               min        0
               parname    detection
               partype    1
               ps         VALUES
               scn        000
               unit       
               look:
                 active     1
                 inactive   0
         reset:
           channel    1
           role       MOTIONDETECTOR_TRANSCEIVER
           subcount   1
           syntax     V:RESET_MOTION:true
           usage      reset
           subcmd:
             000:
               args       true
               dpt        RESET_MOTION
               fnc       
               max        1
               min        0
               parname    RESET_MOTION
               partype    3
               ps         VALUES
               scn        000
               unit       
     state:
       chn        1
       dpt        MOTION
Attributes:
   room       TEST

--- Ende Code ---




--- Code: ---define sensor_Bewegung_Carport HMCCUCHN xxxxxxxxxx:1
attr sensor_Bewegung_Carport room TEST
define notify_Bewegung_Carport_EIN notify sensor_Bewegung_Carport:motion { fhem ("set shelly1_Test1 on") }
define notify_Bewegung_Carport_AUS notify sensor_Bewegung_Carport:noMotion { fhem ("set shelly1_Test1 off") }

--- Ende Code ---


zap:
Hast Du mal in der CCU geschaut, ob dort no motion zeitnah angezeigt wird?

Ggf. könntest Du auch ein kleines Programm in der CCU definieren, das den Zustand abfragt und bei Änderung eine Systemvariable setzt.

Dadurch könnte man herausfinden, ob es an der Kommunikation CCU - FHEM liegt.

remo:

--- Zitat ---Hast Du mal in der CCU geschaut, ob dort no motion zeitnah angezeigt wird?
--- Ende Zitat ---
Ja, habe ich. Auf der CCU2 hängt es dann auch.

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln