Autor Thema: GPIO-Probleme nach neuinstallation  (Gelesen 129 mal)

Offline abc2006

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1015
GPIO-Probleme nach neuinstallation
« am: 14 Januar 2022, 14:49:57 »
Hi,
bei meinem Raspberry ist die SD-Karte abgeraucht. Nun, bei der neuinstallation, habe ich Probleme mit dem Zugriff auf die GPIO's.
An (u.a.) GPIO 22 und 25 sind Relais angeschlossen.

Laut Fhemwiki (https://wiki.fhem.de/wiki/Raspberry_Pi:_GPIOs_schalten) ist es nicht nötig, wiringPi zu installieren.
Leider reagieren die (output)GPIO so gar nicht auf meine FHEM-Devices:

Zitat
Internals:
   DEF        22
   FUUID      61e15d6f-f33f-8758-bd85-297caa181e60b850
   GPIO_Basedir /sys/class/gpio
   GPIO_Nr    22
   NAME       Heizstab_backup
   NR         14
   STATE      on
   TYPE       RPI_GPIO
   WiringPi_gpio /usr/bin/gpio
   READINGS:
     2022-01-14 14:43:47   Pinlevel        low
     2022-01-14 14:25:57   state           on
   fhem:
     interfaces switch
Attributes:
   direction  output
   verbose    5

Also hab ich gesucht, gefunden und die aktuellste version von WiringPi heruntergeladen:
http://wiringpi.com/wiringpi-updated-to-2-52-for-the-raspberry-pi-4b/

User fhem ist in der gruppe gpio drin.
Rebootet hab ich mehrfach.

Mit "gpio readall" bekomme ich die GPIO's angezeigt
mit "gpio mode 25 direction output" ändert sich in der Anzeige die Richtung von IN auf OUT
mit "attr Heizstab_backup direction output" tut sich in der WiringPi-Anzeige nichts, dafür ändert sich in der Datei /sys/class/gpio/gpio22/direction der Inhalt von IN auf OUT
mit "gpio toggle 25" schaltet das an GPIO 25 angeschlossene Relais
mit set Heizstab_backup  toggle schaltet das an GPIO 22 angeschlossene Relais NICHT.

Jemand ne Idee?
Laut Wiki klingt es so, als würde ich die SD-Karte mit rpi-imager bespielen, in den Raspi stecken, fhem installieren, ein define xy RPI_GPIO 25 ausführen und könnte den GPIO nutzen.
Anscheinend funktioniert das so nicht.
Ich bin ratlos.

Danke und lg,
Stephan
FHEM nightly auf Intel Atom (lubuntu) mit VDSL 50000 ;-)
Nutze zur Zeit OneWire und KNX

Offline ollir

  • Full Member
  • ***
  • Beiträge: 174
Antw:GPIO-Probleme nach neuinstallation
« Antwort #1 am: 14 Januar 2022, 14:55:32 »
fhem hast du zur Gruppe hinzugefügt?
sudo adduser fhem gpio

Edit: danach einen reboot
« Letzte Änderung: 14 Januar 2022, 17:28:15 von ollir »

Offline abc2006

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1015
Antw:GPIO-Probleme nach neuinstallation
« Antwort #2 am: 14 Januar 2022, 15:01:59 »

User fhem ist in der gruppe gpio drin.


Danke für den Tipp,
hab ich gemacht.
FHEM nightly auf Intel Atom (lubuntu) mit VDSL 50000 ;-)
Nutze zur Zeit OneWire und KNX