Autor Thema: TCM 310_0 Timeout  (Gelesen 1134 mal)

Offline dobiwan

  • Jr. Member
  • **
  • Beiträge: 73
TCM 310_0 Timeout
« am: 03 Februar 2022, 10:52:03 »
Hallo zusammen,

ich habe jetzt auf mehreren Seiten nach einer Lösung für mein Problem zu finden. Leider ohne Erfolg.
Also ich habe ein EnOcean Board auf meinem Raspi 3 gesteckt. Ich hatte ursprünglich das Modul auf einem Raspi B. Dort konnte ich EnOcean Aktoren und Sender integrieren.
Ich habe jetzt neue Aktoren und wollte alles neu anlernen. Leider bekomme ich grundsätzlich ein Timeout, obwohl das Gerät als initialized angezeigt wird. ich habe auch das /dev/ttyAMA0@57600 wenn ich mir auf der Konsole alles ansehe. Es wird aber nichts entscheidendes ins Log geschrieben. Habe nachgelesen und auf dem Pi die serielle Konsole deaktiviert. Dann habe ich folgendes ausprobiert mit folgendem Eintrag in der config.txt dtoverlay=pi3-miniuart-bt. Das führt aber dazu, dass ich das ttyAMA0 nicht mehr habe und in der Oberfläche auch disconnected steht. Es heißt man soll die interne Bluetooth Schnittstelle deaktivieren
Also das Gerät ist da, aber wenn ich mir die ID oder irgendetwas anderes anzeigen lassen will kommt ein Timeout. Somit kann ich das Modul auch nicht in den Teach Modus versetzen.

Hat jemand noch eine Idee !?

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12300
  • NIVEAu ist keine Creme...
Antw:TCM 310_0 Timeout
« Antwort #1 am: 03 Februar 2022, 11:18:09 »
Klingt für mich (trotzdem du es gemacht hast?) nach seriell nicht aktiviert und/oder BT schnappt sich die Schnittstelle...

Das hast du abgearbeitet: https://wiki.fhem.de/wiki/Raspberry_Pi#Verwendung_UART_f.C3.BCr_Zusatzmodule
(ist bei einem PI3 wegen BT etc. wichtig)

Ich denke mittlerweile heißt das Overlay aber anders (bzw. hängt das von der Raspbian Version ab), siehe meine Notizen...

Hast du die serielle Schnittstelle aktiviert (ich mache das immer per raspi-config / es geht aber [wohl] auch der Eintrag in der /boot/config.txt)?

Ich "deaktiviere" ja BT immer komplett inkl. Deinstallation :)
(ist aber nicht nötig aber da ich BT nicht nutze brauche ich die SW auch nicht "mitschleppen" ;)  dieser Schritt ist in meinen Notizen nicht aufgeführt)

Hier meine Notizen bzgl. EnOcean-Aufsteck-Board:

Zitat
sudo systemctl disable hciuart

sudo nano /boot/config.txt

dtoverlay=disable-bt
enable_uart=1

sudo raspi-config
enable serial

sudo nano /boot/cmdline.txt
remove: 'console=serial0,115200'

define EnOceanPI TCM ESP3 /dev/ttyAMA0@57600

Gruß, Joachim
« Letzte Änderung: 03 Februar 2022, 11:20:14 von MadMax-FHEM »
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline dobiwan

  • Jr. Member
  • **
  • Beiträge: 73
Antw:TCM 310_0 Timeout
« Antwort #2 am: 07 Februar 2022, 09:47:25 »
Danke habe es hinbekommen.

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12300
  • NIVEAu ist keine Creme...
Antw:TCM 310_0 Timeout
« Antwort #3 am: 07 Februar 2022, 09:50:06 »
Danke habe es hinbekommen.

Sagst du mir/uns auch noch: wie

Und setzt du dann auf gelöst, also z.B. [gelöst] "vor" den ersten Post, danke.

Gruß, Joachim
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline dobiwan

  • Jr. Member
  • **
  • Beiträge: 73
Antw:TCM 310_0 Timeout
« Antwort #4 am: 08 Februar 2022, 08:14:13 »
Hallo,

ich habe noch mal das raspi-config durchgeführt und die Einträge in der config.txt gelöscht neu erstellt, dann ging es nach dem Neustart.

 

decade-submarginal