Autor Thema: CUN V1.2 funktioniert nicht mehr nach Firmware update auf 1.67  (Gelesen 1327 mal)

Offline outage

  • Newbie
  • Beiträge: 2
Hallo,

Ich habe mein CUN V1.2 mit der neuesten Firmware 1.67 versehen. Vorher hatte ich 1.39 auf dem Gerät.

Das funktionierte zunächst nicht (Device not found), aber ein Thema hier sagte, dass ich im makefile den Chip ändern sollte von
MCU = at90usb1286 auf
MCU = at90usb646
Somit funktionierte das Firmware-Update. Mein CUN hat einen at90usb646 auf der Platine.

Allerdings bekomme ich seitdem das CUN nicht mehr ins Netzwerk. DHCP ist eingerichtet und funktioniert. Ich habe verschiedene Gigabit und 100MBit Switches verwendet.

Wenn ich das CUN über USB an meinen Debian 11 Rechner anschließe - ohne Drücken der Taste - wird kein Gerät erkannt (keine Änderung unter dmesg).
Wenn ich das CUN über USB - mit Drücken der Taste - wird ein USB-Gerät erkannt, aber es werden nur einige Fehlermeldungen ausgegeben, die ich gerade nicht zur Hand habe.

Ein neuer Flash-Versuch scheiterte ein paar Mal (Device not found), funktionierte aber noch einmal, allerdings ohne Änderung in der Funktionalität (CUN zeigt sich nicht im Netz).

Gibt es eine Möglichkeit an die alte 1.39 Firmware zu kommen, um diese wieder aufzuspielen? Eigentlich war ich im Großen und Ganzen damit zufrieden.
 
MfG Stefan

Offline outage

  • Newbie
  • Beiträge: 2
Antw:CUN V1.2 funktioniert nicht mehr nach Firmware update auf 1.67
« Antwort #1 am: 20 März 2022, 13:31:28 »
Hier noch die dmesg Einträge für das Einstecken mit gedrückter Taste:

[  304.471525] usb 4-1: new full-speed USB device number 2 using uhci_hcd
[  305.147520] usb 4-1: device descriptor read/64, error -71
[  310.955525] usb 4-1: device descriptor read/64, error -84
[  311.191521] usb 4-1: new full-speed USB device number 3 using uhci_hcd
[  311.363520] usb 4-1: device descriptor read/64, error -71
[  311.647519] usb 4-1: device descriptor read/64, error -71
[  311.755547] usb usb4-port1: attempt power cycle
[  311.907521] usb 4-1: new full-speed USB device number 4 using uhci_hcd
[  322.647526] usb 4-1: device not accepting address 4, error -110
[  322.775520] usb 4-1: new full-speed USB device number 5 using uhci_hcd

Offline fiedel

  • Hero Member
  • *****
  • Beiträge: 1893
Antw:CUN V1.2 funktioniert nicht mehr nach Firmware update auf 1.67
« Antwort #2 am: 22 März 2022, 10:10:45 »
Hi Stefan,

hattest du vor dem Flashen (vor dem make) in der board.h die von dir nicht benötigten Protokolle auf undef gesetzt?
Manchmal hilft das schon. Ansonsten könntest du auch die a-culfw probieren. Die sollte ebenfalls den CUN untersützen.

Gruß
Fiedel
FeatureLevel: 6.1 auf Wyse N03D ; Deb. 11 ; Perl: v5.14.2 ; IO: HM-MOD-RPI-PCB + VCCU|CUL 868 V 1.66|LinkUSBi |TEK603
HM: SEC-SCO|SCI-3-FM|LC-SW4-PCB|ES-PMSW1-PL|RC-4-2|SEN-MDIR-O|SEC-WDS-2
CUL: HMS100TF|FS20 S4A-2 ; OWDevice: DS18S20|DS2401|DS2406|DS2423

 

decade-submarginal