FHEM > Automatisierung

[ASC] Seltsames Verhalten bei RainProtection

<< < (2/9) > >>

CoolTux:
Ich lese ausschließlich


--- Code: ---ASC_ShuttersLastDrive: rain un-protected
--- Ende Code ---

wo sind denn die Zeilen für rain protected? Bevor in un-protected gefahren wird muss ja erstmal in protected gefahren worden sein.
Hat es denn tatsächlich geregnet?

Romoker:
Ich bin gerade vom Einkaufen zurückgekommen und die Markise war wieder ausgefahren und wackelte bedenklich im Wind, obwohl ich gestern Abend Shading im ASC_Device global ausgeschaltet habe!
Gerade (13:30 Uhr) hat der Regensensor angeschlagen und die Markise wurde wieder geschlossen, war im protected-Modus und ist 9 Minuten später (Regensensor dry) wieder in die Schattenstellung gefahren bei 'controlShading off'.

Hier die Markisen-relevanten Logeinträge:

--- Code: ---2022-04-05_23:12:14 Markise ASC_ShadingMessage: <html> INFO:  shading was deactivated globally </html>
2022-04-06_12:33:25 h_wetterComHandorf Status: rain
2022-04-06_12:48:25 h_wetterComHandorf Status: dry
2022-04-06_12:48:28 Markise ASC_ShuttersLastDrive: rain un-protected
2022-04-06_12:49:01 Markise finalPos: 90
2022-04-06_13:30:26 h_wetterComHandorf Status: rain
2022-04-06_13:31:05 Markise finalPos: 0
2022-04-06_13:31:05 Markise ASC_ShuttersLastDrive: rain protected
2022-04-06_13:39:28 h_wetterComHandorf Status: dry
2022-04-06_13:39:32 Markise ASC_ShuttersLastDrive: rain un-protected
2022-04-06_13:40:04 Markise finalPos: 90
--- Ende Code ---

Viele Grüße

CoolTux:
So sehe ich leider nichts.

Bitte verbose vom ASC auf 4 stellen und debug auf 1 und mir dann den entsprechenden Zeitraum zukommen lassen in welchen es ein nicht erwartetes Verhalten gab.

Romoker:
OK - dann werfe ich mal das Debugging an.

Viele Grüße

Romoker:
Ich musste das stundenlange Debugging Vorgestern abbrechen, da das Fehlverhalten (Fahren zur Nachtzeit) nicht aufgetreten ist und meine Log-Datei zu voll wurde.

Du hast geschrieben, dass ASC immer die letzte Position anfährt, wenn die Schutzbedingung nicht mehr erfüllt ist. Das würde bedeuten, dass ASC z.B. vor einer rain-unprotected-Fahrt andere Bedingungen, wie z.B. Schatten, Wind, Tag/Nacht, nicht prüft.
Wenn das so ist, kann das der Grund für folgendes Fehlverhalten sein, das ich gestern beobachtet habe:
Gestern war viel Regen und Wind. Die Markise war im rain-protected Modus. Ich habe dann zwischenzeitlich die Schwellwerte für WindProtection nach unten korrigiert. Dann öffnete die Markise plötzlich in 'wind un-protected' (der Wind-Schwellwert war unterschritten) auf die alte Position, obwohl der Regensensor immer noch 'rain' anzeigte. Leider habe ich dazu keinen Debug-Log.
Vielleicht kannst Du die ASC-Logik dahingehend nochmal überprüfen.

Viele Grüße

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln