Autor Thema: Modul für Pushover  (Gelesen 303621 mal)

Offline kadettilac89

  • Hero Member
  • *****
  • Beiträge: 1570
Antw:Modul für Pushover
« Antwort #795 am: 29 September 2022, 15:58:00 »
Hallo zusammen,

beim Empfang der Pushnachrichten aus FHEM, wird in der Nachricht immer das FHEM Logo mitgesendet.
Ist es möglich dies zu deaktivieren?
Welches Logo du mitsendest legst du doch im Channel in Pushover selbst fest. Oder welches Logo meinst du?

Offline kadettilac89

  • Hero Member
  • *****
  • Beiträge: 1570
Antw:Modul für Pushover
« Antwort #796 am: 29 September 2022, 15:59:47 »
"Your Application"???

Offline pitman

  • Jr. Member
  • **
  • Beiträge: 71
Antw:Modul für Pushover
« Antwort #797 am: 29 September 2022, 20:02:10 »
Oh Mann. 🤦‍♂️
Ich hab es jahrelang genutzt, ohne irgendetwas zu ändern.

Vielen Dank für die Auffrischung 👍

Offline pitman

  • Jr. Member
  • **
  • Beiträge: 71
Antw:Modul für Pushover
« Antwort #798 am: 30 September 2022, 13:55:48 »
Ist es möglich über FHEM einen Smiley bzw. einen Emoji per Pushover zu senden?

Offline kadettilac89

  • Hero Member
  • *****
  • Beiträge: 1570
Antw:Modul für Pushover
« Antwort #799 am: 01 Oktober 2022, 16:53:40 »
Ist es möglich über FHEM einen Smiley bzw. einen Emoji per Pushover zu senden?
an apple watch scheinbar, ansonsten nein. Zumindest weiß ich nichts davon

https://forum.fhem.de/index.php/topic,16215.msg907766.html#msg907766


Offline Thyraz

  • Hero Member
  • *****
  • Beiträge: 1306
Antw:Modul für Pushover
« Antwort #800 am: 05 Oktober 2022, 13:36:59 »
Also als Inhalt einer Nachricht?
Einfach den Emoji (der ja auch nur ein Unicode "Text"-zeichen ist) an der richtige Stelle in den set Befehl des Pushover Moduls einsetzen, damit er als Teil der Message geschickt wird, oder eben als alleinige Message ohne weiteren Text.
Fhem und MariaDB auf NUC6i5SYH in Proxmox Container (Ubuntu)
Zwave, Conbee II, Hue, Harmony, Solo4k, LaMetric, Echo, Sonos, Roborock S5, Nuki, Prusa Mini, Doorbird, ...

Offline bismosa

  • Developer
  • Full Member
  • ****
  • Beiträge: 485
Antw:Modul für Pushover
« Antwort #801 am: 13 November 2022, 15:18:06 »
Hallo!

Ich habe seit kurzen (ein paar Tage) irgendwie Schwierigkeiten Nachrichten zu verschicken. Es kommt immer wieder zu einem Timeout:
Nachricht:
set pushmsg msg device=Tab title='Wasser in Küche ausgelaufen!' sound=siren priority=2 retry=30 expire=3600 ACHTUNG! In der Küche ist Wasser ausgelaufen! Sofort beheben! Batterie: 2.80 V Batteriestatus: ok RSSI: -58
Bisher sind diese Nachrichten immer problemlos durchgekommen. jetzt lese ich bei Verbose 1 etwas von RCV Timeout.

Ich habe festgestellt, dass die Nachrichten bisher durchkommen, wenn ich im Modul das Timeout auf 10sekunden setze. Könnte das Attribut (was ja in dem Programmpart bereits abgefragt wird, aber nicht verfügbar ist) mit eingebaut werden?

Warum es jetzt zu dem Timeouts kommt weiß ich nicht. Sind die Nachrichten etwas kürzer kommen diese eigentlich immer durch. Diese werden aber auch von einem anderen DOIF versendet.
Ich könnte mir vorstellen, das mein FHEM auf dem Raspberry einfach etwas mehr ausgelastet ist (Ich bin gerade dabei mir ein FTUI interface zu erstellen). Vielleicht ist unsere Internetverbindung auch einfach nicht die beste...oder Pushover ist langsamer geworden?

Gruß
Bismosa
1x nanoCUL 433MHz (SlowRF Intertechno) für Fenstersensoren
1x nanoCUL 868Mhz für MAX (9x HT 1xWT)
1x ZigBee CUL
Weiteres: Squeezebox server, Kindle Display, ESP8266, Löterfahrung, ...

Offline kadettilac89

  • Hero Member
  • *****
  • Beiträge: 1570
Antw:Modul für Pushover
« Antwort #802 am: 13 November 2022, 16:54:39 »
Warum es jetzt zu dem Timeouts kommt weiß ich nicht. Sind die Nachrichten etwas kürzer kommen diese eigentlich immer durch. Diese werden aber auch von einem anderen DOIF versendet.
Ich könnte mir vorstellen, das mein FHEM auf dem Raspberry einfach etwas mehr ausgelastet ist (Ich bin gerade dabei mir ein FTUI interface zu erstellen). Vielleicht ist unsere Internetverbindung auch einfach nicht die beste...oder Pushover ist langsamer geworden?
Ich habe zwar mehr Leistung als einen Raspberry aber das Versenden ist ... Klicken und das Handy blinkt. Ohne irgend einen Delay. Vermutlich hast du irgendwo anders ein Problem.

Eine Idee, hast du DNS-Attribut gesetzt? Vielleicht hat dein Raspberry ein Problem mit der Namensauflösung.

Attribut irgend sowas ... die Ip deines DNS musst du selber wissen und entsprechend setzen.
attr global dnsServer 127.0.0.11

Offline bismosa

  • Developer
  • Full Member
  • ****
  • Beiträge: 485
Antw:Modul für Pushover
« Antwort #803 am: 13 November 2022, 20:14:56 »
Hallo!

Wie bereits geschrieben ist mein Raspberry nicht sehr potent und hat mittlerweile viele Aufgaben zu erledigen.
Suboptimal dazu ist, das die Nachricht zu einer Zeit verschickt wird, wenn der Raspberry eh schon auf 100% Auslastung läuft.
Das hängt auch damit zusammen, das in diesem Fall ein selbstgebauter Wassermelder mittels "http get" seine Werte meldet. Da ist FHEM eh etwas mehr ausgelastet. Die Firmware ist jedoch "fix". Da kann ich nur mit zu großem Aufwand etwas ändern...z.B. telnet verwenden. (und bisher funktionierte es ja auch  ;) )

Ich gehe nochmal weiter auf Fehlersuche. Es passiert auch häufig, wenn ich das nur als Kommando abschicke.
Jedoch kommen die Nachrichten mit einem längeren Timeout eigentlich bisher immer durch. Da es ja auch Nonblocking ist, passiert ja nichts, wenn ein Augenblick länger gewartet wird.
So sehen die Zeiten übrigens bei mir aus:
2022.11.13 20:08:47 5: Pushover pushmsg: GET https://api.pushover.net:443/1/messages.json ...
2022.11.13 20:08:51 5: Pushover pushmsg: Received HttpUtils callback: ...
2022.11.13 20:13:05 5: Pushover pushmsg: GET https://api.pushover.net:443/1/messages.json ...
2022.11.13 20:13:09 5: Pushover pushmsg: Received HttpUtils callback


Gruß
Bismosa
1x nanoCUL 433MHz (SlowRF Intertechno) für Fenstersensoren
1x nanoCUL 868Mhz für MAX (9x HT 1xWT)
1x ZigBee CUL
Weiteres: Squeezebox server, Kindle Display, ESP8266, Löterfahrung, ...

 

decade-submarginal