FHEM > English Corner

Error:Modul 00_MQTT2_CLIENT deactivate after error

(1/1)

kroonen:
Hi,

I updated fhem, and now I get an error on the MQTT2_CLIENT

Global symbol "$FW_chash" requires explicit package name (did you forget to declare "my $FW_chash"?) at ./FHEM/00_MQTT2_CLIENT.pm line 724, <$fh> line 20.

any idea how to solve this?

Beta-User:
The update has been complete? As Rudi has posted in https://forum.fhem.de/index.php/topic,127223.msg1217668.html#msg1217668, there are a few more pieces of code affected to get that up and running.

"update check" might reveal problems in the update process.

rudolfkoenig:
Sorry, my fault, I fixed it now.

In your configuration MQTT2_CLIENT is defined before a FHEMWEB instance. As a workaround you could change that, or wait until the FHEM-update tomorrow.

kroonen:
I did an update today, and works again. thnx

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln