Autor Thema: Probleme beim Anlernen neuer Devices  (Gelesen 1376 mal)

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3993
Probleme beim Anlernen neuer Devices
« am: 05 September 2022, 11:03:03 »
Hi,

habe jetzt meinen ersten FT55-rw Schalter und einen USB-300 Stick.
Anleitung im Wiki habe ich gelesen. Der USB Stick ist in FHEM angelegt.
Wenn ich nun in FHEM autocreate einschalte und in den teach Mode gehe, wird aber mein Schalter nicht als neues Device angelegt. Laut Wiki sollte aber genau das passieren.
Wo liegt hier mein Denkfehler?

Internals:
   BaseID     00000000
   CFGFN     
   DEF        ESP3 /dev/CUL_EnOcean@57600
   DeviceName /dev/CUL_EnOcean@57600
   FD         32
   FUUID      6315aaf8-f33f-99a0-9c26-6facece04cbb59d5
   LastID     00000000
   MODEL      ESP3
   NAME       CUL_EnOcean
   NOTIFYDEV  global
   NR         8526
   NTFY_ORDER 45-CUL_EnOcean
   PARTIAL   
   RSSI       -82
   STATE      opened
   TYPE       TCM
   .attraggr:
   .attrminint:
   Helper:
     DBLOG:
       state:
         DbLog:
           TIME       1662364408.26995
           VALUE      CONNECTED
   READINGS:
     2022-09-05 10:48:23   baseID          BaseID: FFD87700 RemainingWriteCycles: 0A
     2022-09-05 09:54:50   dutycycleLimit  ActualSlotLeft: 006C DutyCycle: 00 LoadAfterActual: 00 SlotPeriod: 0168 Slots: 0A
     2022-09-05 10:53:40   getUsedID       
     2022-09-05 09:53:28   state           opened
   helper:
     telegramSentTimeLast 1662368101.54797
     awaitCmdResp:
Attributes:
   DbLogExclude .*
   group      CUL
   learningMode demand
   room       99_Devices
   verbose    5

attr autocreate disable 0
set CUL_EnOcean teach 60

Im Log tauchen auch fleissig die RAW-MEssages des Tasters auf wenn ich die Wippe oben/unten drücke
2022.09.05 11:01:32 3: TCM CUL_EnOcean set teach 60
2022.09.05 11:01:32 5: TCM CUL_EnOcean sent ESP: 5500100001A5D0114FFEFFFFFFFFFFFFFF0000000000C4
2022.09.05 11:01:32 5: DevIo_SimpleWrite CUL_EnOcean: 5500100001A5D0114FFEFFFFFFFFFFFFFF0000000000C4
2022.09.05 11:01:33 5: TCM CUL_EnOcean received ESP: 5500010002650000
2022.09.05 11:01:33 5: TCM CUL_EnOcean TCM_Parse 00
2022.09.05 11:01:33 5: TCM CUL_EnOcean RESPONSE: OK
2022.09.05 11:01:40 5: TCM CUL_EnOcean received ESP: 55000707017AF630FEFD06323001FFFFFFFF4A00B0
2022.09.05 11:01:40 5: TCM CUL_EnOcean received ESP: 55000707017AF600FEFD06322001FFFFFFFF4A0006
2022.09.05 11:01:41 5: TCM CUL_EnOcean received ESP: 55000707017AF610FEFD06323001FFFFFFFF4D0025
2022.09.05 11:01:42 5: TCM CUL_EnOcean received ESP: 55000707017AF600FEFD06322001FFFFFFFF4F0047
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Flachzange

  • Full Member
  • ***
  • Beiträge: 194
Antw:Probleme beim Anlernen neuer Devices
« Antwort #1 am: 05 September 2022, 11:08:20 »
mach doch mal ein

get CUL_EnOcean baseID
und schau mal, ob die baseID gesetzt wird.

Ansonsten sollte es relativ straight forward sein, so wie von Dir beschrieben.

1) set CUL_EnOcean  teach xy
2) Taser drücken

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3993
Antw:Probleme beim Anlernen neuer Devices
« Antwort #2 am: 05 September 2022, 11:10:54 »
sieht normal aus?
BaseID: FFD87700 RemainingWriteCycles: 0A
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline Flachzange

  • Full Member
  • ***
  • Beiträge: 194
Antw:Probleme beim Anlernen neuer Devices
« Antwort #3 am: 05 September 2022, 12:35:04 »
Und auch danach hat mit "set teach" autocreate kein Device für den Taster im Raum "EnOcean" erzeugt? Und der Taster nicht schon zufällig als Device angelegt gewesen?

Auffällig ist noch, dass STATE opened ist. Richtig wäre initialized. FHEM schon mal neugestartet?

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3993
Antw:Probleme beim Anlernen neuer Devices
« Antwort #4 am: 05 September 2022, 12:47:00 »
Ich habe sicherheitshalber ein FHEM update gemacht. das TCM MOdul war mit dabei. Danach Neustart und dansch war das Modul "initialized"
Jetzt wurde auch der Schalter angelegt.
Merkwürdig, gestern nach Einstecken des USB Sticks hatte ich den gesamten Server wegen eines anderen Problems neugestartet.....

Danke für die Unterstützung.
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

 

decade-submarginal