Autor Thema: ZWave-Aktoren werden bei Regel sporadisch nicht angesteuert  (Gelesen 793 mal)

Offline laufhem

  • New Member
  • *
  • Beiträge: 19
ZWave-Aktoren werden bei Regel sporadisch nicht angesteuert
« am: 18 September 2022, 20:14:51 »
Hallo,

ich nutze an einem RaspberryPi3 einen Z-Wave USB Stick (ZMEEUZB1). Außerdem habe ich mehrere Fibaro Roller Shutter 3 im Einsatz.
Ich habe eine Regel im Einsatz, die zu einer Uhrzeit die Rollläden schließen soll. Allerdings habe ich des Öfteren bemerkt, dass sporadisch manche Rollläden offenbar nicht reagieren. Die Funkverbindung möchte ich fast ausschließen (es sind z.B. auch die Rollläden in direkter Nähe zur Zentral betroffen). Auch ist keine Regelmäßigkeit zu erkennen - es tritt nur bei jedem fünften Mal oder seltener auf.
Wenn ich die Rollläden direkt vor Ort steuere oder auch händisch einzelne Rollläden über das FHEM Webinterface ansteuere, sind noch nie Probleme aufgetreten.
Ich habe das Gefühl, dass FHEM nicht ganz damit klar kommt, 10-15 Rollläden gleichzeitig zu schalten. FHEM zeigt im Webinterface allerdings trotzdem an, dass die Rollläden gefahren worden wären. Ich habe bereits versucht, kleinere Gruppen von Rollläden mit sleep getrennt zu schalten. Aber auch da tritt das Problem auf. Meine jetziger Umweg ist, dass ich die Rollläden in der Regel zweimal nacheinander ansteuere. Damit ist das Problem zu 99% behoben.

Kennt ihr das Problem? Wie kann ich das eingrenzen oder eventuell beheben?

Offline Wardancer

  • Full Member
  • ***
  • Beiträge: 118
Antw:ZWave-Aktoren werden bei Regel sporadisch nicht angesteuert
« Antwort #1 am: 19 September 2022, 10:17:42 »
Hey,

ich tippe mal darauf, dass dein ZWave-Mesh von Nachrichten geflooded wird .... schau mal im Log, ob es da irgendwelche Meldungen darüber gibt, dass evtl. Nachrichten nochmal resended werden mussten. Das sorgt dann für noch mehr Traffic und dann kommen die Befehle nicht an. Ich selber hab ein solches Verhalten auch, hab mir aber speziell mit den Rolladen und ASC über shuttersDriveDelay geholfen.... Die wirkliche Ursache auszumerzen ist mir leider nie gelungen. Es mag auch an der Menge an Aktoren liegen.
Du bist mit dem Sleep quasi damit in die richtige Richtung unterwegs um einen Workaround zu schaffen. Um die Ursache am Schopf zu packen müsstest du dich weiter in ZWave und die Messages einarbeiten....

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25833
Antw:ZWave-Aktoren werden bei Regel sporadisch nicht angesteuert
« Antwort #2 am: 19 September 2022, 11:16:24 »
Das Problem ist mir bekannt, allerdings (mangels Beschreibung des USB-Protokolls) weiss ich nicht, wie man es loesen sollte. Ich vermute als Ursache, dass der ZWave-Tranceiver im USB-Dongle nicht in der Lage ist mehrere Befehle parallel zu bearbeiten, weiss aber nicht, wann ein Befehl "beendet" ist. Meine Vermutung ist, dass beim set der ACK, beim get die Antwort den Befehl "schliesst", was scheinbar nicht immer zutrifft.

Ich empfehle die betroffenen Geraete ueber ein structure zu schalten, und da das Attribut async_delay auf 0.1 oder 0.2 zu setzen.

 

decade-submarginal