CUL > Hard- und Firmware

Maplecun mit CC2530 Zigbee

(1/3) > >>

Raspi09:
Hi, ich habe einen Maplecun über LAN laufen, das funktioniert auch super. Jetzt habe ich einen CC2530 mit einem Addon von Ranseyer auf die Platine vom Maplecun gesteckt. Ich bekomme es leider nicht hin das Zigbee2MQTT darauf zugreifen kann, wie binde ich die UART Schnittstelle ein?

In der Fhem Wiki steht:

CC2530 AddOn

Der CC2530 kann über ein AddOn direkt am MapleCUN betreiben werden. Das läuft ist seit August 2018 erprobt.

Hört sich so einfach an, ist es für mich leider nicht.

Wäre um Hilfe dankbar

Nighthawk:
Du müsstest an dem Rechner / Pi etc. wo Zigbee2Mqtt läuft, die IP und den Port unter dem der Mappelcun den CC2530 freigibt,  folgendermaßen in der configuration.yaml Datei angeben:


--- Code: ---nano /opt/zigbee2mqtt/data/configuration.yaml

--- Ende Code ---

und dort bei serial die IP:Port angeben, in etwa so:


--- Code: ---serial:
  port:192.168.XXX.XXX:YYY

--- Ende Code ---

Raspi09:
ich bekomme dann eine Fehlermeldung: Error: Error while opening serialport 'Error: Error: No such file or directory, cannot open 192.168.178.17:2324
Das sieht doch dann so aus als würde der cc2530 nicht vom Maplecul erkannt...

Raspi09:
was ich bisher gemacht habe:

den CC2530 mit dem debugger als Coordinator geflasht

die Baudrate auf dem MapleCUL eingestellt

    UART0 Baudrate einstellen: pb0@38400
    UART1 Baudrate einstellen: pb1@9600
    Baudrate im EEPROM speichern: ps
    Baudrate anzeigen: pi

Versucht über socat eine verbindung herzustellen

/usr/bin/socat pty,link=/dev/ttyTCP0,ignoreeof,user=root,group=dialout,mode=777,raw,echo=0 tcp:192.168.178.17:2324

die komandozeile geht jedoch nicht durch, sodas ich mit strg C abbrechen muss

Habe ich was übersehen?


Raspi09:
Das Projekt Zigbee CC2530 verwerfe ich dann mal.

Entweder ist die Verbindung vom CC2530 zum Maple nicht korrekt,
oder die Firmware aculfw oder die vom Zigbee funktionieren nicht.

Ich habe es an UART0 und UART1 versucht, mit Addon auf den Maplecun verbunden dann mal
mit Jumperkabel angeschlossen GND VCC P02 P03

Alle möglichen Schreibweisen in der configuration.yaml

homeassistant: false
permit_join: true
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://localhost:1883'
serial:
  port: tcp:192.168.178.17:2324 (ohne tcp: dann mal '192.168.178.17:2324')
advanced:
   rtscts: false (mit und Ohne rtscts:)

verschiedene Baudraten unter Fhem auf den Maplecul eingestellt

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln