FHEM - Hardware > Server - Linux

[gelöst] AptToDate - Fehlerhafte Anzeige?

(1/2) > >>

TomHB:
Hallo Forum,

ich habe ein seltsames Phänomen...
AptToDate zeigt im Status "alles gut"/grün - Der Server zeigt anwendbare Aktualisierungen.
Auch ein manuelles  set reposync & get DistributionInfo (die beiden einzigen Optionen derzeit) per Hand ändern nichts daran.
In der Vergangenheit, bevor ich im Linux die automatischen Aktualisierungen aktiviert habe, wurden regelmäßig die fehlenden Pakete gemeldet.



Definition AptToDate:

--- Code: ---defmod SVL01_APT AptToDate localhost
attr SVL01_APT DbLogExclude .*
attr SVL01_APT devStateIcon system.updates.available:security@red system.is.up.to.date:security@green .*in.progress:system_fhem_reboot@orange errors:message_attention@red
attr SVL01_APT event-on-change-reading .*
attr SVL01_APT room .System

setstate SVL01_APT system is up to date
setstate SVL01_APT 2022-08-09 11:29:49 .updatedList {}
setstate SVL01_APT 2022-09-08 15:39:25 .upgradeList {}
setstate SVL01_APT 2021-10-24 10:07:46 os-release_BUG_REPORT_URL https://bugs.launchpad.net/ubuntu/
setstate SVL01_APT 2021-10-24 10:07:46 os-release_HOME_URL https://www.ubuntu.com/
setstate SVL01_APT 2021-10-24 10:07:46 os-release_ID ubuntu
setstate SVL01_APT 2021-10-24 10:07:46 os-release_ID_LIKE debian
setstate SVL01_APT 2021-10-24 10:07:46 os-release_NAME Ubuntu
setstate SVL01_APT 2022-11-08 11:17:36 os-release_PRETTY_NAME Ubuntu 20.04.5 LTS
setstate SVL01_APT 2021-10-24 10:07:46 os-release_PRIVACY_POLICY_URL https://www.ubuntu.com/legal/terms-and-policies/privacy-policy
setstate SVL01_APT 2021-10-24 10:07:46 os-release_SUPPORT_URL https://help.ubuntu.com/
setstate SVL01_APT 2021-10-24 10:07:46 os-release_UBUNTU_CODENAME focal
setstate SVL01_APT 2022-11-08 11:17:36 os-release_VERSION 20.04.5 LTS (Focal Fossa)
setstate SVL01_APT 2021-10-24 10:07:46 os-release_VERSION_CODENAME focal
setstate SVL01_APT 2021-10-24 10:07:46 os-release_VERSION_ID 20.04
setstate SVL01_APT 2021-10-24 10:07:46 os-release_language de
setstate SVL01_APT 2022-11-08 11:18:20 repoSync fetched done
setstate SVL01_APT 2022-11-08 11:18:24 state system is up to date
setstate SVL01_APT 2022-08-09 11:29:49 toUpgrade successful
setstate SVL01_APT 2022-08-09 11:29:50 updatesAvailable 0

--- Ende Code ---


Anzeige auf dem Server:

--- Code: ---Willkommen zu Ubuntu 20.04.5 LTS (GNU/Linux 5.4.0-131-generic x86_64)

  System information as of Di 8. Nov 11:17:51 CET 2022

  System load:  0.08               Processes:               245
  Usage of /:   80.1% of 14.17GB   Users logged in:         0
  Memory usage: 37%                IPv4 address for ens160: xxx
  Swap usage:   5%


2 updates can be applied immediately.
1 of these updates is a standard security update.
To see these additional updates run: apt list --upgradable


--- Ende Code ---


Hat jemand eine Erklärung für das Verhalten?

Gruß
Tom

CoolTux:
Was sagt denn ein

apt list --upgradeable

TomHB:
Dat...


--- Code: ---$ apt list --upgradeable
Auflistung... Fertig
libpixman-1-0/focal-updates,focal-security 0.38.4-0ubuntu2.1 amd64 [aktualisierbar von: 0.38.4-0ubuntu1]
libtiff5/focal-updates,focal-security 4.1.0+git191117-2ubuntu0.20.04.6 amd64 [aktualisierbar von: 4.1.0+git191117-2ubuntu0.20.04.5]
nodejs/unbekannt 14.21.1-deb-1nodesource1 amd64 [aktualisierbar von: 14.20.1-deb-1nodesource1]
php7.4-cgi/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-cli/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-common/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-intl/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-json/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-opcache/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-readline/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-sqlite3/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]
php7.4-xml/focal-updates,focal-security 7.4.3-4ubuntu2.15 amd64 [aktualisierbar von: 7.4.3-4ubuntu2.13]

--- Ende Code ---

CoolTux:
ok, und was sagt


--- Code: ---apt-get -s -q -V upgrade
--- Ende Code ---

TomHB:
Das...


--- Code: ---$ apt-get -s -q -V upgrade
HINWEIS: Dies ist nur eine Simulation!
         apt-get benötigt root-Privilegien für die reale Ausführung.
         Behalten Sie ebenfalls in Hinterkopf, dass die Sperren deaktiviert
         sind, verlassen Sie sich also bezüglich des reellen aktuellen
         Status der Sperre nicht darauf!
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Paketaktualisierung (Upgrade) wird berechnet...
Die folgenden Pakete werden aktualisiert (Upgrade):
   nodejs (14.20.1-deb-1nodesource1 => 14.21.1-deb-1nodesource1)
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Inst nodejs [14.20.1-deb-1nodesource1] (14.21.1-deb-1nodesource1 Node Source:deb.nodesource.com [amd64])
Conf nodejs (14.21.1-deb-1nodesource1 Node Source:deb.nodesource.com [amd64])

--- Ende Code ---


Inzwischen hat sich die Anmeldebegrüßung auch auf das geändert (AutoUpdate wahrscheinlich):

--- Code: ---1 update can be applied immediately.
To see these additional updates run: apt list --upgradable

--- Ende Code ---

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln