FHEM - Hausautomations-Systeme > Homematic

HomeMatic USB Konfigurations-Adapter (HM-CFG-USB) in Fhem nutzen

<< < (2/219) > >>

betateilchen:
Ich habe das Ganze jetzt mal versucht, auf dem Raspberry zu installieren. Kompilieren funktioniert einwandfrei, beim Starten passiert aber folgendes:


--- Code: ---
/opt/hmcfgusb # ./hmland -D -p 1234
Client 127.0.0.1 connected!
Can't find/open hmcfgusb!
Can't initialize HM-CFG-USB!
Connection to 127.0.0.1 closed!

--- Ende Code ---




* ein lsusb liefert keinen Hinweis auf den Stick.
* wenn ich den Stick einstecke, gibt es im syslog keinen Hinweis auf irgendein neues USB Gerät

Was kann denn da schieflaufen?

mgernoth:
Hallo,


--- Zitat von: betateilchen schrieb am Mi, 03 Juli 2013 13:54 ---Ich habe das Ganze jetzt mal versucht, auf dem Raspberry zu installieren. Kompilieren funktioniert einwandfrei, beim Starten passiert aber folgendes:


--- Code: ---
...
Can't find/open hmcfgusb!
...

--- Ende Code ---


--- Ende Zitat ---


Das USB-Gerät wird nicht gefunden, passt auch zu Deinen folgenden Aussagen.


--- Zitat ---

* ein lsusb liefert keinen Hinweis auf den Stick.
* wenn ich den Stick einstecke, gibt es im syslog keinen Hinweis auf irgendein neues USB Gerät

Was kann denn da schieflaufen?

--- Ende Zitat ---


Hmm, also eigentlich sollte im Log auf jeden Fall etwas erscheinen und auch lsusb das Gerät zeigen. Wenn der Stick nicht in lsusb auftaucht, kann der hmland auch nicht funktionieren...

Welchen Kernel benutzt Du? Der USB-Stack des RPi ist ziemlich kaputt, mit aktuellen Kerneln aus rpi-update ist es aber erträglich. Damit lief zumindest bei mir der HM-CFG-USB an einem RPi, schön war es aber nicht, da der USB-Stack manche Transfers etwas verzögert. Könnte aber evtl. demnächst behoben werden.

Gruß
  Michael

betateilchen:
Hallo Michael,

danke für Deine schnelle Reaktion. Der Raspberry ist auf dem aktuellsten Stand,


--- Code: ---Linux rasp-fhem 3.6.11+ #474 PREEMPT Thu Jun 13 17:14:42 BST 2013 armv6l
--- Ende Code ---


Das mit dem USB Stack mag schon stimmen, aber bisher habe ich sämtliche USB Geräte trotzdem zum Laufen gebracht, sogar SDR via DVB-T Stick. Und zumindest im Log sollte ja irgendwas passieren, wenn man den Stick anschließt.

Ich hab mal eine "doofe" Frage: Funktioniert der Stick eigentlich out-of-the-box oder muss der irgendwie (z.B. unter Windows) konfiguriert werden? Ich habe den nämlich einfach ausgepackt und angesteckt. Wenn ich den Stick an mein MacBook anschließe, wird er korrekt erkannt.

Viele Grüße
Udo

edit:

ist das der Stick?


--- Code: ---Bus 001 Device 005: ID 1b1f:c00f
--- Ende Code ---


auf einem zweiten Raspberry wird mir diese Info bei einem lsusb ausgegeben, auf dem Raspberry mit FHEM allerdings nicht.

eedit:

auf dem zweiten Raspi die Source per git ausgecheckt und kompiliert - der Stick läuft problemlos.

Also irgendwas muss auf dem ersten Raspi faul sein - ich geh mal auf die Suche.

betateilchen:
Problem gelöst - es lag nicht an Deiner Software und auch nicht an meinem Stick oder Raspberry, sondern einfach an meiner eigenen Dussligkeit: ich hatte das Datenkabel zwischen Raspberry und dem neu eingesetzten USB Hub vergessen (http://www.smiliesuche.de/smileys/kopf-gegen-wand/kopf-gegen-wand-smilies-0005.gif)

mgernoth:
Hi,

sowas passiert jedem.

Freut mich aber zu hören, dass es jetzt bei Dir funktioniert. :-)

Gruß
  Michael

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln