FHEM - Hausautomations-Systeme > ZWave

Vision USB Stick VIS_ZU1401

(1/2) > >>

TomNo:
Hallo,
hat schon jemand diesen Stick Vision USB Stick VIS_ZU1401 (z.B. hier:http://www.zwave4u.com/Z-Wave-Controller/PC-Adapter/Vision-USB-Stick-VIS_ZU1401::12358.html ausprobiert? Ist der unter Linux einsetzbar? Er kostet ja erheblich weniger als der AeonLabs, der wohl schon erfolgreich von einigen hier eingesetzt wird.
Ich würde gern einen Raspberry an einer funktechnisch günstigen Stelle als Z-Wave Zentrale einsetzen, der dann von FHEM die zu sendenden Befehle erhält (und die Ergebnisse zurückschickt).
VG TomNo

aron:
Hallo TomNo,

hast du dir den Stick bestellt und damit erfahrungen sammeln können? Ich stehe gerade vor der selben Entscheidung.

LG
aron

krikan:
Der Vision USB Stick VIS_ZU1401 funktioniert bei mir auf der Fritzbox 7390 ohne Probleme mit einer Baudrate von 115200.

Jetzt wollte ich den Stick auf den Raspberry Pi mit aktuellster Raspian-Umgebung umziehen.
Bei einer simplen Definition entsprechend der Fritzbox mit:

--- Code: ---define zwdongle ZWDongle /dev/ttyAMA0@115200
--- Ende Code ---
zeigt Fhem mir immer den Stick als "disconnected"

Analog zum Razberry (basiert nmM auf gleichem Chip) auf Raspbian habe ich die hier http://forum.fhem.de/index.php/topic,11716.msg190402.html#msg190402 beschriebenen Änderungen vorgenommen:


--- Zitat ---in /boot/cmdline.txt das folgende entfernt "console=ttyAMA0,115200 kgdboc=ttyAMA0,115200"
restlicher Dateiinhalt unverändert

in /etc/inittab das folgende entfernen (oder auskommentieren) "T0:23: respawn: /sbin/getty -L ttyAMA0 115200 vt100"
restlicher Dateiinhalt unverändert

Raspberry reboot

im FHEM cfg.file
define ZWAVE1 ZWDongle /dev/ttyAMA0@115200
--- Ende Zitat ---

"kgdboc=ttyAMA0,115200" stand bei mir nicht in der cmdine.txt und konnte dementsprechend nicht gelöscht werden.

Jetzt zeigt mir Fhem zwar den Stick als "Initialized" an. Trotzdem enden alle Abfragen des Stick in einem Timeout:

--- Code: ---Timeout reading answer for get get zwdongle homeId
--- Ende Code ---

Hat jemand Ideen, woran dies liegen könnte bzw. wie ich das Problem finde?

Achtung, ich bin Windows-User :-[

Danke, Christian

rudolfkoenig:
ttyAMA0 ist mWn die serielle Schnittstelle, und hat nix mit USB zu tun.

krikan:
Danke Rudi, für den notwendigen Schubs. Wenn man (ICH) die richtige Schnittstelle auswählt :-[, geht es ohne Probleme sofort:
also beim Rasperry Pi

--- Code: ---define zwdongle ZWDongle /dev/ttyACM0@115200
--- Ende Code ---

Autocreate funktioniert für den Stick nicht. Wenn ich etwas liefern soll, damit das eingebaut werden kann, bitte (mit für dumme Windows-User-verständlicher) Anleitung melden.

Gruß, Christian

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln