Autor Thema: weather sensors not found  (Gelesen 3153 mal)

Offline HarryT

  • Full Member
  • ***
  • Beiträge: 150
weather sensors not found
« am: 30 Juli 2013, 23:18:14 »
Hi

I have 4 new weather sensors. 2 are automatically detected and 2 not.
RFXMNGR sees all 4.

In RFXMNGR I see:
------------------------------------------------
0A520703300E00DD3F0169
Packettype    = TEMP_HUM
subtype       = TH7 - Cresta, TFA TS34C
                channel 1
Sequence nbr  = 3
ID            = 12302
Temperature   = 22,1 °C
Humidity      = 63
Status        = Comfortable
Signal level  = 6
Battery       = OK
------------------------------------------------
0A520703570E00E23F0169
Packettype    = TEMP_HUM
subtype       = TH7 - Cresta, TFA TS34C
                channel 2
Sequence nbr  = 3
ID            = 22286
Temperature   = 22,6 °C
Humidity      = 63
Status        = Comfortable
Signal level  = 6
Battery       = OK
------------------------------------------------
0A520703720E00E33B0179
Packettype    = TEMP_HUM
subtype       = TH7 - Cresta, TFA TS34C
                channel 3
Sequence nbr  = 3
ID            = 29198
Temperature   = 22,7 °C
Humidity      = 59
Status        = Comfortable
Signal level  = 7
Battery       = OK
------------------------------------------------
08500505460000BF69
Packettype    = TEMP
subtype       = TEMP5 - LaCrosse TX3, TX4, TX17
Sequence nbr  = 5
ID            = 17920
Temperature   = 19,1 °C
Signal level  = 6
Battery       = OK
------------------------------------------------
0851010546004E0369
Packettype    = HUM
subtype       = HUM1 - LaCrosse TX3
Sequence nbr  = 5
ID            = 17920
Humidity      = 78
Status        = Wet
Signal level  = 6
Battery       = OK
------------------------------------------------

But in the xmllist only:

        <TRX_WEATHER_LIST>
                <TRX_WEATHER name="TFATS34C_Zolder" state="T: 22.4 H: 65 BAT: ok" sets="" attrs="room group comment alias eventMap userReadings IODev ignore:1,0 do_not_notify:1,0 loglevel:0,1,2,3,4,5,6 event-on-change-reading event-on-update-reading event-min-interval stateFormat devStateIcon devStateStyle icon invertState onOffDevice sortby toggleDevice webCmd">
                        <INT key="CODE" value="TFATS34C_14"/>
                        <INT key="DEF" value="TFATS34C_14"/>
                        <INT key="LASTInputDev" value="TRX_0"/>
                        <INT key="MSGCNT" value="20"/>
                        <INT key="NAME" value="TFATS34C_Zolder"/>
                        <INT key="NR" value="247"/>
                        <INT key="STATE" value="T: 22.4 H: 65 BAT: ok"/>
                        <INT key="TRX_0_MSGCNT" value="20"/>
                        <INT key="TRX_0_RAWMSG" value="0a520701570e00e0410179"/>
                        <INT key="TRX_0_TIME" value="2013-07-30 22:05:10"/>
                        <INT key="TYPE" value="TRX_WEATHER"/>
                        <INT key="IODev" value="TRX_0"/>
                        <ATTR key="room" value="Zolder"/>
                        <STATE key="battery" value="ok" measured="2013-07-30 22:05:10"/>
                        <STATE key="humidity" value="65" measured="2013-07-30 22:05:10"/>
                        <STATE key="state" value="T: 22.4 H: 65 BAT: ok" measured="2013-07-30 22:05:10"/>
                        <STATE key="temperature" value="22.4" measured="2013-07-30 22:05:10"/>
                </TRX_WEATHER>
                <TRX_WEATHER name="TX3TH" state="H: 81 BAT: ok" sets="" attrs="room group comment alias eventMap userReadings IODev ignore:1,0 do_not_notify:1,0 loglevel:0,1,2,3,4,5,6 event-on-change-reading event-on-update-reading event-min-interval stateFormat devStateIcon devStateStyle icon invertState onOffDevice sortby toggleDevice webCmd">
                        <INT key="CODE" value="TX3"/>
                        <INT key="DEF" value="TX3"/>
                        <INT key="LASTInputDev" value="TRX_0"/>
                        <INT key="MSGCNT" value="14"/>
                        <INT key="NAME" value="TX3TH"/>
                        <INT key="NR" value="243"/>
                        <INT key="STATE" value="H: 81 BAT: ok"/>
                        <INT key="TRX_0_MSGCNT" value="14"/>
                        <INT key="TRX_0_RAWMSG" value="085101014600510379"/>
                        <INT key="TRX_0_TIME" value="2013-07-30 22:04:23"/>
                        <INT key="TYPE" value="TRX_WEATHER"/>
                        <INT key="IODev" value="TRX_0"/>
                        <ATTR key="room" value="Buiten"/>
                        <STATE key="battery" value="ok" measured="2013-07-30 22:04:23"/>
                        <STATE key="humidity" value="81" measured="2013-07-30 22:04:23"/>
                        <STATE key="state" value="H: 81 BAT: ok" measured="2013-07-30 22:04:23"/>
                        <STATE key="temperature" value="18.8" measured="2013-07-30 22:04:22"/>
                </TRX_WEATHER>
        </TRX_WEATHER_LIST>

I updated to the latest FHEM software yesterday.  
Any ideas about this?

{HT}
FHEM 5.9 auf Raspberry Pi1  (700Mhz)
RFXTRX433XL und ZWave
Raspberry Pi3 f(1,2 Ghz) or testing

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Aw: weather sensors not found
« Antwort #1 am: 07 August 2013, 07:28:37 »
Did not see your message til now. Sorry.

To make research easier for me (XML is not really human readable, at least in my case...): Which sensors shown in RFXmngr are not detected?

-- Willi
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline HarryT

  • Full Member
  • ***
  • Beiträge: 150
Aw: weather sensors not found
« Antwort #2 am: 07 August 2013, 11:28:36 »
Zitat von: Willi schrieb am Mi, 07 August 2013 07:28
Did not see your message til now. Sorry.



No problem, the weather is much to hot for looking at sensors :-)

Zitat


To make research easier for me (XML is not really human readable, at least in my case...): Which sensors shown in RFXmngr are not detected?

-- Willi


In RFXMNGR:
------------------------------------------------
0A520703300E00DD3F0169
Packettype = TEMP_HUM
subtype = TH7 - Cresta, TFA TS34C
channel 1
Sequence nbr = 3
ID = 12302
Temperature = 22,1 °C
Humidity = 63
Status = Comfortable
Signal level = 6
Battery = OK
------------------------------------------------
0A520703570E00E23F0169
Packettype = TEMP_HUM
subtype = TH7 - Cresta, TFA TS34C
channel 2
Sequence nbr = 3
ID = 22286
Temperature = 22,6 °C
Humidity = 63
Status = Comfortable
Signal level = 6
Battery = OK
--------------------------------------------

are not detected by FHEM. The problem might be that 1 sensor is identical as the detected sensor and the other is almost identical (and is detected by rfxmgr as identical). The difference is the channel used so I would expect to see them in FHEM too.  
In the mean time 1 of the 2 missing sensors is detected by autodetect, but I have no readings from this sensors.

{HT}
FHEM 5.9 auf Raspberry Pi1  (700Mhz)
RFXTRX433XL und ZWave
Raspberry Pi3 f(1,2 Ghz) or testing

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Aw: weather sensors not found
« Antwort #3 am: 09 August 2013, 20:01:36 »
The channel ID was not calculated correct for TS34C.

I had already developed a fix. See: Link
It was already tested and used by user Icebear.
 
For whatever reasons, my fixes never found the way to SVN. Very strange. Now they are there (in SVN).

To test is, use the new 46_TRX_WEATHER.pm from SVN:
http://sourceforge.net/p/fhem/code/HEAD/tree/trunk/fhem/FHEM/46_TRX_WEATHER.pm?format=raw

It will be also there tomorrow via update.
As the ID are now set correctly like on RFXmngr, the system may see new devices. So you may have to copy your old logs to the new ones.

Regards

Willi
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline HarryT

  • Full Member
  • ***
  • Beiträge: 150
Aw: weather sensors not found
« Antwort #4 am: 09 August 2013, 22:48:26 »
Zitat von: Willi schrieb am Fr, 09 August 2013 20:01
The channel ID was not calculated correct for TS34C.

I had already developed a fix. See: Link
It was already tested and used by user Icebear.



That was my impression too so I updated to the current fhem version.
Zitat


 
For whatever reasons, my fixes never found the way to SVN. Very strange. Now they are there (in SVN).

To test is, use the new 46_TRX_WEATHER.pm from SVN:
http://sourceforge.net/p/fhem/code/HEAD/tree/trunk/fhem/FHEM/46_TRX_WEATHER.pm?format=raw



It works fine now.

Zitat


Regards

Willi


Thanks for your work

{HT}
FHEM 5.9 auf Raspberry Pi1  (700Mhz)
RFXTRX433XL und ZWave
Raspberry Pi3 f(1,2 Ghz) or testing

Offline HarryT

  • Full Member
  • ***
  • Beiträge: 150
Aw: weather sensors not found
« Antwort #5 am: 13 August 2013, 22:56:27 »
Zitat von: Willi schrieb am Fr, 09 August 2013 20:01

To test is, use the new 46_TRX_WEATHER.pm from SVN:
[...]

It will be also there tomorrow via update.

Regards

Willi


Hi Willi

The current version writes 2 entries in the log file at every reading. (once per minute) I guess this was not your intention.

{HT}
FHEM 5.9 auf Raspberry Pi1  (700Mhz)
RFXTRX433XL und ZWave
Raspberry Pi3 f(1,2 Ghz) or testing

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Aw: weather sensors not found
« Antwort #6 am: 13 August 2013, 23:17:44 »
Please show these entries.
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline HarryT

  • Full Member
  • ***
  • Beiträge: 150
Aw: weather sensors not found
« Antwort #7 am: 13 August 2013, 23:29:13 »
Zitat von: Willi schrieb am Di, 13 August 2013 23:17
Please show these entries.


For example:
2013.08.13 23:25:22 1: TRX_WEATHER: TFA
2013.08.13 23:25:22 1: TRX_WEATHER: TFA 1
2013.08.13 23:25:25 1: TRX_WEATHER: TFA
2013.08.13 23:25:25 1: TRX_WEATHER: TFA 2
2013.08.13 23:26:01 1: TRX_WEATHER: TFA
2013.08.13 23:26:01 1: TRX_WEATHER: TFA 3
2013.08.13 23:26:05 1: TRX_WEATHER: TFA
2013.08.13 23:26:05 1: TRX_WEATHER: TFA 1
2013.08.13 23:26:10 1: TRX_WEATHER: TFA
2013.08.13 23:26:10 1: TRX_WEATHER: TFA 2
2013.08.13 23:26:48 1: TRX_WEATHER: TFA
2013.08.13 23:26:48 1: TRX_WEATHER: TFA 1
2013.08.13 23:26:49 1: TRX_WEATHER: TFA
2013.08.13 23:26:49 1: TRX_WEATHER: TFA 3

{HT}
FHEM 5.9 auf Raspberry Pi1  (700Mhz)
RFXTRX433XL und ZWave
Raspberry Pi3 f(1,2 Ghz) or testing

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Aw: weather sensors not found
« Antwort #8 am: 14 August 2013, 07:24:33 »
I have now removed this debug logging (fhem.log)

Get the newest 46_TRX_WEATHER.pm from SVN or update FHEM tomorrow (updates from SVN are just done once a day...).

-- Willi
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

 

decade-submarginal