Autor Thema: neues modul mailcheck  (Gelesen 140127 mal)

Offline dennis_n

  • Sr. Member
  • ****
  • Beiträge: 561
Antw:neues modul mailcheck
« Antwort #495 am: 26 November 2018, 09:44:07 »
Moin,

ich nutze seit einiger zeit das mailcheck Modul mit dem patch hier aus dem Thread.
Allerdings ist mir aufgefallen, dass nach einiger Zeit vorhandene Mails in der INBOX nicht mehr in die Readings geschrieben werden.

Im Log ist nichts auffälliges zu finden. Das Modul connected und zeigt mir auch an, dass eine Mail da ist. Aber die Readings werden nciht aktualisiert.

Read: * OK Still here
Sending: DONE
Sent 6 bytes
Read: 31 OK Idle completed (0.001 + 59.991 + 59.990 secs).
Sending: 33 SELECT INBOX
Sent 17 bytes
Read: * OK [CLOSED] Previous mailbox closed.
  * FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
  * OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft \*)] Flags permitted.
  * 1 EXISTS
  * 0 RECENT
  * OK [UNSEEN 1] First unseen.
  * OK [UIDVALIDITY 1518623563] UIDs valid
  * OK [UIDNEXT 320] Predicted next UID
  * OK [HIGHESTMODSEQ 689] Highest
  33 OK [READ-WRITE] Select completed (0.000 + 0.000 secs).
Sending: 34 IDLE
Sent 9 bytes
Read: + idling

Woran kann das liegen?

Gruss
Dennis

Offline conmarti

  • New Member
  • *
  • Beiträge: 9
Antw:neues modul mailcheck
« Antwort #496 am: 08 Dezember 2018, 15:05:42 »
Hallo,

bei mir tritt von Zeit zu Zeit auch dieses Problem auf. Dein Logausschnitt zeigt den Abschnitt wo mailcheck_Poll aufgerufen wird. Das Reading selbst wird aber in mailcheck_Read gesetzt. Dieser Code wird aber nur dann durchlaufen, wenn der Mailserver den Eingang einer Mail auch korrekt "signalisiert". Jedesmal wenn das von dir beschriebene Problem bei mir auftrat, fehlte die "Signalisierung" vom Server. Von daher vermute ich das Problem eher beim Mailserver als bei dem Modul.

 

decade-submarginal