Autor Thema: IT Empfang mit CUL  (Gelesen 150494 mal)

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
IT Empfang mit CUL
« am: 18 August 2013, 20:47:11 »
Hallo,

ich integriere gerade Code zum Empfang u.a. von IT Signalen in die CUL Firmware: http://forum.fhem.de/index.php?t=msg&goto=90835&rid=2194#msg_90835.
Die von der CUL dekodierten Meldungen sehen dann so aus:
i541514
Jeweils 2Bit entsprechen einem Tristate:
00: 0
11: 1
01: F
Bei mir funktioniert es soweit schon mal ganz gut...

Ich könnte aber ein wenig Unterstützung beim Testen und bei der Integration in FHEM gebrauchen.

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
Aw: IT Empfang mit CUL
« Antwort #1 am: 19 August 2013, 23:56:19 »
Hier kommt mein erster Versuch den CUL-IT Empfang auch in FHEM zu integrieren:

Ich sollte erwähnen, dass ich an 00_CUL.pm noch einige Änderungen vorgenommen habe:
- basierend auf Revision 3659: siehe Anhang (inkl. Revolt Anpassung).
- Zeile 50: ":IT" zu "$clientsSlowRF" hinzugefügt.
- Zeile 859: RSSI Verarbeitung "if($dmsg =~ m/^[AFTKEHRStZi]([A-F0-9][A-F0-9])+$/) { # RSSI"
- Zeile 925:
"} elsif($fn eq "i" && $len >= 7) {              # IT
     $dmsg = lc($dmsg);"

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #2 am: 21 August 2013, 21:30:00 »
Hi,

wie kann ich unterstützen ?
Ist das noch aktuell bei Dir ?

Ich habe eine CUL-868 (V3) und eine CUL-433 (V3) an einem Raspberry pi hängen diversen FHT, CUL_WS und Intertechno Steckdosen/Dimmer.

Alles funktioniert soweit (an dieser Stelle ein kurzes Danke an alle Entwickler :-)) und ich würde jetzt gerne noch das "Schalten" der FB erfassen können.
Das wäre nicht nur für die Steckdosen und die Visualisierung interessant, sondern auch zum Starten von beliebigen Aktionen :-)

Wenn ich Dich richtig verstanden habe, ist das genau der Punkt an dem Du arbeitest.

Was soll/kann ich testen ?  Ist das schon eingecheckt ?  In der CUL-Doku ist bis jetzt nur vom Senden die Rede...

Brauche ich nur die zwei Perl-Scripte oder hast Du noch eine spezielle CUL-Firmware ?

Grüße,
  Thomas

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
Aw: IT Empfang mit CUL
« Antwort #3 am: 21 August 2013, 21:57:42 »
Hallo,

bei mir spielt alles schon ganz wunderbar zusammen (433er-CUL)..

Zum Empfangen der Signale brauchst du die angepasste CUL-Firmware: Eingechekt sind die Änderungen, die müssen allerdings noch aktiviert und übersetzt werden. (board.h: #define HAS_IT). Ich kann auch gerne ein .hex posten..

Zum Verarbeiten der Signale in FHEM brauchst du die beiden Anpassung von 00_CUL.pm und 10_IT.pm

Gruß
Martin

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #4 am: 21 August 2013, 22:14:43 »
Super, ich check es mal aus und versuche mich daran :-)

Danke :-)

Grüße,
  Thomas

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #5 am: 22 August 2013, 00:37:40 »
(Teil)Erfolg :-)

1. Beide CULs neu geflasht mit dem Define HAS_IT
2. FHEM-Update und die zwei Module überschrieben

--> Ich bekomme Events für die definierten Codes. Allerdings scheint on/off vertauscht zu sein:

2013-08-22 00:26:48 IT Sofaleuchte off
2013-08-22 00:26:48 IT Sofaleuchte RSSI: -62.5
2013-08-22 00:26:48 IT Sofaleuchte RAWMSG: i01455117

kommt wenn ich auf der FB ON drücke und die Lampe angeht...
Die definition lautet:

define Sofaleuchte IT 000FF0FFFF 0F F0 FF 00
attr Sofaleuchte IODev CUL_433
attr Sofaleuchte model itdimmer

Das gleiche passiert bei einem itswitch Device.

Ist das noch ein Bug oder ein Fehler in meiner Konfig ?

Noch was: Die Steckdosen scheinen empfindlicher/schneller zu sein. Wenn ich nur kurz auf der FB drücke reagiert die Steckdose aber nicht der CUL... Kann man da noch irgendwo drehen ?

Alles andere scheint bei mir noch zu gehen. FHT und CUL_WS empfangen ihre Geräte noch :-)

Grüße,
  Thomas

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
Aw: IT Empfang mit CUL
« Antwort #6 am: 22 August 2013, 19:35:20 »
Hmmm, seltsam.
Der CUL sendet i014551, d.h. ...0F also laut Definition von "Sofaleuchte" "on". Kannst du mal schauen was im Log (nicht event-Log) steht; wie sind die Attribute XMIToff und XMITon?

Die "Empfindlichkeit" hängt wahrscheinlich mit dem Empfangsparametern des CUL zusammen - da gibts viel zu verstellen, aber auch viel um den Empfang anderer Geräte kaputt zu machen.

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
Aw: IT Empfang mit CUL
« Antwort #7 am: 22 August 2013, 21:53:18 »
Bug gefunden!

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #8 am: 23 August 2013, 00:44:24 »
:-)
Ich sage Bescheid ob es bei mir geht sobald ich mein System nach einem Umbau wieder am laufen habe :-)
Irgendwie Empfange ich grade nichts mehr, es liegt aber nicht am neuen Modul :-)

Grüße,
   Thomas

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #9 am: 26 August 2013, 21:49:21 »
OK, der Fix geht auch bei mir, ich hatte noch ein Konfig Problem :-)

Was ungeschickt ist sind die langen Reaktionszeiten bis der Code ankommt (oder zumindest FHEM reagiert).
Es dauert bei mir bis zu 3 Sekunden "Dauerdrücken" bis im Log die ON/OFF Meldung kommt.
Bei einer Lampe ist man in dieser Zeit schon wieder vom Knopf. Der Empfänger ist 3 Meter Sichtlinie entfernt.

Was sind Deine Erkennungszeiten ?
Gibt es noch was zum drehen ?

Grüße,
  Thomas

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
Aw: IT Empfang mit CUL
« Antwort #10 am: 26 August 2013, 23:46:09 »
Hast du schon mit freq, sens, rAmpl, bWidth herum gespielt?
Was meldet der CUL, wenn du ihm ein "set raw X27" sendest und ein paar Tasten drückst? (mit "set raw X21" gehts zurück).

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #11 am: 27 August 2013, 00:31:31 »
Da gibt es sofort eine Reaktion, selbst bei ganz kurzen Tastendrücken.

Log über alle 4 Tasten (jeweils on/off):

2013-08-27 00:24:08 CUL CUL_433 UNKNOWNCODE p 7  288  960  960  320  1  3 0 E5 01055F
2013-08-27 00:24:09 CUL CUL_433 UNKNOWNCODE p 3  240 1008  880  384  7  2 0 E7 055F
2013-08-27 00:24:10 CUL CUL_433 UNKNOWNCODE p 3  224 1024  896  368  7  2 0 E5 155F
2013-08-27 00:24:10 CUL CUL_433 UNKNOWNCODE p 3  208 1040  896  400  7  2 0 E6 0551
2013-08-27 00:24:11 CUL CUL_433 UNKNOWNCODE p 3  256  976  896  368  7  2 0 E7 155F
2013-08-27 00:24:12 CUL CUL_433 UNKNOWNCODE p 3  256 1008  928  336  7  2 0 EC 155F
2013-08-27 00:24:13 CUL CUL_433 UNKNOWNCODE p 3  256  976  912  384  7  2 0 EA 0554
2013-08-27 00:24:13 CUL CUL_433 UNKNOWNCODE p 3  288  960  928  320  6  2 0 EC 055F
2013-08-27 00:24:13 CUL CUL_433 UNKNOWNCODE p 7  256  976  928  352  1  3 0 EC 01155F
2013-08-27 00:24:13 CUL CUL_433 UNKNOWNCODE p 3  272  992  928  336  6  2 0 EB 155F
2013-08-27 00:24:15 CUL CUL_433 UNKNOWNCODE p 3  240  992  928  336  7  2 0 EC 155F
2013-08-27 00:24:15 CUL CUL_433 UNKNOWNCODE p 7  256 1008  896  384  1  3 0 EB 01155F
2013-08-27 00:24:16 CUL CUL_433 UNKNOWNCODE p 3  240 1008  960  352  7  2 0 F7 1154
2013-08-27 00:24:16 CUL CUL_433 UNKNOWNCODE p 3  256 1008  912  368  6  2 0 F7 1154
2013-08-27 00:24:17 CUL CUL_433 UNKNOWNCODE p 3  256  992  912  368  7  2 0 F9 1451
2013-08-27 00:24:17 CUL CUL_433 UNKNOWNCODE p 3  256  992  880  400  7  2 0 F8 155F
2013-08-27 00:24:18 CUL CUL_433 UNKNOWNCODE p 3  288  976  944  336  7  2 0 FA 1454
2013-08-27 00:24:18 CUL CUL_433 UNKNOWNCODE p 3  256  992  928  336  5  2 0 FB 155F
2013-08-27 00:24:18 CUL CUL_433 UNKNOWNCODE p 7  256  976  928  320  1  3 0 FA 01155F
2013-08-27 00:24:19 CUL CUL_433 UNKNOWNCODE p 3  240 1024  912  352  7  2 0 F3 1511
2013-08-27 00:24:19 CUL CUL_433 UNKNOWNCODE p 3  256 1008  896  368  5  2 0 F2 155F
2013-08-27 00:24:19 CUL CUL_433 UNKNOWNCODE p 3  224 1024  944  352  6  2 0 F1 1514
2013-08-27 00:24:19 CUL CUL_433 UNKNOWNCODE p 3  240 1008  864  400  7  2 0 F2 155F
2013-08-27 00:24:20 CUL CUL_433 UNKNOWNCODE p 7  192 1072  864  400  1  3 0 F1 01155F


Änderungen der freq, sens, rAmpl, bWidth Parameter habe ich noch nicht versucht, Aufgrund des obigen Logs und der Nähe zwischen Empfänger und Sender scheint mir das Unwahrscheinlich. Kann ich aber noch testen....

Offline mehf

  • Jr. Member
  • **
  • Beiträge: 78
Aw: IT Empfang mit CUL
« Antwort #12 am: 27 August 2013, 21:20:43 »
"p 7.." heißt, dass er den IT-sync Pulse erkannt hat. In den anderen Zeilen scheint er den sync pulse nicht korrekt zu erkennen (die einzelnen Bits hingegen schon). Das kann entweder mit den Empfang-Parametern zusammen hängen, oder ich muss doch die sync Erkennung etwas robuster gestalten.. Das kann man aber in den Logs schlecht erkennen - ich werde da nochmal ein paar Meßreihen starten.

ttww

  • Gast
Aw: IT Empfang mit CUL
« Antwort #13 am: 27 August 2013, 21:46:35 »
Hast Du einen Vorschlag in welcher Richtung und an welchen Parametern ich drehen soll ?

/Nachdenk/:

freq:
Stimmt wahrscheinlich, da sofortige Reaktion im RAW Modus.

sens:
Evtl. zu sensitiv da der Empfänger relativ nah... Sättigung ?

rAmpl:
Mmmm...

bWidth:
Wahrscheinlich gilt her das gleiche wie bei der Frequenz.

Aktuelle läuft alles noch auf den Defaults:
 CUL_433 ccconf => freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB

Versuche mich mal an der Sensitivität :-) falls Du keine spezielle Vermutung hast :-)


Offline rpdeveloper

  • New Member
  • *
  • Beiträge: 9
Aw: IT Empfang mit CUL
« Antwort #14 am: 30 August 2013, 01:07:57 »
Hallo, vielleicht hilft ein Hinweis weiter.
Bei Surfen bin ich auf folgende Arbeit gestoßen.
Implementierung eines Netzwerk-Gateways für kabellose Heim-Automatisierung


Hier wird technisch auf die Protokolle (auch von Intertechno) eingegangen.

 

decade-submarginal