Autor Thema: Die Statistiken funktionieren nicht mehr  (Gelesen 2249 mal)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 14664
  • s/fhem\.cfg/configDB/g
Die Statistiken funktionieren nicht mehr
« am: 24 August 2013, 11:33:58 »
Seit ein paar Tagen lande ich beim Aufruf der Statistiken immer nur noch in einem Server Fehler 500

Das Ganze war ein schleichender Prozess. Manchmal hat der Aufruf beim zweiten oder dritten Reload funktioniert, aber nun kommen die Statistiken gar nicht mehr.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 07.09.2018 - 18:30 Uhr

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18560
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #1 am: 24 August 2013, 11:47:53 »
Ja, das ist grausam.

statistics.cgi ist in contrib/lib/statistics eingecheckt, und liest/schreibt eine sqlite Datenbank. Sie stammt von Martin (Fischer), ich habe es aber schon mal etwas umgebaut (gleiche Symptome), danach lief es eine Weile weiter.

Das Problem ist, dass koeniglich.de z.Zt. bei 1und1 gehostet wird, und die ruecken die Fehlermeldungen aus dem apache error.log nicht raus (hab schon gebettelt). Wenn ich statistics.cgi direkt (d.h. eingeloggt per ssh) aufrufe, dann funktioniert es, ueber Apache nicht. Vmtl. setzt Apache irgendeine Grenze (Speicher?), was natuerlich doof ist, weil wir zunehmend mehr Eintraege haben.

Irgendwelche Ideen wie man das fixen koennte?

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 14664
  • s/fhem\.cfg/configDB/g
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #2 am: 24 August 2013, 12:33:29 »
Hast Du die Möglichkeit, den Apache selbst zu konfigurieren? Wenn ja: das error_log kannst Du prinzipiell hinlegen, wohin Du möchtest. Und auch die Speicherverwendung pro Prozess kann in der httpd.conf angegeben werden (RLimitMem) übrigens genauso wie RLimitCPU und RLimitNPROC solche Ressourcenbeschränkungen definieren.

Ansonsten: hinterfragen ob der Hoster (noch) der richtige/zeitgemäße ist. Ich hoste z.B. bei Strato und da kann ich mit meinem Apache machen, was ich will.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 07.09.2018 - 18:30 Uhr

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18560
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #3 am: 24 August 2013, 16:33:47 »
> Hast Du die Möglichkeit, den Apache selbst zu konfigurieren?

Natuerlich nicht (bzw. nicht das ich wuesste), sonst wuerde ich nicht anfangen zu betteln.
Vermutlich haette man mir das aber auch in den Antworten gezeigt.


> hinterfragen ob der Hoster (noch) der richtige/zeitgemäße ist

Hab vergessen zu sagen: diese Loesung wollte ich nicht hoeren :)


Habs jetzt "offline" geloest: das Ergebnis wird ab sofort einmal am Tag um 7:45 beim fhemupdate auf meinem lokalen Server erstellt, und als statistics.html hochgeladen. Hab die Links auf fhem.de auch schon umgestellt. Wenn jemand Lust hat das Problem "richtig" zu fixen, dann bin ich dankbar :)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 18560
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #4 am: 24 August 2013, 16:40:15 »
Apropos statistics.cgi:
ich moechte hiermit Techendorf in AT zum absoluten FHEM-Hochburg kueren:
27 Installationen auf 766 Einwohner, das ist weltweite Spitze :)

Ich sehe gerade: der Farb-Streifen ist unter FF weg, unter Chrome/Safari schwarz.
Hat jemand eine Idee wieso?

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #5 am: 10 September 2013, 14:33:09 »
Moin Rudi,
Die Statistiken gehen seit einigen Tagen nicht mehr.
Zitat
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Gruß Joachim
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17747
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #6 am: 10 September 2013, 14:50:32 »
siehe etwas weiter oben:
Zitat
Habs jetzt "offline" geloest: das Ergebnis wird ab sofort einmal am Tag um 7:45 beim fhemupdate auf meinem lokalen Server erstellt, und als statistics.html hochgeladen. Hab die Links auf fhem.de auch schon umgestellt. Wenn jemand Lust hat das Problem "richtig" zu fixen, dann bin ich dankbar :)
gruss
  andre
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #7 am: 10 September 2013, 16:51:02 »
Moin Andre,
das hatte ich gelesen, und gedacht, dass mit
Zitat
Hab die Links auf fhem.de auch schon umgestellt.

gemeint ist, dass die Links funktionieren.

Im Forum ist immer noch falsch verlinkt.
http://fhem.de/stats/statistics.cgi
statt
http://fhem.de/stats/statistics.html

gruß Joachim
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17747
Aw: Die Statistiken funktionieren nicht mehr
« Antwort #8 am: 10 September 2013, 16:53:12 »
achso :) ich glaube damit war aber der link auf der fhem.de seite direkt gemeint. nicht auf die fhem.de seite.

gruss
  andre
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

 

decade-submarginal