FHEM - Hausautomations-Systeme > InterTechno

CUL868 - Ohne FHEM Daten empfangen

(1/2) > >>

piro299:
Schönen guten Abend,

ich bin seit heute stolzer Besitzer eines CUL868.

Ich würde gerne die vorhanden Sensoren (2 x Temperatur & Luftfeuchte von Hama für 2 Stationen)  und deren Daten in meinem Haus empfangen ohne FHEM zu verwenden. Erstmal noch nicht.

Würde gerne wissen, wie es generell funktioniert und wie man mit dem CUL868 so was macht. Die Seite http://culfw.de/culfw.html zeigt schon vieles aber ich verstehe es noch nicht, da ich völliger Anfänger bin. Mit welchem Kommando kann ich Daten empfangen?

Mit dem Befehl
--- Code: ---screen /dev/ttyACM0
--- Ende Code ---
und dann
--- Code: ---V
--- Ende Code ---
kann ich mir die Version anzeigen lassen.

Verwendet wird der CUL868 an einem Raspberry PI.

Danke im Voraus für Hinweise Tutorials oder sogar Codebeispiele.

fiedel:
Gib mal X21 in deine Konsole (screen) ein! Das ist das, was du suchst. Da kommen dann alle SlowRF Funktelegramme rein. Weiter musst du dann eine Applikation selbst programmieren, die etwas mit den Daten anfängt.

piro299:
Danke. Das mit dem X hatte ich auch schon versucht. Hatte nur nicht gewartet
bis etwas kam.

Eins ist mir aber immer noch nicht klar. Wie kann ich denn X21 ohne screen z.B. im Shell Script oder Python verwenden? Was müsste ich starten ohne screen zu verwenden.

Danke für die Hilfe.
Sven

fiedel:
Das ist dann "einfache" Kommunikation mit der seriellen Schnittstelle. Wie es genau geht (Syntax), müsste ich auch erst ergoogeln. ;o)

FHEM macht es (vereinfacht) so: Bei Systemstart wird ein "V" an die Schnittstelle gesendet und gewartet, ob die Versionsnummer in einer bestimmten Form zurückkommt. Wenn nicht -> Zeitüberschreitung, CUL nicht initialisiert. Wenn ja -> CUL initialisiert -> schicke "X21" an  die Schnittstelle und warte auf Daten...

Gruß

Frank

piro299:
Sorry aber nach 1 Stunde suchen und probieren, bekomme ich es nicht hin Daten an die Schnittstelle zu senden.

Folgendes habe ich versucht:

--- Code: ---
echo "V" > /dev/ttyACM0

--- Ende Code ---

Leider kam nichts zurück.

Bräuchte da doch noch ein paar mehr Hilfestellungen.

Danke im Voraus.

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln