Autor Thema: CULflash CUL_0 CUL_V3 klappt nicht  (Gelesen 14473 mal)

Offline ChrisW

  • Hero Member
  • *****
  • Beiträge: 1680
CULflash CUL_0 CUL_V3 klappt nicht
« am: 22 Oktober 2013, 18:57:57 »
Hmmm Versuche mein CUL mit der neusten version zu flashen aber leider klappt es über FHEM nicht so..
Meien Nachricht nach eingabe von : CULflash CUL_0 CUL_V3
dfu-programmer: no device present.


Klar weil CUL_0 auf einmal Status: disconnected

Das ist erst passiert als ich dfu-programmer bzw 1. Culflash ausgeführt habe :(

Derzeitige Version:
V 1.49 CUL433


Muss dann einen raspberry reboot machen dann ist CUL wieder da ... aber culflash klappt noch immer nicht jemand eine idee?

LOG:
2013.10.22 19:24:00 1: CULflash (dfu-programmer atmega32u4 erase && dfu-programmer atmega32u4 flash ./FHEM/CUL_V3.hex && dfu-programmer atmega32u4 start) 2>&1
2013.10.22 19:24:00 1: CULflash dfu-programmer: no device present.


EDIT: Es liegt wieder daran das fhem keien root rechte hat !!
Da shab ich gefunden: Zum flashen muss man Root-Rechte besitzen, andernfalls erhält man ein dfu-programmer: no device present.
« Letzte Änderung: 22 Oktober 2013, 20:26:36 von ChrisW »
Raspberry PI3 mit allem möglichen.

Offline cotecmania

  • Full Member
  • ***
  • Beiträge: 489
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #1 am: 16 Dezember 2013, 21:55:23 »
Wie setze ich die ROOT-Rechte ?
FHEM auf RaspberryPI B (jessie)
2xCUL868 für MAX/Slow_RF, HM-LAN, JeeLink
MAX!/HM-Thermostate, FS20/HM-Rolladenschalter, FS20-EM, LevelJet-Ölstandsmessung, PCA301, IT, KM271, IPCAM, ACER Iconia One mit AMAD/FTUI

Offline Stephan

  • Full Member
  • ***
  • Beiträge: 151
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #2 am: 26 Dezember 2013, 05:24:16 »
Bei mir klappt es auch nicht.
Gruß
Stephan

fhem 5.5, Raspi B, CUL V3 868 (max), Arduino Uno R3 conf.firmata v2.05

Offline Joachim

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1460
FHEM aktuellste Version auf FB 7570 und 7390 mit Zebradem Toolbox Freetz
FHEM auf Raspberry
1-Wire mit LinkUSBi und Rs-Pi ds2482-800  1-Wire-9 Board; Max mit Cube, HMLAN
div. 1-Wire Sensoren; MAX-Thermostaten; Homematic-Komponenten, Zehnder KWL über RS-232

Offline stgeran

  • Sr. Member
  • ****
  • Beiträge: 964
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #4 am: 30 Dezember 2013, 22:37:30 »
Ich glaube, es geht darum einen funktionierenden CUL V 1.xx am Raspi auf die aktuelle Version zu flashen. Sozusagen ein Update. Alle Beschreibungen gehen, soweit ich das sehe, von einem "fabrikneuen" CUL aus.
FHEM auf Raspberry
CSM 866MHz für EM1010 mit Strom und Gaszähler
CUL 866MHz für MAX! Radiator Thermostat 
CUL 433MHz für Innen und Aussen Temp
HMLAN für HM-LC-Sw1-PI-2

Offline furban

  • Full Member
  • ***
  • Beiträge: 100
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #5 am: 04 Oktober 2014, 20:16:13 »
Mal so als Doku auch für mich weil ich gerade auch vor dem Problem stand mein CUL am RaspberryPI flashen zu wollen:

Da FHEM als User fhem läuft und diesem USer die passenden Rechte fehlen startet man es einfach einmal als root
/etc/init.de/fhem stop
User fhem in der /etc/passwd einfach umbenennen
/etc/init.de/fhem start
schon läuft FHEM als root
telnet localhost 7072
CULflash CUL1 CUL_V3
Dann wieder den FEM User in der /etc/passwd zurück benennen und FHEM neu starten.
Fertig.

Offline Puschel74

  • Hero Member
  • *****
  • Beiträge: 9793
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #6 am: 04 Oktober 2014, 20:27:04 »
Zotac BI323 als Server mit DBLog
CUNO für FHT80B, 3 HM-Lan per vCCU, RasPi mit CUL433 für Somfy-Rollo (F2F), RasPi mit I2C(LM75) (F2F), RasPi für Panstamp+Vegetronix +SONOS(F2F)
Ich beantworte keine Supportanfragen per PM! Bitte im Forum suchen oder einen Beitrag erstellen.

Offline Topgun

  • New Member
  • *
  • Beiträge: 30
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #7 am: 30 November 2014, 01:14:00 »
Hallo,

ich habe jetzt 3h lang versucht meinen CUL V3 (433 Mhz) zu flashen, aber jetzt muss ich doch mal fragen  :(.

Beim Start vom FHEM kommt: "CULflash dfu-programmer: no device present.", da es nicht mit root-Rechten läuft.
Also habe ich auf dem Raspberry Pi das Programm dfu-programmer installiert.

Vor dem anstecken des CULs den "Programmier-Knopf" gedrückt und gehalten.
dmesg zeigt:
usb 1-1.4: new full-speed USB device number 5 using dwc_otg
usb 1-1.4: New USB device found, idVendor=03eb, idProduct=2ff4
usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.4: Product: ATm32U4DFU
usb 1-1.4: Manufacturer: ATMEL
usb 1-1.4: SerialNumber: 1.0.0

Danach:
pi@raspbmc:/opt/fhem/FHEM/firmware$ sudo dfu-programmer atmega32u4 erase
Checking memory from 0x0 to 0x6FFF...  Empty.
Chip already blank, to force erase use --force.
pi@raspbmc:/opt/fhem/FHEM/firmware$ sudo dfu-programmer atmega32u4 flash CUL_V3.hex

Und jetzt hängt das Programm. Nach 15 Minuten habe ich es abgebrochen. CPU-Last um die 80% und ein strace -p <PID> zeigt nichts.

Kann es sein, dass der CUL defekt ist, oder habe ich etwas übersehen?


Update:
Da ich den CUL an der Fritzbox 7390 flashen konnte, konnte ich einen Defekt des CUL ausschließen.
Anschließend habe ich auf dem Pi das Programm dfu-programmer noch mal neu kompiliert und siehe da ... es geht.

Ob das jetzt an einem Initialen flashen über die Fritzbox oder an ein "falsch" kompiliertem dfu-programmer lag, kann ich jetzt leider nicht mehr nachvollziehen.
« Letzte Änderung: 30 November 2014, 08:41:55 von Topgun »

Offline Flatede

  • Newbie
  • Beiträge: 1
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #8 am: 20 Dezember 2017, 19:16:26 »

Da FHEM als User fhem läuft und diesem USer die passenden Rechte fehlen startet man es einfach einmal als root
/etc/init.de/fhem stop
User fhem in der /etc/passwd einfach umbenennen
/etc/init.de/fhem start
schon läuft FHEM als root
telnet localhost 7072
CULflash CUL1 CUL_V3
Dann wieder den FEM User in der /etc/passwd zurück benennen und FHEM neu starten.
Fertig.

User fhem in der /etc/passwd einfach umbenennen???
OK, ist wahrscheinlich ne blöde Frage, aber ich bin Newbie bei Linux.
Soweit habe ich die Datei mit Nano geöffnet.
Jetzt steht da in einer Zeile
fhem:x:999:20::/opt/fhem:/bin/false
Was soll ich da jetzt ändern, das der User umbenannt ist?
Ich steh auf dem Schlauch.

Gruß
Flatede

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #9 am: 20 Dezember 2017, 21:38:19 »
Hi, ist auch eine komische Anleitung, aber Du könntest
Versuchen fhem in test zu ändern und dann findet der service keinen user mehr und startet als root.
Aber ich würde eher
cd /opt/fhem
sudo perl fhem.pl fhem.cfg
benutzen.
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 9907
    • Otto's Technik Blog
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #10 am: 20 Dezember 2017, 21:45:27 »
Hi,

CUL Stick flashen geht nativ in FHEM. Warum schaut man da in 3 Jahre alte Anleitungen?

https://heinz-otto.blogspot.de/2016/02/cul-stick-flashen.html

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,ET9200,Arduino nano,ESP8266

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #11 am: 04 Februar 2018, 22:25:13 »
Hallo,
die Beschreibung in dem Blog hat mir direkt geholfen mein busware auf die letze Version zu flashen (V1.67). Aber ich möchte diesen Busware auf die alternative Version flashen...da suche ich noch vergebens wie das funktioniert. Ich hatte es probiert mit dem blog Beitrag: http://www.meintechblog.de/2017/10/low-cost-smart-home-super-guenstige-funk-bewegungsmelder-von-smartwares-mit-fhem-nutzen/
Ich bekomme aber da noch den fehler: dfu-programmer: no device present.

Wie gesagt, beim normalen Flashen (CULflash CUL_0 CUL_V3 ) ist der Busware direkt auf 1.67 geflashed worden....da hat dfu_programmer funktioniert.

danke fuer die Hilfe.
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #12 am: 04 Februar 2018, 22:44:33 »
Hi,
die Suche im Forum hilft bestimmt, aber hier mal der Versuch einer Anleitung:

Wichtig: Den Busware CUL immer mit gedrückter Taste einstecken oder mit dem folgenden Befehl in FHEM in den Flashmodus bringen:
set CUL raw B01

Hier mal die kurze Fassung mit der aktuellen a-culfw (Der Link ändert sich halt immer) auf Linux Systemen:
cd ~
sudo apt-get install wget zip avrdude avr-libc dfu-programmer
mkdir a-culfw
cd a-culfw
wget http://download1586.mediafire.com/dt4zf2h48afg/sn6k6uwpi8cq085/a-culfw_1.26.01_build_272.zip
unzip a-culfw_*.zip
cd CUL
sudo systemctl stop fhem
sudo ./flash.sh
Danach den Fragen folgen...
sudo systemctl start fhem

und hier mal die lange Version inkl. Eigenkompilierung auf Linux Systemen:
cd ~
sudo apt-get install wget zip make gcc-avr avrdude avr-libc dfu-programmer
mkdir a-culfw
cd a-culfw
wget https://github.com/heliflieger/a-culfw/archive/master.zip
unzip master.zip
cd a-culfw_*/culfw/Devices/CUL
make
sudo systemctl stop fhem
sudo ./flash.sh
Danach den Fragen folgen...
sudo systemctl start fhem
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
« Letzte Änderung: 05 Februar 2018, 23:21:20 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #13 am: 05 Februar 2018, 18:55:33 »
Hallo, und danke!
Ich bin linux unerfahren, deshalb die Frage: Ich habe zwei CULs im System (nanoCUL und Busware). Wie weis mein Ubuntu System welchen von diese beiden CULs er flashen soll? Muss ich dem System das irgendwie sagen? Alternative kann ich den den ich nicht flashen möchte heraus ziehen?

Ich habe es mit der langen Version probiert, leider der selbe Fehler. Ich habe ja erfolgreich die 1.67 Version gestern auf den Busware geflasht, also muss ja dfu-programmer funktionieren...
The device will now be flashed
Continue (y/n)?y
Flash now device
Call: dfu-programmer atmega32u4 erase
dfu-programmer: no device present.
Call: dfu-programmer atmega32u4 flash CUL_V3_433MHZ.hex
dfu-programmer: no device present.
Call: dfu-programmer atmega32u4 start
dfu-programmer: no device present.
tyrone@ubuntuserver:~/a-culfw/a-culfw-master/culfw/Devices/CUL$
« Letzte Änderung: 05 Februar 2018, 19:27:09 von zgadgeter »
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #14 am: 05 Februar 2018, 19:35:14 »
Hi,
ls -la /dev/serial/by-id/
Und dann steht da was mit busware und als letztes /dev/ttyACM0 oder ...1, /dev/ttyUSB0 oder ...1.

Den anderen rausstecken ist kein Problem, dann siehst Du nur einen ;-)

Auch möglich
dmesg -w
und dann den USB Stick raus und wieder rein. Die Zeilen die man dann sieht gehören zu dem Stick. Irgendwo sollt /dev/tty.... auftauchen.

Ja Dein dfu-programmer geht. Von ihm kommt die Fehlermeldung.
Achso Dein FHEM ist beendet? Aber steckst Du den CUL auch mit gedrückter Taste ein? Oder setzt in FHEM als letztes den Befehl
set CUL raw B01
ab (also booten des Stick im Flashmode)?

Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
« Letzte Änderung: 05 Februar 2018, 20:22:55 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #15 am: 05 Februar 2018, 20:20:11 »
Hallo, also ich stehe irgendwie auf dem Schlauch. Wenn ich das ls -la mache bekomme ich:

drwxr-xr-x 2 root root 80 Feb  5 20:11 .
drwxr-xr-x 4 root root 80 Feb  5 20:11 ..
lrwxrwxrwx 1 root root 13 Feb  5 20:11 usb-busware.de_CUL868-if00 -> ../../ttyACM0
lrwxrwxrwx 1 root root 13 Feb  5 20:11 usb-FTDI_FT232R_USB_UART_A1062BG8-if00-port0 -> ../../ttyUSB0
So weit ok.
ABer wenn ich dann den rest mache, komme ich auf 10 Auswahlmöglichkeiten (0-9), die so aussehen...danach habe ich bisher die 9 und die 4 ausgewählt, aber dann bekomme ich immer den Fehler wie oben: no device present. Wahrscheinlich mache ich was ganz einfaches falsch...
Please choose a device:
 1 = CUL_V2 868MHZ
 2 = CUL_V2_HM 868MHZ
 3 = CUL_V2_MAX 868MHZ
 4 = CUL_V3 868MHZ
 5 = CUL_V4 868MHZ
 6 = CUL_V2 433MHZ
 7 = CUL_V2_HM 433MHZ
 8 = CUL_V2_MAX 433MHZ
 9 = CUL_V3 433MHZ
 0 = CUL_V4 433MHZ
Please select device (1-5): 4
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #16 am: 05 Februar 2018, 20:25:08 »
Hi,
Hatte gerade oben noch mal ein Update gemacht.

set CUL raw B01 bzw. Taste gedrückt beim einstecken vergessen?

Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #17 am: 05 Februar 2018, 21:13:45 »
Hi,
von den 10 Auswahlmoeglichkeiten (0-9), welche sollte ich den nehmen fuer den busware?
Ich habe auch einen nanoCUL, welche option sollte ich fuer den nehmen?
Please choose a device:
 1 = CUL_V2 868MHZ
 2 = CUL_V2_HM 868MHZ
 3 = CUL_V2_MAX 868MHZ
 4 = CUL_V3 868MHZ
 5 = CUL_V4 868MHZ
 6 = CUL_V2 433MHZ
 7 = CUL_V2_HM 433MHZ
 8 = CUL_V2_MAX 433MHZ
 9 = CUL_V3 433MHZ
 0 = CUL_V4 433MHZ
Please select device (1-5): 4
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #18 am: 05 Februar 2018, 21:42:44 »
Hi,
Für den Busware war die V3 schon richtig, also 4 oder 9, je nach Freq. Was steht auf Deinem CUL V3???
Für den nanoCUL musst du in das nanoCUL Verzeichnis statt CUL gehen. Da gibt es andere Optionen bei der ./flash.sh
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #19 am: 05 Februar 2018, 22:24:48 »
Hallo,
also ich habe es endlich geschaft den Busware zu flashen! Am ende hat es nur funktioniert in dem ich den knopf gehalten habe am CUL beim einstecken. Dann hat es funktioniert.
Morgen probiere ich das auch bei dem nanoCUL...
Aber, wenn der Busware mit dem neue Flash sowieso alles kann wie der nanoCUL, brauche ich den ja nicht mehr...

Vielen Dank fuer die Hilfe!
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #20 am: 05 Februar 2018, 23:23:03 »
Hi,
schön dann den Thread bitte mit [gelöst] kennzeichnen ;-)
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #21 am: 07 Februar 2018, 22:06:04 »
Hallo, leider scheint der neue geflaschte Busware CUL doch noch nicht richtig zu funktionieren. Also ich bekomme keine IT Geräte gepaired, und das sollte mit der neuen Firmware möglich sein.
« Letzte Änderung: 07 Februar 2018, 22:35:40 von zgadgeter »
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #22 am: 08 Februar 2018, 19:31:31 »
Okay:
set cul raw e
Dann abziehen und wieder dran
get cul ccconf
get cul version
get cul cmds
Und dann hier das
list cul
In code tags posten
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4171
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #23 am: 08 Februar 2018, 21:30:42 »
In code tags posten
Das würde dann in etwa so aussehen  8) 8) 8)

Okay:
set cul raw e
Dann abziehen und wieder dran
get cul ccconfget cul version get cul cmdsUnd dann hier das
list cul
Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #24 am: 08 Februar 2018, 22:08:38 »
Okay:
set cul raw e
Dann abziehen und wieder dran
get cul ccconf
get cul version
get cul cmds
Und dann hier das
list cul
In code tags posten
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Hallo, sorry ich habe dein post erst jetzt gesehen. Ich mache das morgen und poste dann ...danke für die Hilfe schon Mal.

Sent from my SM-N950F using Tapatalk

NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #25 am: 10 Februar 2018, 10:18:33 »
Jetzt versteh ich garnichts mehr. Unten ist der output fuer den Busware (CUL_0) und danach den output fuer den nanoCUL. Die scheinen beide den richtigen flash bekommen zu haben.
Allerdings, wenn ich probiere den Busware (nanoCUL ist nicht im USB port) mit einem 433Hz Bewegungsmelder zu pairen funktioniert das nicht. Der Busware sieht das geraet nicht.
Wenn ich das gleiche probiere mit dem nanoCUL (Busware ist nicht im USB port), findet der den Bewegungsmelder. Nur, und das ist komisch, findet er 4 Geraete, alle Bewegungsmelder, alle unterschiedliche Namen, und alle geraete reagieren wenn ich vor dem einem Bewegungsmelder bin, bzw. Bewegung habe. Noch stranger: diese 4 Geraete sind alle gepaired mit dem CUL_0, also dem Busware, der gerade garnicht im usb angeschlossen ist. Ich habe das ganze schon zweimal durchgespielt: Gepaired Gereaete geloscht, Busware aus dem USB port, nanoCUL rein, FHEM neugestartet, Geraete (Bewegungsmelder) wird erkannt und an den CUL0 als IO geraet.
Komisch....

Ok, hier ist der output fuer den Busware CUL
get CUL_0 ccconf
CUL_0 ccconf => freq:868.300MHz bWidth:325KHz rAmpl:42dB sens:4dBget cul version
CUL_0 version => V 1.26.01 a-culfw Build: private build (unknown) CUL868 (F-Band: 868MHz)get cul cmds
CUL_0 cmds =>  A B C E e F G h i K k L l M m R T t U u V W X x Ylist cul
Internals:
   CMDS       ABCEeFGhiKkLlMmRTtUuVWXxY
   Clients    :FS20:FHT.*:KS300:USF1000:BS:HMS: :CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN: :ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY: :STACKABLE_CC:TSSTACKED:STACKABLE:CUL_RFR::CUL_TCM97001:CUL_REDIRECT:
   DEF        /dev/ttyACM0@9600 1034
   DeviceName /dev/ttyACM0@9600
   FD         32
   FHTID      1034
   NAME       CUL_0
   NR         234
   PARTIAL   
   STATE      Initialized
   TYPE       CUL
   VERSION    V 1.26.01 a-culfw Build: private build (unknown) CUL868 (F-Band: 868MHz)
   initString X21
   MatchList:
     1:USF1000  ^81..(04|0c)..0101a001a5ceaa00....
     2:BS       ^81..(04|0c)..0101a001a5cf
     3:FS20     ^81..(04|0c)..0101a001
     4:FHT      ^81..(04|09|0d)..(0909a001|83098301|c409c401)..
     5:KS300    ^810d04..4027a001
     6:CUL_WS   ^K.....
     7:CUL_EM   ^E0.................$
     8:HMS      ^810e04......a001
     9:CUL_FHTTK ^T[A-F0-9]{8}
     A:CUL_RFR  ^[0-9A-F]{4}U.
     B:CUL_HOERMANN ^R..........
     C:ESA2000  ^S................................$
     D:CUL_IR   ^I............
     E:CUL_TX   ^TX[A-F0-9]{10}
     F:Revolt   ^r......................$
     G:IT       ^i......
     H:STACKABLE_CC ^\*
     I:UNIRoll  ^[0-9A-F]{5}(B|D|E)
     J:SOMFY    ^Y[r|t|s]:?[A-F0-9]+
     K:CUL_TCM97001 ^s[A-F0-9]+
     L:CUL_REDIRECT ^o+
     M:TSSTACKED ^\*
     N:STACKABLE ^\*
   READINGS:
     2018-02-10 09:55:32   ccconf          freq:868.300MHz bWidth:325KHz rAmpl:42dB sens:4dB
     2018-02-10 09:57:20   cmds             A B C E e F G h i K k L l M m R T t U u V W X x Y
     2018-02-05 21:16:29   credit10ms      900
     2018-02-05 21:16:17   fhtbuf          AE
     2018-02-09 22:30:01   raw             is0F00F00F0FF0
     2018-02-10 09:54:48   state           Initialized
     2018-02-05 21:16:02   uptime          0 01:04:47
     2018-02-10 09:56:54   version         V 1.26.01 a-culfw Build: private build (unknown) CUL868 (F-Band: 868MHz)
Attributes:
   room       System

Und hier der Output für den nanoCUL
get cul ccconf
nanoCUL ccconf => freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dBget cul version
nanoCUL version => V 1.26.01 a-culfw Build: private build (unknown) nanoCUL433 (F-Band: 433MHz)get cul cmds
nanoCUL cmds =>  A B C e F f G i K L l M N R T t U V W X xlist cul
Internals:
   CMDS       ABCeFfGiKLlMNRTtUVWXx
   Clients    :FS20:FHT.*:KS300:USF1000:BS:HMS: :CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN: :ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY: :STACKABLE_CC:TSSTACKED:STACKABLE:CUL_RFR::CUL_TCM97001:CUL_REDIRECT:
   DEF        /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A1062BG8-if00-port0@38400 1234
   DeviceName /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A1062BG8-if00-port0@38400
   FD         29
   FHTID      1234
   NAME       nanoCUL
   NR         161
   PARTIAL   
   RAWMSG     i145114FD
   RSSI       -75.5
   STATE      Initialized
   TYPE       CUL
   VERSION    V 1.26.01 a-culfw Build: private build (unknown) nanoCUL433 (F-Band: 433MHz)
   initString X21
   nanoCUL_MSGCNT 25
   nanoCUL_TIME 2018-02-10 10:03:33
   MatchList:
     1:USF1000  ^81..(04|0c)..0101a001a5ceaa00....
     2:BS       ^81..(04|0c)..0101a001a5cf
     3:FS20     ^81..(04|0c)..0101a001
     4:FHT      ^81..(04|09|0d)..(0909a001|83098301|c409c401)..
     5:KS300    ^810d04..4027a001
     6:CUL_WS   ^K.....
     7:CUL_EM   ^E0.................$
     8:HMS      ^810e04......a001
     9:CUL_FHTTK ^T[A-F0-9]{8}
     A:CUL_RFR  ^[0-9A-F]{4}U.
     B:CUL_HOERMANN ^R..........
     C:ESA2000  ^S................................$
     D:CUL_IR   ^I............
     E:CUL_TX   ^TX[A-F0-9]{10}
     F:Revolt   ^r......................$
     G:IT       ^i......
     H:STACKABLE_CC ^\*
     I:UNIRoll  ^[0-9A-F]{5}(B|D|E)
     J:SOMFY    ^Y[r|t|s]:?[A-F0-9]+
     K:CUL_TCM97001 ^s[A-F0-9]+
     L:CUL_REDIRECT ^o+
     M:TSSTACKED ^\*
     N:STACKABLE ^\*
   READINGS:
     2018-02-10 10:03:45   ccconf          freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB
     2018-02-10 10:04:36   cmds             A B C e F f G i K L l M N R T t U V W X x
     2018-02-09 23:30:00   raw             is0F000F0F0FF0
     2018-02-10 10:03:33   state           Initialized
     2018-02-10 10:04:09   version         V 1.26.01 a-culfw Build: private build (unknown) nanoCUL433 (F-Band: 433MHz)
Attributes:
   room       System
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4171
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #26 am: 10 Februar 2018, 12:38:53 »
Allerdings, wenn ich probiere den Busware (nanoCUL ist nicht im USB port) mit einem 433Hz Bewegungsmelder zu pairen funktioniert das nicht.
Der Busware CUL ist ja auch laut list ein 868 MHz CUL, Du kannst den zwar auf 433 MHz umschalten, aber die Reichweite ist eher bescheiden.

Wenn Du einen CUL aussteckst, könnte es sein (bin mir aber nicht sicher), dass FHEM das ioDevice intern einfach umschaltet, so dass der andere die Daten empfängt.

Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #27 am: 10 Februar 2018, 13:30:19 »
Der Busware CUL ist ja auch laut list ein 868 MHz CUL, Du kannst den zwar auf 433 MHz umschalten, aber die Reichweite ist eher bescheiden.
Ja, aber in dem Artikel http://www.meintechblog.de/2017/10/low-cost-smart-home-super-guenstige-funk-bewegungsmelder-von-smartwares-mit-fhem-nutzen/ ist beschrieben das wenn man die alternative firmware flashed kann der Busware auch zusetzlich 433 empfangen.
Wenn Du einen CUL aussteckst, könnte es sein (bin mir aber nicht sicher), dass FHEM das ioDevice intern einfach umschaltet, so dass der andere die Daten empfängt.
Das wäre interessant...wer weis da mehr?
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1672
  • Es begann alles so klein ;-)
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #28 am: 10 Februar 2018, 15:19:34 »
Hi,
Also es gibt Hardware (und deren Physik) und es gibt Software (und deren Ambition).
Die Hardware eines 868MHz Sticks kann gut 868MHz und sehr bescheiden (in Abhängigkeit der Antennen) 433MHz.

Ja, deine nun aktualisierte a-culfw kann die 433MHz Protokolle entschlüsseln/verstehen, aber Deine Hardware ist trotzdem fast taub auf 433MHz! Du könntest eine andere Antenne versuchen, aber ich verstehe nicht, warum Dir der nanoCUL nicht reicht!?

Zu dem ioDev: Hier wird bei CULs immer das zuletzt in FHEM definierte Gateway des Protokolls eingetragen. Das kann man per Hand ändern (z.B. nach den besten RSSI Werten).
GrußArnd

Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline zgadgeter

  • Full Member
  • ***
  • Beiträge: 264
Antw:CULflash CUL_0 CUL_V3 klappt nicht
« Antwort #29 am: 10 Februar 2018, 19:18:48 »
aber ich verstehe nicht, warum Dir der nanoCUL nicht reicht!?
Ja, stimmt. Ich dachte nur das ich mit einem CUL auskommen könnte. Aber auch weil der nanoCUL 4 Geräte für den Bewegungsmelder angelegt hat, bzw ich weis gar nicht ob es der nanoCUL wirklich ist. Siehe screenshot. Irgendwie stehen beide Culs in den Angaben. Und, das Signal von dem Bewegungsmelder mit dem NanoCUL ist sehr träge, eigentlich nicht nutzbar um ein Licht zu steuern. Ich hatte gehofft das es mit dem Busware besser wird. Ist wohl nicht.


Zu dem ioDev: Hier wird bei CULs immer das zuletzt in FHEM definierte Gateway des Protokolls eingetragen. Das kann man per Hand ändern (z.B. nach den besten RSSI Werten).
Das versteh ich nicht ganz. Ist das was in "LASTInputDev" steht?
NUC FHEM mit vielen Intertechno/FS20/Flamingo schalter
und Busware CUL und nanoCUL